Live Earth unable to connect to server

Bug #1715677 reported by Diego
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Wallch
Undecided
Unassigned

Bug Description

Hi! I use Wallch in Live Earth mode. A couple of days ago I noticed that that the desktop wasn't changing, so I switched to Wallpapers mode and switched back to Live Earth, getting this Internet Connection error message: "There was a problem while trying to download what you requested. Please check your internet connection".
So then I tried to switch to Picture Of The Day and get the same message, but when I switch to Live Website (www.google.com) it works perfectly!
My internet connection is working fine and I connected in several other connections getting the same result.
So... My guesses are that something is broken with the app or the servers are not working.

Pd.: I just got a crash while switching from Live Website to Wallpapers
I leave you the error information from this crash below

ExecutablePath
  /usr/bin/wallch
Package
  wallch 4.0-0Ubuntu4
ProblemType
  Crash
Title
  wallch crashed with SIGFPE
ApportVersion
  2.20.1-0ubuntu2.10
Architecture
  amd64
CoreDump
CurrentDesktop
  Unity
Date
  Thu Sep 7 12:04:21 2017
Dependencies
Disassembly
DistroRelease
  Ubuntu 16.04
InstallationDate
  Installed on 2017-06-02 (96 days ago)
InstallationMedia
  Ubuntu 14.04.4 LTS "Trusty Tahr" - Release amd64 (20160217.1)
JournalErrors
NonfreeKernelModules
  wl
PackageArchitecture
  amd64
ProcCmdline
  /usr/bin/wallch-start
ProcCpuinfoMinimal
ProcEnviron
ProcMaps
ProcStatus
ProcVersionSignature
  Ubuntu 4.4.0-93.116-generic 4.4.79
Registers
Signal
  8
SourcePackage
Stacktrace
StacktraceAddressSignature
  /usr/bin/wallch:8:/usr/bin/wallch+58897:/usr/bin/wallch+58c:/...
StacktraceTop
Tags
  xenial
ThreadStacktrace
Uname
  Linux 4.4.0-93-generic x86_64
UserGroups
  adm cdrom dip lpadmin plugdev sambashare sudo

Revision history for this message
Jonathan Drapeau (dranon) wrote :

Getting the same error on mint 18.1 since about a week or so.

Revision history for this message
Diego (diego-luna-1711) wrote :

Update:

I superseded the issue by using "Live Website" mode with the URL that wallch uses to serve the Live Earth wallpaper:
                 http://static.die.net/earth/mercator/1600.jpg

I hope that it works for you too!

Revision history for this message
dwreck420 (dwreck420) wrote :

thanks for the link! i had figured out the site but couldnt find a link for just the image itself!!!

Revision history for this message
dwreck420 (dwreck420) wrote :

site also quit working for me recently, same connection error, no real reason, must be server side

Revision history for this message
VirtualThai (enghishman) wrote :

Same "strange" connetion error here...
Live Website with 1600.jpg picture works fine in my Elementary OS!
Thanks!

Revision history for this message
akbagchi@gmail.com (akbagchi) wrote :

@ Diego

I experienced the same problem of image not getting displayed in Live Earth. Also, not in Wallpaper mode. My system now is on Ubuntu 16.04.3 LTS. I use a 100 Mbps internet connection.

I tried several ways with the hope to make it working again, but none worked. I even reinstalled Wallch 4.187-1~218~xenia, but to no avail.

Just now I came to read your post. I tried as suggested. It worked. But I have to wait to see if the picture changes after 20 minutes.

Thanks for the suggestion. Let me wait and see.

Best wishes :-)

Revision history for this message
akbagchi@gmail.com (akbagchi) wrote :

@ Diego Thank you very much for your suggestion to make the Wallch working from a different way than it is prescribed inside the apps.

It worked perfectly in the very first instance. I was waiting to note the auto-change of the 'Live Earth' features. This too is working fine.

Thanks a lot again. Best wishes. :-)

Revision history for this message
Diego (diego-luna-1711) wrote :

I came here looking for help but instead I became a helper. I'm glad that it worked for @akbagchi and for @Mauro Inglese.

@dwreck420 Live Website mode isn't working either for you?

Revision history for this message
VirtualThai (enghishman) wrote :

Hi guys!
Live Earth does not work after application re-install...
Live Website need to be re-activated to work... each time system boots up!!!
WHY Live Earth give this problem? It was so lovely!!!!
Please solve this!!!!

Revision history for this message
Lolwhites (lolwhites) wrote :

I tried Diego's workaround but it places the image in the top left hand corner and leaves white space along the bottom and right edges. No amount of playing with the seeetings will make it fill the screen like before. This worked fine in 17.04 but not 17.10.

Revision history for this message
Diego (diego-luna-1711) wrote :

@Lolwhites: Did you try to crop the image with the Crop Tool??

Revision history for this message
Diego (diego-luna-1711) wrote :

@VirtualThai: Try to extend the startup timeout in preferences!

Revision history for this message
Lolwhites (lolwhites) wrote :

@Diego that worked, thanks!

Revision history for this message
iesmenceybencomo (iesmenceybencomo) wrote :

Try

sudo add-apt-repository ppa:peterlevi/ppa
sudo apt-get update
sudo apt-get install variety

and choose in preferences World Sunlight Map

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions