in WadlConsole when -i , -o and -n is not provided , the error message is really unhelpful

Bug #646389 reported by Manish Sinha (मनीष सिन्हा) on 2010-09-23
This bug affects 1 person
Affects Status Importance Assigned to Milestone
WADL Sharp
Status tracked in 0.2
Manish Sinha (मनीष सिन्हा)

Bug Description

I pretended to be a first timer using wadl# and wadl-sharp utility

I tried running ./wadl-sharp and was greeted with
wadl-sharp: There is one or more failed validations.
Try `wadl-sharp --help' for more information.

I tried wadl-sharp --help and got many options. All options are not necessary. So instead of "wadl-sharp: There is one or more failed validations." the utility should tell which mandatory option is missing.

Like, when I use
./wadl-sharp -i file.xml

The error message I should get something like this
Output file is not specified. Please use the -o option
Namespace is not specified. Please use the -n option

Related branches

Not changing the status as Manuel needs to have a look at this bug first.

Changed in wadlsharp:
importance: Undecided → Low
milestone: none → 0.2.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers