Redundancy in names should be avoided when possible

Bug #641441 reported by Manuel de la Peña on 2010-09-17
This bug affects 1 person
Affects Status Importance Assigned to Milestone
WADL Sharp
Manuel de la Peña

Bug Description

It is normal practice in wadl that the name of a method uses the name of the app, For example:

 <wadl:resource_type id="captchas">

      <wadl:method name="GET" id="captchas-get">

As it can be seen in the generated code, the name of the method is CaptchasGet which clearly is not nice. This kind of redundancy should be removed.

Related branches

Manuel de la Peña (mandel) wrote :
Manuel de la Peña (mandel) wrote :
Changed in wadlsharp:
milestone: none → 0.2
Changed in wadlsharp:
assignee: nobody → Manuel de la Pena (mandel)
importance: Undecided → Medium
status: New → In Progress
Changed in wadlsharp:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers