Gnome Virtual Terminal Emulator

bad file descriptor on .deb install

Reported by teepfluecker on 2009-06-18
140
This bug affects 27 people
Affects Status Importance Assigned to Milestone
Gnome Virtual Terminal Emulator
New
Unknown
vte (Ubuntu)
Undecided
Michael Vogt

Bug Description

If i try to install a .deb file with Package Installer the installation stops with:

dpkg: Kann Dateideskriptorflags für "<Dateideskriptor für Paketstatus und Fortschritt>" nicht lesen: Bad file descriptor.

translated to english (i hope its correct [corrected]):

dpkg: unable to read filedescriptor flags for <package status and progress file descriptor>: Bad file descriptor

I tried several .deb files. Always the same error.

This only happes when using the graphical gdebi-gtk application

i use:

Description: Ubuntu karmic (development branch) Release: 9.10

I attached one of the .deb files (Epson V10 scanner driver. Maybe only my system is affected.

BR Marco

teepfluecker (marco-boehrs) wrote :
EclipseAgent (ben-kevan) wrote :

I was getting the same error..

I just did an update that seemed to fix it.

Philip Muškovac (yofel) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
Can you please attach a complete terminal log of your installation attempt?
(To set the terminal output to english first type 'export LANGUAGE=C' - assuming that you're using bash)

Changed in ubuntu:
status: New → Incomplete
description: updated
teepfluecker (marco-boehrs) wrote :

I tried to install a .deb in terminal to get a log. If i run the installation in terminal it works. So the error only occurs in a gui installation. I attached a terminal log of the working installation and a screenshot showing the error in gui mode.

teepfluecker (marco-boehrs) wrote :
Sergey Sedov (serg-sedov) wrote :

I have this problem too.

P.S. Ubuntu karmic

Sergey Sedov (serg-sedov) wrote :

>>>> I tried to install a .deb in terminal to get a log. If i run the installation in terminal it works.
+1
Yes, It works successfully only in terminal.

Ubuntu karmic (development branch)
GNOME 2.27.3 (Ubuntu 2009-06-16)
Linux 2.6.30-9-generic
i686

Philip Muškovac (yofel) wrote :

Hm, no Idea what's exactly broken here, but It only happens when using gdebi-gtk...

affects: ubuntu → gdebi (Ubuntu)
Changed in gdebi (Ubuntu):
status: Incomplete → Confirmed
description: updated
description: updated
Nicolò Chieffo (yelo3) wrote :

Yes, also for me gdebi-gtk does not work, but gdebi does (with all packages I want to install, I've tried 5-6 different ones)

I have the same problem: gdebi-gtk returns the following error when attempting to install a package:

dpkg: unable to read filedescriptor flags for <package status and progress file descriptor>: Bad file descriptor

My console output:

richardwolfvi@richardwolf:~$ LANG="en_US.UTF-8" sudo gdebi-gtk '/home/richardwolfvi/.opera/temporary_downloads/wizardpen_0.7.0-alpha2_i386.deb'
/usr/lib/python2.6/dist-packages/GDebi/DebPackage.py:305: DeprecationWarning: Accessed deprecated property Package.installedVersion, please see the Version class for alternatives.
  cachever = self._cache[pkgname].installedVersion
/usr/lib/python2.6/dist-packages/GDebi/DebPackage.py:264: DeprecationWarning: Accessed deprecated property Package.installedDependencies, please see the Version class for alternatives.
  for dep_or in pkg.installedDependencies:
/usr/lib/python2.6/dist-packages/GDebi/DebPackage.py:73: DeprecationWarning: Accessed deprecated property Package.installedVersion, please see the Version class for alternatives.
  instver = inst.installedVersion
/usr/lib/python2.6/dist-packages/GDebi/DebPackage.py:307: DeprecationWarning: Accessed deprecated property Package.candidateVersion, please see the Version class for alternatives.
  cachever = self._cache[pkgname].candidateVersion

Using gdebi on the console or dpkg -i seems to work without issues.

I get the same error, only with gdebi-gtk. With console version everything is fine.

Jon Arnold (jonarnoldsemail) wrote :

Comparing gdebi-gtk with gdebi I get the following console output running the graphical version but not when I run gdebi:
/usr/lib/python2.6/dist-packages/GDebi/DebPackage.py:417: DeprecationWarning: Accessed deprecated property Package.candidateOrigin, please see the Version class for alternatives.
  for origin in pkg.candidateOrigin:

There are two other errors that occur in both:
/usr/lib/python2.6/dist-packages/GDebi/DebPackage.py:264: DeprecationWarning: Accessed deprecated property Package.installedDependencies, please see the Version class for alternatives.
  for dep_or in pkg.installedDependencies:
Reading state information: Done
/usr/lib/python2.6/dist-packages/GDebi/DebPackage.py:73: DeprecationWarning: Accessed deprecated property Package.installedVersion, please see the Version class for alternatives.
  instver = inst.installedVersion

Perhaps the one on line 417 is the problem with the graphical version?

Kamikaze321 (d-gun) wrote :

I have the same problem

Ben (ben2talk) wrote :

Same here trying to install Virtualbox 3.0, and several other packages - I'm sure this worked after the CD install, but after a few updates it's borked.
sudo gdebi works nicely though.

Michael Vogt (mvo) wrote :

It turns out that this is a problem with the latest vte

affects: gdebi (Ubuntu) → vte (Ubuntu)
Changed in vte (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vte - 1:0.20.5-1ubuntu2

---------------
vte (1:0.20.5-1ubuntu2) karmic; urgency=low

  * debian/patches/30_fix_env.patch:
    - make the envv paramter work again (LP: #388953)

 -- Michael Vogt <email address hidden> Mon, 06 Jul 2009 14:03:47 +0200

Changed in vte (Ubuntu):
status: Fix Committed → Fix Released
Changed in vte:
status: Unknown → New
Feistybird (bryanjen-tw) wrote :

I still have the same problem (bad file descriptor on gui .deb install) with my ubuntu 9.04 jaunty

tried with the following versions of python-vte packages, but none of them solves the gdebi problems:

python-vte
1:0.20.1-1.im (jaunty's most recent version)
1:0.20.0-0ubuntu2 (jaunty's previous version)
1:0.17.4-0ubuntu1 (intrepid's version)

James Lewis (james-fsck) wrote :

Seen this on a freshly booted, freshly updated, clean install of 9.10 Alpha6... infact I accidentally captured a video of it happening incase it's of interest to anyone:-

http://www.fsck.co.uk/Skype910.ogv

ledenjes (jpa-rijks) wrote :

I have the same problem.

output of "lsb_release -a":

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu karmic (development branch)
Release: 9.10
Codename: karmic

I have Alpha 6, which I installed cleanly (DVD version; I overburned my DVD) after removing Ubuntu Jaunty Jackalope. Installing the .deb in the gnome-terminal worked, though (through "dpkg -i <package name>").

KammutierSpule (mrluzeiro) wrote :

Xubuntu, 9.10 karmic with last updates...

same problem here when installing last version of Opera browser...
... also.. after give the GUI error.. i cannot close the gui window anymore... dont know if its related.. or is another bug..

Jonathan Lumb (jonolumb) wrote :

Same problem here - I have had this issue over the last few days on Ubuntu Karmic Alpha 6.

Whenever I double click on a *.deb file on the desktop and try and install, I get the below error (but in Chinese, not english)

dpkg: 在<包状态和进度文件描述符> 时,无法读取文件描述符的标志位: 错误的文件描述符
dpkg: unable to read filedescriptor flags for <package status and progress file descriptor>: Bad file descriptor

Let me know if there is anything I can do to help get this fixed, in the meantime, to install individual DEB files I am using the following command:

sudo dpkg -i my-file.deb

This seems to work fine as a temporary workaround.

Just to confirm it is a bug of the GUI only. Bashing it with
> sudo dpkg -i nautilus-dropbox_0.6.1_i386_ubuntu_9.04.deb
just worked.

Philip Muškovac (yofel) wrote :

Confrimed that it happens again in karmic with gdebi-gtk.
Installed vte: 1:0.22.0-0ubuntu1

Changed in vte (Ubuntu):
status: Fix Released → Confirmed
Rajeev Nair (rajeev) wrote :

Happening on the latest daily build of karmic 25 September trying to install th packge skype 64 bit.

Juan Manuel (lukather35) wrote :

In my pc the same problem occurs.

My version of Karmic Koala is in Spanish. When I install both programs, the end state that is not possible. At the terminal I get the following text, but in Spanish:

   """"" Dpkg: can not read the properties of the descriptor file for package `<This progress and file descriptor> ': Invalid file descriptor """"

My version of Karmic Koala is updated daily on September 26.

The same error happens to me on two different Pc. One in the 32bit version and another with 64.
Once the installer indicates that you can complete the installation, you can not close that window unless you log off.

I can confirm this bug in karmic last update on September 27 using a HP Netbook.
Installing from terminal works fine.

I'm also experiencing this bug in Ubuntu Karmic. With latest updates.

fubarbundy (launchpad-mailtic) wrote :

Fixed in the upstream bug - can someone pull in a new version of vte or have a look at applying the patch attached to the Gnome bug please?

The patch is already committed to lp:~ubuntu-desktop/vte/ubuntu and will go into Karmic after beta. See bug 438266.

alex (1alex) wrote :

I had the same error for skype 2.1 beta in Karmic beta. Installing it using dpkg from the shell fixed it (instead of using gdebi):

$ dpkg -i skype-ubuntu-intrepid_2.1.0.47-1_amd64.deb

Dallas Wiebelhaus (wiebelhaus) wrote :

Same issue on 9.10 Fresh beta install , dkpg -i Installs perfectly.

neuromancer (neuromancer) wrote :

As reported in the original bug 438266 :
"run the update manager and install all available updates; the problem will go away".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.