Reporting difficulty with email and password

Bug #477704 reported by Kyle Saunders on 2009-11-07
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
voicecheck
Critical
Unassigned

Bug Description

After entering: "./voicecheck -e [email] -p [password]," it returns "having difficulty, check your email/password." I'm running Arch Linux with all necessary dependencies and the username and password are correct.

Revision history for this message
Anthony Hook (anthonyhook) wrote :

I can verify this is happening with all of the correct dependencies on Ubuntu 9.10 Karmic Koala.

Changed in voicecheck:
importance: Undecided → Critical
status: New → Confirmed
Revision history for this message
Anthony Hook (anthonyhook) wrote :

I am going to assume some API change is made regarding authorization.

Revision history for this message
Anthony Hook (anthonyhook) wrote :

begin line 81:
       source = xml.dom.minidom.parseString( result.getvalue() )
        json_source = source.getElementsByTagName( 'json' )[0].firstChild.data
        html_source = source.getElementsByTagName( 'html' )[0].firstChild.data
    except:
        print 'having difficulty, check your email/password.'
        sys.exit()
end line 86

Revision history for this message
exigraff (exigraff) wrote :

This seems to have resolved itself, oddly. Anyone else seeing this?

Revision history for this message
Anthony Hook (anthonyhook) wrote :

Negative, all seems okay now.

Revision history for this message
exigraff (exigraff) wrote :

Right then, marking this as invalid, but we'll watch this one ongoing. Successful authentication is sort of important. :p

Changed in voicecheck:
status: Confirmed → Invalid
Revision history for this message
Kyle Saunders (sgiath) wrote :

I'm having difficulty with this again. I'm getting the same output: "having difficulty, check your email/password." Is anyone else experiencing this again?

Revision history for this message
Anthony Hook (anthonyhook) wrote :

It is working here, but we can take a look at this

Changed in voicecheck:
status: Invalid → Confirmed
Revision history for this message
Matt Mossholder (matt-mossholder) wrote :

Not working here, either. I am getting a 403/Forbidden error, with valid credentials.

Revision history for this message
Matt Mossholder (matt-mossholder) wrote :

FYI, the script at this link does work: http://everydayscripting.blogspot.com/2009/08/python-google-voice-mass-sms-and-mass.html

Perhaps it is because voicecheck doesn't fill in the GALX value in the authentication request?

Revision history for this message
Matt Mossholder (matt-mossholder) wrote :

A little more research... some of the javascript in the gbar function returned from Google is tripping up the DOM parser. On my page, it is the && on line 18, characters 875 and 876. It is expecting them to be escaped. Not sure how to get around this w/o ripping out expat and using something like SAX or regexes...

Revision history for this message
exigraff (exigraff) wrote :

I don't remember offhand if the last fix is in included in the downloads, but voicecheck does indeed fill in galx. Still trying to duplicate the problem on this end. Not entirely sure why it's this elusive.

Changed in voicecheck:
status: Confirmed → Fix Released
Revision history for this message
Kyle Saunders (sgiath) wrote :

I just wanted to confirm that the fix is working. Works great! Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers