Python3 support?

Bug #1819111 reported by Marcin Juszkiewicz on 2019-03-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
vmtp
Undecided
Unassigned

Bug Description

I am looking into moving Kolla images to use Python 3. 'vmtp' is one of few projects that resist:

INFO:kolla.common.utils.vmtp:Collecting fluent-logger>=0.5.2 (from vmtp==2.4.9.dev9)
INFO:kolla.common.utils.vmtp: Downloading https://files.pythonhosted.org/packages/7b/bd/ca035aa263f98d0d5ca3b6ffbaa8289eac5f97e1fd07f04baa7c3e088d5d/fluent_logger-0.9.3-py2.py3-none-any.whl
INFO:kolla.common.utils.vmtp:Collecting functools32>=3.2.3 (from vmtp==2.4.9.dev9)
INFO:kolla.common.utils.vmtp: Downloading https://files.pythonhosted.org/packages/c5/60/6ac26ad05857c601308d8fb9e87fa36d0ebf889423f47c3502ef034365db/functools32-3.2.3-2.tar.gz
INFO:kolla.common.utils.vmtp: Complete output from command python setup.py egg_info:
INFO:kolla.common.utils.vmtp: This backport is for Python 2.7 only.
INFO:kolla.common.utils.vmtp:

I understand a need for functools32 on RHEL7 systems as there is no Python 3 there.

How are your plans for moving to Python 3?

Yichen Wang (yicwang) wrote :

Hi, Marcin,

Thanks a lot for your patch. As of now, we don't have any plan yet to move to Python 3 support. :(

Regards,
Yichen

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers