VM

attachment button duplicates upon enter

Bug #911903 reported by mere user
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
VM
Fix Committed
Medium
Uday Reddy

Bug Description

hi Uday,

in the past few days, when I press return to open an attachment, the attachment line duplicates instead. here is an example after doing return 3 times. let me know if I should send a specific example. best, Eli

----------------------------------------------------------------------
xDocument [Press RETURN to display]
xDocument [Press RETURN to display]
xDocument [Press RETURN to display]
xDocument [Press RETURN to display]

Revision history for this message
John Hein (xpqheqdvq4) wrote :

Is that with stock settings (no .vm or .vm.preferences)?

Can you sanitize a sample message that shows this behavior and attach it here?

What version of vm? emacs?

Revision history for this message
Uday Reddy (reddyuday) wrote : Re: [Bug 911903] [NEW] attachment button duplicates upon enter

Eli, it is possible that the revision 1324 of the trunk fixes this problem.
Please try it.

Cheers,
Uday

Changed in vm:
milestone: none → 8.2.0
assignee: nobody → Uday Reddy (reddyuday)
importance: Undecided → Medium
Revision history for this message
mere user (emacs-user) wrote : Re: [Bug 911903] Re: attachment button duplicates upon enter

indeed fixed. brilliant of you as always, thanks, Eli

On Wed, Jan 4, 2012 at 9:39 PM, Uday Reddy <email address hidden> wrote:
> Eli, it is possible that the revision 1324 of the trunk fixes this problem.
> Please try it.
>
> Cheers,
> Uday
>
>
> ** Changed in: vm
>    Milestone: None => 8.2.0
>
> ** Changed in: vm
>     Assignee: (unassigned) => Uday Reddy (reddyuday)
>
> ** Changed in: vm
>   Importance: Undecided => Medium
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/911903
>
> Title:
>  attachment button duplicates upon enter
>
> Status in VM (View Mail) for Emacs:
>  New
>
> Bug description:
>  hi Uday,
>
>  in the past few days, when I press return to open an attachment, the
>  attachment line duplicates instead.  here is an example after doing
>  return 3 times.  let me know if I should send a specific example.
>  best, Eli
>
>  ----------------------------------------------------------------------
>  xDocument                  [Press RETURN to display]
>  xDocument                  [Press RETURN to display]
>  xDocument                  [Press RETURN to display]
>  xDocument                  [Press RETURN to display]
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/vm/+bug/911903/+subscriptions

Revision history for this message
Uday Reddy (reddyuday) wrote :

Well, the "brilliance" in this case owes to John Hein, who reported it yesterday!

Revision history for this message
John Hein (xpqheqdvq4) wrote :

Well, I didn't see the duplicated lines. I understand the cause of the issue I reported (now that Uday zeroed in on the code and killed the bug), but based on that simple fix (revno 1323) I don't understand why this would cause the dup button lines in the presentation buffer.

Anyway, I'm glad it (as well as my issue) is fixed.

Revision history for this message
Uday Reddy (reddyuday) wrote :

John Hein writes:

> Well, I didn't see the duplicated lines. I understand the cause of the
> issue I reported (now that Uday zeroed in on the code and killed the
> bug), but based on that simple fix (revno 1323) I don't understand why
> this would cause the dup button lines in the presentation buffer.

I don't know why there were duplicated lines either. But what the code was
doing, before I fixed it, was to replace one button by another button. If
the old button didn't get erased properly, I guess one would see two buttons
instead.

Cheers,
Uday

Revision history for this message
Uday Reddy (reddyuday) wrote :

This bug is really a duplicate of Bug 771221, fixed in rev. 1323 of trunk.

Changed in vm:
milestone: 8.2.0 → 8.2.90a
status: New → Triaged
status: Triaged → Won't Fix
Uday Reddy (reddyuday)
Changed in vm:
milestone: 8.2.90a → 8.2.89a
Uday Reddy (reddyuday)
no longer affects: vm/8.2.x
Changed in vm:
milestone: 8.2.89a → 8.2.0b1
Revision history for this message
Uday Reddy (reddyuday) wrote :

Here is a patch that contains the fix made in rev. 1323.

Changed in vm:
status: Won't Fix → Fix Committed
Uday Reddy (reddyuday)
Changed in vm:
milestone: 8.2.2a → 8.2.1a
Uday Reddy (reddyuday)
Changed in vm:
milestone: 8.2.1a → 8.2.90a
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers