VM

assertion failure in vm-imap-synchronize

Bug #567232 reported by Uday Reddy on 2010-04-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
VM
Low
Uday Reddy

Bug Description

Doing vm-imap-synchronize in a summary buffer produced an assertion failure:

Debugger entered--Lisp error: (error "assertion failed: (eq (car vm-buffer-types) type)")
  signal(error ("assertion failed: (eq (car vm-buffer-types) type)"))
  error("assertion failed: %S" (eq (car vm-buffer-types) type))
  vm-imap-retrieve-uid-and-flags-data()
  vm-imap-synchronize(nil)
  call-interactively(vm-imap-synchronize)
  execute-extended-command(nil)
  call-interactively(execute-extended-command)

The current-buffer is the folder buffer, and folder is wanted. But vm-buffer-types had 'process at its head.

Related branches

Uday Reddy (reddyuday) on 2010-04-20
Changed in vm:
importance: Undecided → Medium
status: New → Triaged
assignee: nobody → Uday Reddy (reddyuday)
tags: added: imap
Changed in vm:
milestone: none → 8.1.1
Uday Reddy (reddyuday) wrote :

The problem is that vm-buffer-type:set has been disabled in vm-select-folder-buffer, saying "this may be problematic". This was done in revno 570. No explanation.

description: updated
Changed in vm:
milestone: 8.1.1 → 8.2.0-devo
Uday Reddy (reddyuday) on 2010-04-20
Changed in vm:
importance: Medium → Low
milestone: 8.2.0-devo → 8.1.90a
Uday Reddy (reddyuday) wrote :

Tentative fix made in revno 755. Need to watch it.

Changed in vm:
status: Triaged → In Progress
Uday Reddy (reddyuday) on 2010-04-22
Changed in vm:
status: In Progress → Incomplete
Uday Reddy (reddyuday) on 2010-05-03
Changed in vm:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers