VM

Smoothen emacs-w3m interface

Bug #515478 reported by Uday Reddy on 2010-02-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
VM
Low
Uday Reddy

Bug Description

When a html message is first viewed by emacs-w3m, there is 'jitter'. The *Messages* buffer shows Inlining text/html...

After hitting <SPC>, there is more jitter instead of scrolling forward. The *Messages* buffer shows another instance of "Inline text/html...".

All this gives a half-baked impression.

Uday Reddy (reddyuday) on 2010-02-01
Changed in vm:
status: New → Confirmed
importance: Undecided → Low
Uday Reddy (reddyuday) wrote :

The jitter is due to the variable w3m-force-redisplay, which might be unnecessarily set to t. Setting it to nil avoids the jitter.

The double decoding of MIME messages is for preview and show. Added a variable vm-mime-decode-for-show using which the double decoding can be turned off. But it is not clear if it will introduce any other problems. (This seems to have been inherited from Kyle's code.)

Changed in vm:
status: Confirmed → In Progress
Uday Reddy (reddyuday) on 2010-02-01
Changed in vm:
status: In Progress → Fix Committed
Uday Reddy (reddyuday) wrote :

fix in revno 692 of trunk.

Changed in vm:
milestone: none → 8.1.1-devo
Uday Reddy (reddyuday) on 2010-03-23
Changed in vm:
assignee: nobody → Uday Reddy (reddyuday)
Uday Reddy (reddyuday) on 2010-04-18
Changed in vm:
milestone: 8.2.0-devo → 8.1.90a
Uday Reddy (reddyuday) on 2010-04-27
Changed in vm:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers