VM

vm-imap-list-folders causes problems with gmail

Bug #1207479 reported by Uday Reddy on 2013-08-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
VM
Medium
Uday Reddy

Bug Description

M-x vm-imap-list-folders fails with IMAP error: "server said NO" when issued on a Google Mail IMAP account. It seems that VM doesn't handle the situation when an IMAP folder that contains subfolder does "not exist". From the related IMAP trace:

VM STATUS "[Gmail]/Drafts" (MESSAGES RECENT)
* STATUS "[Gmail]/Drafts" (MESSAGES 2 RECENT 0)
VM OK Success
VM STATUS "[Gmail]/All Mail" (MESSAGES RECENT)
* STATUS "[Gmail]/All Mail" (MESSAGES 11893 RECENT 0)
VM OK Success
VM STATUS "[Gmail]" (MESSAGES RECENT)
VM NO [NONEXISTENT] Invalid folder: [Gmail] (Failure)
VM LOGOUT
* BYE LOGOUT Requested

Notice that the '[Gmail]' folder is not accessible via IMAP e.g. Thunderbird shows the folder in gray. I am using VM 8.2.0b

Any ideas how to fix this?

Uday Reddy (reddyuday) wrote :

Transferred from Answers section.

Changed in vm:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Uday Reddy (reddyuday)
milestone: none → 8.2.0b1
tags: added: 8.2 imap
Uday Reddy (reddyuday) wrote :

Seems to be fixed in the trunk already.

Changed in vm:
status: Triaged → Fix Committed
Uday Reddy (reddyuday) on 2016-10-28
Changed in vm:
milestone: 8.2.2a → 8.2.1a
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers