lua services discovery error

Bug #998729 reported by Sam_ on 2012-05-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
VLC media player
New
Unknown
vlc (Ubuntu)
Medium
Unassigned

Bug Description

Reproducable.
Open vlc and then playlist.
Go to 'Internet' and click on e.g. Free Music Charts or Jamendo. (screenshot)
Result:
It won't respond nor display anything.
Playlist dialog can only be closed by 'force quit' dialog.
But this doesn't quit vlc.
Right click on the panel icon selecting quit also doesn't quit vlc. Needs to be killed by pid.

Terminal output:
~$ vlc
VLC media player 2.0.1 Twoflower (revision 2.0.1-0-gf432547)
[0x19a0d68] dbus interface: listening on dbus as: org.mpris.MediaPlayer2.vlc
[0x194b138] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[0x7ffacc3dcbd8] lua services discovery error: Error loading script /usr/lib/vlc/lua/sd/fmc.luac: lua/sd/fmc.lua:22: attempt to call global 'require' (a nil value)

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: vlc 2.0.1-4
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Sun May 13 13:16:19 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120204)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: vlc
UpgradeStatus: No upgrade log present (probably fresh install)

Sam_ (and-sam) wrote :
Rémi Denis-Courmont (rdenis) wrote :

VLC 2.0.x requires Lua 5.1.

Lua 5.2 is not fully backward compatible and broke VLC. This will be fixed in VLC 2.1.0.

Sam_ (and-sam) wrote :

Rémi, thanks for the feedback.
FWIW, just tested 2.0.3 from proposed.
This time in playlist -> Internet it let me click on all the services but froze again.
Terminal output:
~$ vlc
VLC media player 2.0.1 Twoflower (revision 2.0.1-0-gf432547)
[0x6cac18] dbus interface: listening on dbus as: org.mpris.MediaPlayer2.vlc
[0x677138] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[0x7f208440f678] lua services discovery error: Error loading script /usr/lib/vlc/lua/sd/jamendo.luac: lua/sd/jamendo.lua:24: attempt to call global 'require' (a nil value)
[0x7f2084433b58] lua services discovery error: Error loading script /usr/lib/vlc/lua/sd/fmc.luac: lua/sd/fmc.lua:22: attempt to call global 'require' (a nil value)
[0x7f2084477098] lua services discovery error: Error loading script /usr/lib/vlc/lua/sd/icecast.luac: lua/sd/icecast.lua:22: attempt to call global 'require' (a nil value)
[0x7f2060c120e8] access_http access error: cannot connect to mafreebox.freebox.fr:80
[0x7f2060c120e8] access_mms access error: cannot connect to mafreebox.freebox.fr:80
[0x7f20843aa928] main services discovery error: no suitable access module for `http://mafreebox.freebox.fr/freeboxtv/playlist.m3u'
Killed

~$ apt-cache policy vlc
vlc:
  Installed: 2.0.3-0ubuntu0.12.04.1
  Candidate: 2.0.3-0ubuntu0.12.04.1
  Version table:
 *** 2.0.3-0ubuntu0.12.04.1 0
        500 http://archive.ubuntu.com/ubuntu/ precise-proposed/universe amd64 Packages
        100 /var/lib/dpkg/status
     2.0.1-4 0
        500 http://archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages

Changed in vlc (Ubuntu):
status: New → Confirmed
Benjamin Drung (bdrung) on 2012-07-30
Changed in vlc (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Changed in vlc:
status: Unknown → New
Sebastian Ramacher (s-ramacher) wrote :

Supposed to be fixed in 2.1.0-1.

Changed in vlc (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.