vlc: doesn't keep track of current chapter in Matroska files

Bug #288526 reported by Alex Mauer on 2008-10-24
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
VLC media player
Fix Released
Undecided
Unassigned
vlc (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: vlc

When vlc plays a Matroska file containing chapters, it doesn't properly keep track of what chapter it's on.

For example, if chapter two begins at 2:00, and you let the video play from 0:00 to 2:30, and then hit "next chapter", it will skip /back/ to 2:00. It should obviously skip to chapter 3 instead.

Alex Mauer (hawke) wrote :

Attached please find a test file containing several chapters at ten second intervals

Magnus S (magnuss) wrote :

Confirmed for:
----------
  Installed: 0.9.4-1ubuntu3
  Candidate: 0.9.4-1ubuntu3
  Version table:
 *** 0.9.4-1ubuntu3 0
        500 http://se.archive.ubuntu.com intrepid/multiverse Packages
        100 /var/lib/dpkg/status
-----------
with the video attached by Alex. Haven't tried with other videos yet, but will as soon as i can find one to test with.

//magnus

Changed in vlc:
status: New → Confirmed
Magnus S (magnuss) wrote :

Attaching the verbose output from vlc. These are the steps:
1. Launch vlc
2. Open file via menu
3. Let it play, at 00:50 press "next chapter" - it went back to 00:08 instead of moving forward. Playback continues.
4. Close vlc.

@ Alex Mauer:
Which version are you running? And which version of ubuntu?

//magnus

Magnus S (magnuss) wrote :

This issue doesn't seem to appear when i run "nvlc filename.mkv" in a terminal.
//magnus

Hew (hew) wrote :

Tested with the file provided. It appears to be an unsupported format, but using next/previous chapter jumps at about 8-10s intervals.

There have been a large number of bugfixes with the latest VLC release, 1.0.0~rc2-1ubuntu1. Can you reproduce your issue with this latest version? You can test this in Ubuntu Karmic, or Ubuntu Jaunty with the MOTU Media PPA at https://launchpad.net/~motumedia/+archive/ppa . Thanks in advance.

Changed in vlc (Ubuntu):
status: Confirmed → Incomplete
Alex Mauer (hawke) wrote :

I can reproduce it in nvlc; you have to use the hotkeys to do it. Shift-n is the hotkey for next chapter.

Alex Mauer (hawke) wrote :

This is still a problem in vlc 1.0.0 from Karmic. Hew, I assume you're not properly following the steps to reproduce, as given by Magnus S.

In what way does the file appear to be an unsupported format? It plays fine here.

Changed in vlc (Ubuntu):
status: Incomplete → Confirmed
Changed in vlc:
status: Unknown → New
Jacob (jacob-rau) wrote :

Confirmed for the sample video attached to this thread and Matroska files I've created with HandBrake.

Also confirmed that when playing a DVD, the chapter setting automatically moves according to the playback position.

Thank you for reporting this bug.

In Maverick, I downloaded attached file and it played flawlessly. Marking as such.

lsb_release -rd
Description: Ubuntu maverick (development branch)
Release: 10.10

apt-cache policy vlc
vlc:
  Installed: 1.1.4-1ubuntu1
  Candidate: 1.1.4-1ubuntu1
  Version table:
 *** 1.1.4-1ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/universe i386 Packages
        100 /var/lib/dpkg/status

Changed in vlc (Ubuntu):
status: Confirmed → Fix Released
Alex Mauer (hawke) wrote :

This is still not fixed.

rusivi1, please read the description before changing the status. The problem is not that the video doesn’t play, it’s that VLC doesn’t properly keep track of which chapter it’s on.

Changed in vlc (Ubuntu):
status: Fix Released → New
Changed in vlc (Ubuntu):
status: New → Confirmed
Rémi Denis-Courmont (rdenis) wrote :

Manually updating status

Changed in vlc:
importance: Unknown → Undecided
Rémi Denis-Courmont (rdenis) wrote :

Fixed in VLC 2.0.0.

Changed in vlc:
status: New → Fix Released
Changed in vlc (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.