Change the project's id to be not limited only to numbers

Bug #1169538 reported by Marco Giusti
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Virtualbricks
Wishlist
Unassigned

Bug Description

Project's id should accept arbitrary strings and not only ints.

Related branches

Revision history for this message
Marco Giusti (marco-giusti) wrote : Re: [Bug 1169538] [NEW] Project's id limited to numeric only

What is exactly the problem with numeric ids? How can I reproduce it?

Revision history for this message
Francesco Apollonio (lorddex) wrote : Re: Project's id limited to numeric only

this is related with project import/export. The project id is used for the local private cow files.
It's important that when exporting a project it hasn't anything related with the local machine (project id is a number incremented each time that a new project is created but only in the local machine). So the problem is not the project id itself but we have to find a way to allow to a project to be exported and then imported in another machine without any problem.

Changed in virtualbrick:
milestone: none → 1.0
Changed in virtualbrick:
status: New → Opinion
importance: Undecided → Wishlist
summary: - Project's id limited to numeric only
+ Change the project's id to be not limited only to numbers
Revision history for this message
Marco Giusti (marco-giusti) wrote :

Fixed. The fix is lost in the mass of commits.

Changed in virtualbrick:
status: Opinion → Fix Committed
Changed in virtualbrick:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints