Networking doesn't work because modprobe vboxnetflt fails

Bug #571574 reported by Alkis Georgopoulos on 2010-04-29
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Virtualbox
Fix Released
Unknown
virtualbox-ose (Ubuntu)
Undecided
Felix Geyer

Bug Description

Binary package hint: virtualbox-ose

This is very similar to bug #314650 but since that was filed against an older vbox version and marked as "fixed released", I'm opening a new one.

virtualbox-ose: 3.1.6-dfsg-2ubuntu2 (Lucid), using kernel linux-image-2.6.32-21-generic-pae.

$ sudo service virtualbox-ose start
 * Starting VirtualBox kernel modules
 * modprobe vboxnetflt failed. Please use 'dmesg' to find out why [fail]

$ dmesg | tail -n 1
[ 7853.014417] vboxguest: exports duplicate symbol RTMemExecFree (owned by vboxdrv)

$ sudo insmod /lib/modules/2.6.32-21-generic-pae/updates/dkms/vboxnetflt.ko

After using insmod instead of modprobe, everything works fine. So until the problem is correctly resolved, a workaround is to insert this function in /etc/init.d/virtualbox-ose:

modprobe()
{
 local module

 test -n "$1" || return 1
 if ! /sbin/modprobe "$1" > /dev/null 2>&1; then
  module=$(find /lib/modules/`uname -r` -name "$1\.*" 2>/dev/null)
  if [ -f "$module" ]; then
   insmod "$module"
   return $?
  else
   return 1
  fi
 fi
 return 0
}

Felix Geyer (debfx) wrote :

Please remove the virtualbox-ose-guest-dkms package.
vboxdrv and vboxguest seem to conflict with each other as both export the symbol RTMemExecFree.
It makes no sense to have virtualbox-ose-dkms and virtualbox-ose-guest-dkms installed
at the same time so I'll make them conflict with each other.

Changed in virtualbox-ose (Ubuntu):
assignee: nobody → Felix Geyer (debfx)
status: New → In Progress
Alkis Georgopoulos (alkisg) wrote :

After removing virtualbox-ose-guest-dkms it's working fine (I can't remember when/why I installed virtualbox-ose-guest-utils on my host, though).

Thank you.

Daniel Richard G. (skunk) wrote :

Felix, please reconsider making v-o-dkms and v-o-guest-dkms conflict with each other. At my site, we have a standard Ubuntu image that can be "ghosted" onto a system via a PXE-booted utility. The image not only contains the VirtualBox application, it is downloaded onto VirtualBox machines as often as real hardware.

It is enormously convenient to have a single image that can both host virtual machines, and run in a virtual machine (with extensions) itself. This worked without a problem in Karmic. Would it be possible to make the driver and guest modules compatible with each other? Isn't it just a matter of renaming the offending symbol?

Felix Geyer (debfx) wrote :

Looking at the source code renaming the symbol isn't that easy and is something that should be done upstream.
Making the packages conflict is better than doing nothing.

Changed in virtualbox:
status: Unknown → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox-ose - 3.2.0-dfsg-1ubuntu1

---------------
virtualbox-ose (3.2.0-dfsg-1ubuntu1) maverick; urgency=low

  * Merge from Debian unstable, remaining changes:
    - Set x11 backport switch to "lucid".
    - VirtualBox should go in Accessories, not in System tools. (LP: #288590)
      - debian/virtualbox-ose-qt.files/virtualbox-ose.desktop
    - Add Apport hook.
      - debian/virtualbox-ose.files/source_virtualbox-ose.py
      - debian/virtualbox-ose.install
    - Drop *-source packages.
  * Drop u03-fix-cpu-lockup.dpatch, fixed upstream.
  * Remove Launchpad integration as (non-packaging) bugs should be reported
    upstream.

virtualbox-ose (3.2.0-dfsg-1) unstable; urgency=low

  [ Felix Geyer ]
  * New upstream release.
  * Add 23-remove-invalid-chars-check.patch to remove a check for invalid
    characters in the build path since kBuild is now able to handle those.
  * Fix FTBFS when building without arch-all packages.

  [ Michael Meskes ]
  * Changed order of some commands to make sure links are created inside
    the source tarball not outside.

virtualbox-ose (3.1.53-dfsg-1) experimental; urgency=low

  * New upstream release 3.2.0 Beta 3.
  * Add build-dependencies required by new upstream version.
  * Adapt 18-system-xorg.dpatch to new upstream version.
  * Update to new upstream release of vdfuse.
  * Build vdfuse with -Wl,--as-needed.
  * Install vbox PAM module.
  * Drop 17-disable-help-contents.dpatch and 20-hide-help-buttons.dpatch
    as VirtualBox can download the manual.
  * Enable VDE networking.
  * Enable VNC server in VBoxHeadless.
  * Don't build VBoxBFE as it's not installed anyway.
  * Hide the update menu item and settings page instead of disabling them.
  * Make both dkms packages conflict with each other as the kernel modules
    export the same symbol. (LP: #571574)
  * Switch from dpatch to quilt patching system.
  * Convert debian/rules to dh7.
  * Use dkms debhelper script.

virtualbox-ose (3.1.8-dfsg-1) unstable; urgency=low

  * New upstream version (LP: #578723).
    - Fixes vboxsf file systems not being mounted while booting on Ubuntu.
      (LP: #530179)
  * Adapt 18-system-xorg.dpatch and 06-xsession.dpatch to new upstream version.
  * Use upstream 50-vboxmouse.conf instead of our own.
  * Add libxrandr-dev to build-dependencies.
  * Don't load the kernel modules in the guest utils init script as they are
    loaded automatically.
  * Drop 15-wined3d-guest-addition.dpatch as the Windows guest additions
    provide Direct3D acceleration.

virtualbox-ose (3.1.6-dfsg-3) unstable; urgency=low

  * Move 10-vboxmouse.conf to 50-vboxmouse.conf and install it in
    /usr/share/X11/xorg.conf.d.
  * Use substvar from new xsfbs.mk.
 -- Felix Geyer <email address hidden> Tue, 25 May 2010 22:51:39 +0200

Changed in virtualbox-ose (Ubuntu):
status: In Progress → Fix Released
phl (ubuntu-leledy) wrote :

Felix, please reconsider making v-o-dkms and v-o-guest-dkms conflict with each other: I second that wish.

For me it's also a must have: single image used either as host or guest.

Of course, not both roles are played at the same time by an instance of the OS !

So, i'd like both dkms kernel modules installed, and the useful kernel modules loaded only on demand: host-dkms when the virtualbox applicaton is started, and guest when linux kernel finds itself running on a virtual machine provided by virtualbox.

Tks for a solution or a hint to find a by-pass.

Ph.L.

Felix Geyer (debfx) wrote :

> Felix, please reconsider making v-o-dkms and v-o-guest-dkms conflict
> with each other: I second that wish.
You won't be able to load either of the kernel modules when both packages are installed.
The package conflict just represents how it is.

> So, i'd like both dkms kernel modules installed, and the useful kernel
> modules loaded only on demand
You need to convince Oracle to fix the kernel modules.

Changed in virtualbox:
status: New → Fix Released
Daniel Richard G. (skunk) wrote :

The underlying conflict between the vboxdrv and vboxguest modules appears to have been addressed as of 4.0.6, according to the upstream bug tracker.

Could a backports release be in order?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.