Vineyard Won't run

Bug #718333 reported by Whinis on 2011-02-13
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Vineyard
High
Unassigned

Bug Description

I was trying to get warcraft 3 to run on its own config file through vineyard when the entire vineyard seemed to stop working.

The first problem I encountered that seemed odd is that the config file that I had warcraft 3 was set to use a virtual desktop however it refused to open in a virtual desktop. So I deleted the config file and decided to make another

Here is where the second problem arrived, I could no longer make a new config file, I could click the plus button and be prompted for a name however it never showed up. I used the command line option to check for config files and got this.
"john@john-laptop:~$ vineyard-cli --list-conf
Traceback (most recent call last):
  File "/usr/bin/vineyard-cli", line 829, in <module>
    main = Main()
  File "/usr/bin/vineyard-cli", line 212, in __init__
    data.append( [i, wine.prefixes.get_dir(i)] )
  File "/usr/lib/pymodules/python2.6/wine/prefixes.py", line 233, in get_dir
    bottle_dir = get_dir_name(bottlename)
  File "/usr/lib/pymodules/python2.6/wine/prefixes.py", line 212, in get_dir_name
    list(True)
  File "/usr/lib/pymodules/python2.6/wine/util.py", line 814, in dict_to_case_insensitive
    dict_copy[key.lower()] = value
AttributeError: 'NoneType' object has no attribute 'lower'

Then I tried to start vineyard preferences again and got this

Traceback (most recent call last):
  File "/usr/bin/vineyard-launcher", line 777, in <module>
    filename = os.path.abspath(sys.argv[1])
  File "/usr/bin/vineyard-launcher", line 137, in __init__
    ] + sorted(wine.prefixes.list(), key=str.lower)
TypeError: descriptor 'lower' requires a 'str' object but received a 'NoneType'

now nothing works at all.

Thanks for reporting this.

I can't reproduce the error so could you post the output of:
ls -R ~/.winebottles

Changed in vineyard:
importance: Undecided → High
Whinis (john-p-turner) wrote :

was kind of long so heres an attachment

Thanks. I've now managed to reproduce the error and am currently in the process of fixing it.

Thank you for the help.

Changed in vineyard:
status: New → In Progress
Changed in vineyard:
status: In Progress → Fix Committed
Whinis (john-p-turner) wrote :

I uninstalled vineyard, and then installed your fixed version and now I can open preferences again and run programs from the run executable option. However I can not run it by double clicking the executable. All I get is a loading wheel and then it stops. I have no way of debugging further.

When you say that you double click the executable, do you mean in the file manager (Nautilus)?
If so, could you try running vineyard-launcher /path/to/executable in a terminal and post the output?

Also, by the fixed version you mean the latest in trunk, right?

Whinis (john-p-turner) wrote :

Yes it is the trunk version
john@john-laptop:~$ vineyard-launcher '/home/john/Programs/Eve Fitting Tool/EFT.exe'
Reading section CODE at 504
Reading section DATA at 544
Reading section BSS at 584
Reading section .idata at 624
Reading section .tls at 664
Reading section .rdata at 704
Reading section .reloc at 744
Reading section .rsrc at 784
Traceback (most recent call last):
  File "/usr/local/bin/vineyard-launcher", line 821, in <module>
    filename = os.path.abspath(sys.argv[1])
  File "/usr/local/bin/vineyard-launcher", line 123, in __init__
    ).format(self.program_name))
TypeError: Gtk.Label.set_text() argument 1 must be string without null bytes, not str

Changed in vineyard:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments