Resource Pages Translate view WYSIWYG editor is displayed too low

Bug #1171995 reported by Ramindu Deshapriya
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Vesuvius
Fix Released
Low
Unassigned

Bug Description

The WYSIWYG editor given when attempting to translate a Resource Page is shown towards the middle of the left text body when translating a page which has a large amount of content. This needs to be brought to the top.

Reproduction steps:
1. Go Administrator->Resource Pages.
2. Select Translate on one of the pages.
3. The WYSIWYG editor is displayed low down, it is visible only after scrolling the page.

Tags: defect
Revision history for this message
Sneha Bhattacharya (sneha-22-7) wrote :

Editing the theme/lpf3/sahana.css has fixed this.
I changed a few of the div attributes like the rezLog and mainTable to get it fixed. Also adding a horizontal scrollbar can help.

Revision history for this message
gurutharshan (gurutharshan) wrote :

I have add javascript function to scroll inside rez_perform_translate() calls in /mod/rez/xajax.inc file
It works fine for me.. check and tell me if u need further improvements..:)

Revision history for this message
Sneha Bhattacharya (sneha-22-7) wrote :

this is the sahana.css file which i have edited. please let me know if i am moving in the right direction

Revision history for this message
Ramindu Deshapriya (rasade88) wrote :

Sneha, can you do a bzr diff on your codebase and generate a patch like Guru has done?

Guru, I'll take a look at your patch tonight. Thanks!

Revision history for this message
Sneha Bhattacharya (sneha-22-7) wrote :
Changed in vesuvius:
status: New → Confirmed
Revision history for this message
Ramindu Deshapriya (rasade88) wrote :

The above patches do not fix the bug. Please test your code with enable_locale set to 'true' in sahana.conf and changing around the locale in the Resource Pages administration section.

Revision history for this message
Vishesh S Hiremath (thevisheshone) wrote :

I tried changing the xajax.inc file itself in vesuvius/mod/rez.
Overriding the css style didn't work for some reason. I used the older valign attribute and it works.

Revision history for this message
Vishesh S Hiremath (thevisheshone) wrote :

Incase the way I took the patch was wrong above, I'm attatching the xajax.inc file here.
It goes inside vesuvius/mod/rez/

Revision history for this message
Vishesh S Hiremath (thevisheshone) wrote :

I'm sorry, the above fix used valign. It's depreciated. The css override does work. This patch fixes it overriding the default css values. The fix is for the xajax.inc file in vesuvius/mod/rez/ Please use this patch.

Revision history for this message
Vishesh S Hiremath (thevisheshone) wrote :

the source file.

Revision history for this message
gurutharshan (gurutharshan) wrote :

Vishesh, ur fix works for me too.. anyway i added patch for that..

Revision history for this message
Vishesh S Hiremath (thevisheshone) wrote :

what?! so the way I added the patch was wrong?

Revision history for this message
Vishesh S Hiremath (thevisheshone) wrote :

Ok, I'm sorry the way I created the patch file was wrong, anyways, here goes.

Revision history for this message
Sneha Bhattacharya (sneha-22-7) wrote :

Apparently adding a scrollbar was not the only solution. The editor was still being displayed low. So i again edited the xajax.inc file.
Now its perfect. :)

Thanks Vishesh for pointing out that changing the .css file does not work all the time.

Revision history for this message
Vishesh S Hiremath (thevisheshone) wrote :

@sneha, can you elaborate on the difference between your patch and mine?
Other than using vertical align, I just also extended the width to 100% as I didn't see any point in keeping the width 90%.

Revision history for this message
Sneha Bhattacharya (sneha-22-7) wrote : Re: [Bug 1171995] Re: Resource Pages Translate view WYSIWYG editor is displayed too low

i also added a scrollbar to the wsywig section. to make the visibilty
better. then i added vertical align. no other changes.

On Mon, Apr 29, 2013 at 12:48 PM, Vishesh S Hiremath <
<email address hidden>> wrote:

> @sneha, can you elaborate on the difference between your patch and mine?
> Other than using vertical align, I just also extended the width to 100% as
> I didn't see any point in keeping the width 90%.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1171995
>
> Title:
> Resource Pages Translate view WYSIWYG editor is displayed too low
>
> Status in Vesuvius:
> Confirmed
>
> Bug description:
> The WYSIWYG editor given when attempting to translate a Resource Page
> is shown towards the middle of the left text body when translating a
> page which has a large amount of content. This needs to be brought to
> the top.
>
> Reproduction steps:
> 1. Go Administrator->Resource Pages.
> 2. Select Translate on one of the pages.
> 3. The WYSIWYG editor is displayed low down, it is visible only after
> scrolling the page.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/vesuvius/+bug/1171995/+subscriptions
>

Revision history for this message
Ramindu Deshapriya (rasade88) wrote :

Committed Sneha's fix as she submitted first.

Vishesh, yours works as well, so you get kudos too.

Thanks!

Changed in vesuvius:
status: Confirmed → Fix Committed
Changed in vesuvius:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers