Statistics module does not load within default UI

Bug #1171080 reported by Ramindu Deshapriya
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Vesuvius
Fix Released
Medium
Mayank Jain

Bug Description

Default HTML/CSS elements for the Vesuvius theme do not load when the Statistics module is loaded.

Reproduction steps:

1. Log in as user with privileges to view stats module.
2. Open the Statistics module from the menu.
3. The theme will not be displayed, only the list of available charts will be displayed as links.

Tags: defect
Revision history for this message
Mayank Jain (mayankkrjain) wrote :

Changing the vesuvius/mod/stat/main.inc solves the problem for me.

Revision history for this message
Mayank Jain (mayankkrjain) wrote :

Here is the patch for this bug.

Revision history for this message
Ramindu Deshapriya (rasade88) wrote :

Your patch fixes the menu. Could you do the same for each individual chart, loading it within the module area of Vesuvius?

Changed in vesuvius:
status: New → In Progress
assignee: nobody → Mayank Jain (mayankkrjain)
Revision history for this message
Mayank Jain (mayankkrjain) wrote :

Fixed for each individial chart.
Noticed another bug with the People Locator Status Pie chart. Displayed count was double than the actual. Fixed it.

Revision history for this message
Ramindu Deshapriya (rasade88) wrote :

Fix accepted, patch applied. Thanks!

Changed in vesuvius:
status: In Progress → Fix Released
status: Fix Released → Fix Committed
Changed in vesuvius:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers