usplash failed after the last kernel update (karmic)

Bug #451252 reported by Patrick Fratczak on 2009-10-14
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
usplash
Undecided
Unassigned
usplash (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: yelp

Description: Ubuntu karmic (development branch)
Release: 9.10
Kernel : 2.6.31-14-generic
Usplash:
  Installé : 0.5.44
  Candidat : 0.5.44

After an update to the 2.6.31.14 kernel, upslash failed to detect and set the resolution of my laptop screen (DELL Vostro 1710)
I got a flashing screen asking me the login and password (console mode), and no way to use the keyboard correctly ...
So i decided to reboot but Grub2 (1.97 BETA) doesn't show me the menu by default .. except if i try to go up or down with the arrows keys !

ProblemType: Bug
Architecture: i386
Date: Wed Oct 14 14:58:15 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/yelp
NonfreeKernelModules: nvidia
Package: yelp 2.28.0-0ubuntu1
ProcEnviron:
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-13.45-generic
SourcePackage: yelp
Uname: Linux 2.6.31-13-generic i686

Patrick Fratczak (patfrat) wrote :
affects: yelp (Ubuntu) → usplash (Ubuntu)
Patrick Fratczak (patfrat) wrote :

To add a comment to my bug report ...
Ubuntu 9.10 use Xsplash, not Usplash, so why does i have this warning, usplash telling me that it failed to get a resolution ???

Patrick Fratczak (patfrat) wrote :

Hello,
i am under the 2.6.31-14 kernel now but i booted by editing the entry in grub and removing the splash option of the kernel line.
Without removing it, my screen flashed, usplash said me "Failed to set the resolution AxB." and try to set another resolution.
What's up doc ?
How can i debug it or log what's wrong when i keep the splah option ?

Patrick Fratczak (patfrat) wrote :

I have tried this after a boot without 'quiet splash' and logged me in a console.
sudo usplash -c -v >/tmp/usplash.log 2>&1

The results of /tmp/usplash.log :
usplash: Setting mode 1152x864 failed
usplash: Using mode 1024x768
but usplash show me the ubuntu white logo ...

Simon Steinbeiß (ochosi) wrote :

i can confirm that bug (dell xps m1330, karmic_amd64, ext4). i'm also wondering why usplash is still involved in all this... can someone explain?

lncoll (luis-coll) wrote :

Also affects my Compaq 8710p.
Booting without usplash also there are some flashes before loading X server.
Removing propietary NVidia driver the problem is solved, usplash works ok and no flashes or messages at boot

lncoll (luis-coll) wrote :

Installing again the NVidia propietary driver all works fine.
The problem seems to be that 2.6.31-14 upgrade breaks NVidia driver, reinstalling it all goes well.

Patrick Fratczak (patfrat) wrote :

Yes, i confirm now that's working ... after an update concerning the kernel, usplash, xsplash and also nvidia drivers ... ;)

Kris (kristian-holsheimer) wrote :

lncoll, could you please elaborate? I tried reinstalling nvidia-glx-185 and downgrading to nvidia-glx-173 (which solved some other problems in the past), but i see no change so far.

Phillip Susi (psusi) wrote :

The usplash package has been superseded by plymouth and has been removed from the Ubuntu archive. Closing all related bugs.

Changed in usplash (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers