Goodix GF3208 (fingerprint reader) not being recognised by lsusb(usbutils)

Bug #1721909 reported by Hassan Williamson on 2017-10-07
374
This bug affects 65 people
Affects Status Importance Assigned to Milestone
usbutils
Fix Released
Undecided
Unassigned
usbutils (Ubuntu)
Undecided
Unassigned

Bug Description

The Goodix GF3208 is not being recognised by the system (Dell Inspiron 15 7577). What's worse is that it isn't even showing the manufacturer vendor id information when doing:

$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 27c6:5301
Bus 001 Device 003: ID 8087:0a2b Intel Corp.
Bus 001 Device 002: ID 046d:c52f Logitech, Inc. Unifying Receiver
Bus 001 Device 005: ID 0bda:5652 Realtek Semiconductor Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Note that the vendor id 27c6 should at least say "Shenzhen Huiding Technology Co., Ltd." as per https://github.com/torvalds/linux/blob/e19b205be43d11bff638cad4487008c48d21c103/Documentation/devicetree/bindings/vendor-prefixes.txt

Will/has support been made for the Goodix GF3208 Fingerprint reader/scanner?

Thanks in advance,
Haz

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: linux-image-4.10.0-35-generic 4.10.0-35.39~16.04.1
ProcVersionSignature: Ubuntu 4.10.0-35.39~16.04.1-generic 4.10.17
Uname: Linux 4.10.0-35-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.10
Architecture: amd64
CurrentDesktop: Unity
Date: Sat Oct 7 04:03:25 2017
InstallationDate: Installed on 2017-10-01 (5 days ago)
InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64 (20170801)
SourcePackage: linux-hwe
UpgradeStatus: No upgrade log present (probably fresh install)

Hassan Williamson (hazrpg) wrote :
Hassan Williamson (hazrpg) wrote :

Thought I'd share my dmesg, which seems like the Goodix is being picked up - but isn't usable by anything (lsusb is still showing blank however):

https://paste.ubuntu.com/25734735/

Hassan Williamson (hazrpg) wrote :

Here is the output of:

sudo lsusb -D /dev/bus/usb/001/003

Where it seems to be attached:

http://paste.ubuntu.com/26019993/

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-hwe (Ubuntu):
status: New → Confirmed
Matthew Frost (epeleutheria) wrote :

Same here on Dell Inspiron 17 5770, running 17.10.

lsusb output matches what hazrpg posted in comment #3.

Hassan Williamson (hazrpg) wrote :

Is there anything we can do to help diagnose and fix this issue? I'm willing to do anything to get this to work. Even if it's sparing some coffee money!

alex (shantanna) wrote :
Vladimir (vmz1net) wrote :

The same problem on my Dell Vostro 5471, 16.04
Fingerprint doesn't work, which is very disappointing.

Changed the title because this is an issue with the kernel and not a specific machine as confirmed by vmz1net.

Is there anyway we can help in any way? I'm willing to deep dive into code if someone can help point me in the right direction. I'm also willing to put time into testing too.

summary: - Goodix GF3208 (fingerprint reader) not being recognised on Dell Inspiron
- 15 7577
+ Goodix GF3208 (fingerprint reader) not being recognised by
+ kernel/system
description: updated
Ant Somers (thiras) wrote :

I confirm the bug at 17.10

Ant Somers (thiras) on 2018-03-13
tags: added: artful
Ant Somers (thiras) on 2018-03-15
information type: Public → Public Security
information type: Public Security → Public
Tushar Varsha (exception4u) wrote :

I confirm bug at 16.04 on Dell Inspiron 15 7577 hardware.

aa-hcl (aa-hcl) wrote :

I confirm this bug on freshly installed from scratch ubuntu 16.04 with all updates on Dell Inspiron 5570 (0810). The device description obtained the same way as in #3 matches the posted output in #3 at http://paste.ubuntu.com/26019993/

Confirmed on bionic beaver final beta release. Inspiron 5370.

affects: linux-hwe (Ubuntu) → linux (Ubuntu)
Scipher (rudolf-harmse) wrote :

Confirmed on bionic beaver release. Inspiron 7577

rharmse@domino:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 27c6:5301
Bus 001 Device 003: ID 8087:0a2b Intel Corp.
Bus 001 Device 005: ID 0c45:6a08 Microdia
Bus 001 Device 002: ID 062a:4102 Creative Labs
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Aleksei Badyaev (abadyaev) wrote :

I confirm this bug on my Dell Inspiron 15 7577 laptop with Ubuntu 16.04 LTS.
I can spend some money or time for solving this bug :-)

Ant Somers (thiras) on 2018-06-16
tags: added: bionic
Liam O'Rourke (liamor) wrote :

I confirm this bug on a Dell G3 15 with Ubuntu 18.04

Bambr (s-bambr) wrote :

I confirm this bug on a Asus UX331UAL with Ubuntu 18.04.1

Matt (mguignes) wrote :

Confirmed on Asus UX331UN with Ubuntu 18.04.

Wallace Roque (wallacerock) wrote :

I confirm this bug on a Dell Vostro 5471 14' with Ubuntu 16.04 and kernel 4.15.0-32-generic.

I confirm this bug on Dell G3 15 with Kubuntu 18.04.1 and kernel 4.15.0-33-generic.

Ahmed Sherif (ahmedsherif95) wrote :

Confirmed on Dell Inspiron 5570 with Ubuntu 18.04.1. (And with Arch, it's not distro-specific)

Confirmed on Ubuntu Budgie 18.10 Beta with linux kernel 4.18.0-8-generic running on Dell Inspiron 15 7577

frank (dallco) wrote :

Confirmed on Ubuntu cosmic catlefish (beta) Dell G3 3779

fanf@fanf-G3-3779:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 27c6:5301
Bus 001 Device 004: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 003: ID 0bda:568a Realtek Semiconductor Corp.
Bus 001 Device 002: ID 046d:c521 Logitech, Inc. Cordless Mouse Receiver
Bus 001 Device 006: ID 8087:0aaa Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
fanf@fanf-G3-3779:~$ uname -a
Linux fanf-G3-3779 4.18.0-10-generic #11-Ubuntu SMP Thu Oct 11 15:13:55 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Ajmal Aju (ajmalaju) wrote :

Confirmed on Dell Inspiron 15 5570 with Ubuntu 18.04.1

user@masked:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.1 LTS
Release: 18.04
Codename: bionic
auser@masked:~$ uname -a
Linux masked 4.15.0-36-generic #39-Ubuntu SMP Mon Sep 24 16:19:09 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
user@masked:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 007: ID 27c6:5301
Bus 001 Device 006: ID 0cf3:e009 Atheros Communications, Inc.
Bus 001 Device 005: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 004: ID 0c45:6a06 Microdia
Bus 001 Device 002: ID 1ea7:0064
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Thomas E (crc-32) wrote :

Confirmed on Dell G3 3579, Ubuntu 18.10
$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.10
Release: 18.10
Codename: cosmic
$ uname -a
Linux masked 4.18.0-10-generic #11-Ubuntu SMP Thu Oct 11 15:13:55 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 27c6:5301
Bus 001 Device 003: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 002: ID 0bda:568a Realtek Semiconductor Corp.
Bus 001 Device 005: ID 8087:0aaa Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Same problem on Dell Inspiron 7577 with Ubuntu 18.10
$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.10
Release: 18.10
Codename: cosmic
$ uname -a
Linux Dell7577Linux 4.18.0-10-generic #11-Ubuntu SMP Thu Oct 11 15:13:55 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 27c6:5301
Bus 001 Device 005: ID 8087:0a2b Intel Corp.
Bus 001 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 042: ID 046d:0a29 Logitech, Inc. H600 [Wireless Headset]
Bus 001 Device 041: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 007: ID 0bda:5652 Realtek Semiconductor Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Would be really nice if I could use the Goodix Fingerprint sensor GF3208 like I use it in Windows 10.

Andres Kuznetcov (parapenter) wrote :

I confirm this bug on a Asus ZenBook UX331UA with Ubuntu 18.10

demonhun7er (demonhun7er) wrote :

Same problem here on a brand new Dell G5 5587...

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.1 LTS
Release: 18.04
Codename: bionic
$ uname -a
Linux dellissimo 4.15.0-36-generic #39-Ubuntu SMP Mon Sep 24 16:19:09 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 27c6:5381
Bus 001 Device 004: ID 0c45:6a08 Microdia
Bus 001 Device 003: ID 1532:0042 Razer USA, Ltd
Bus 001 Device 006: ID 8087:0aaa Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

:(

Vsevolod Velichko (torkvemada) wrote :

Same here with Dell XPS 9570 on Ubuntu 18.10:

0 ➜ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.10
Release: 18.10
Codename: cosmic
0 ➜ uname -a
Linux yaroot-46 4.18.0-11-generic #12-Ubuntu SMP Tue Oct 23 19:22:37 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
0 ➜ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 27c6:5395
Bus 001 Device 002: ID 0cf3:e300 Atheros Communications, Inc.
Bus 001 Device 004: ID 0c45:671d Microdia
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

k0l1 (kolos-kener) wrote :

I have the same problem on a new Dell G3 3579 on Ubuntu 18.04.1 LTS.

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.1 LTS
Release: 18.04
Codename: bionic
uname -a
Linux notebook 4.15.0-1024-oem #29-Ubuntu SMP Tue Oct 16 08:14:23 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 27c6:5301
Bus 001 Device 003: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 002: ID 0bda:568a Realtek Semiconductor Corp.
Bus 001 Device 005: ID 8087:0aaa Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Noah Witt (noahwitt) wrote :
Download full text (3.8 KiB)

Dell XPS 15 9570 (2018) Same issue:

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.10
Release: 18.10
Codename: cosmic

uname -a
Linux noah-XPS-15-9570 4.18.0-11-generic #12-Ubuntu SMP Tue Oct 23 19:22:37 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 27c6:5395
Bus 001 Device 002: ID 0cf3:e301 Atheros Communications, Inc.
Bus 001 Device 004: ID 0c45:671d Microdia
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lsusb -s 001:003 -vv

Bus 001 Device 003: ID 27c6:5395
Couldn't open device, some information will be missing
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 2.00
  bDeviceClass 239 Miscellaneous Device
  bDeviceSubClass 2 ?
  bDeviceProtocol 1 Interface Association
  bMaxPacketSize0 64
  idVendor 0x27c6
  idProduct 0x5395
  bcdDevice 1.00
  iManufacturer 1
  iProduct 2
  iSerial 3
  bNumConfigurations 1
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 75
    bNumInterfaces 2
    bConfigurationValue 1
    iConfiguration 0
    bmAttributes 0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower 100mA
    Interface Association:
      bLength 8
      bDescriptorType 11
      bFirstInterface 0
      bInterfaceCount 2
      bFunctionClass 2 Communications
      bFunctionSubClass 255
      bFunctionProtocol 1
      iFunction 2
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 0
      bAlternateSetting 0
      bNumEndpoints 1
      bInterfaceClass 2 Communications
      bInterfaceSubClass 2 Abstract (modem)
      bInterfaceProtocol 1 AT-commands (v.25ter)
      iInterface 0
      CDC Header:
        bcdCDC 1.10
      CDC Call Management:
        bmCapabilities 0x00
        bDataInterface 1
      UNRECOGNIZED CDC: 04 24 ff 02
      CDC Union:
        bMasterInterface 0
        bSlaveInterface 1
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x82 EP 2 IN
        bmAttributes 3
          Transfer Type Interrupt
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0040 1x 64 bytes
        bInterval 255
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 1
      bAlternateSetting 0
      bNumEndpoints 2
      bInterfaceClass 10 CDC Data
      bInterfaceSubClass 0 Unused
      bInterfaceProtocol 0
      iInterface 0
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
      ...

Read more...

Henri Gomez (henri-gomez) wrote :

Same problem on Dell Inspiron 15 7000 2-in-1 (CPU i7-8565U)

# lsusb

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 0c45:671b Microdia
Bus 001 Device 004: ID 27c6:538c
Bus 001 Device 007: ID 062a:5918 Creative Labs
Bus 001 Device 006: ID 8087:0aaa Intel Corp.
Bus 001 Device 002: ID 046d:0a4d Logitech, Inc. G430 Surround Sound Gaming Headset
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

27c6:538c is not recognized

# lsusb -s 001:004 -vv

Bus 001 Device 004: ID 27c6:538c
Couldn't open device, some information will be missing
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 2.00
  bDeviceClass 255 Vendor Specific Class
  bDeviceSubClass 0
  bDeviceProtocol 0
  bMaxPacketSize0 64
  idVendor 0x27c6
  idProduct 0x538c
  bcdDevice 1.00
  iManufacturer 1
  iProduct 2
  iSerial 0
  bNumConfigurations 1
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 32
    bNumInterfaces 1
    bConfigurationValue 1
    iConfiguration 0
    bmAttributes 0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower 100mA
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 0
      bAlternateSetting 0
      bNumEndpoints 2
      bInterfaceClass 255 Vendor Specific Class
      bInterfaceSubClass 0
      bInterfaceProtocol 0
      iInterface 0
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x01 EP 1 OUT
        bmAttributes 2
          Transfer Type Bulk
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0040 1x 64 bytes
        bInterval 0
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x83 EP 3 IN
        bmAttributes 2
          Transfer Type Bulk
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0040 1x 64 bytes
        bInterval 0

Download full text (4.5 KiB)

As it turns out, one could also live without it.

On Tue, Jan 15, 2019 at 8:05 PM Henri Gomez <email address hidden>
wrote:

> Same problem on Dell Inspiron 15 7000 2-in-1 (CPU i7-8565U)
>
> # lsusb
>
> Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> Bus 001 Device 005: ID 0c45:671b Microdia
> Bus 001 Device 004: ID 27c6:538c
> Bus 001 Device 007: ID 062a:5918 Creative Labs
> Bus 001 Device 006: ID 8087:0aaa Intel Corp.
> Bus 001 Device 002: ID 046d:0a4d Logitech, Inc. G430 Surround Sound Gaming
> Headset
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
>
> 27c6:538c is not recognized
>
> # lsusb -s 001:004 -vv
>
> Bus 001 Device 004: ID 27c6:538c
> Couldn't open device, some information will be missing
> Device Descriptor:
> bLength 18
> bDescriptorType 1
> bcdUSB 2.00
> bDeviceClass 255 Vendor Specific Class
> bDeviceSubClass 0
> bDeviceProtocol 0
> bMaxPacketSize0 64
> idVendor 0x27c6
> idProduct 0x538c
> bcdDevice 1.00
> iManufacturer 1
> iProduct 2
> iSerial 0
> bNumConfigurations 1
> Configuration Descriptor:
> bLength 9
> bDescriptorType 2
> wTotalLength 32
> bNumInterfaces 1
> bConfigurationValue 1
> iConfiguration 0
> bmAttributes 0xa0
> (Bus Powered)
> Remote Wakeup
> MaxPower 100mA
> Interface Descriptor:
> bLength 9
> bDescriptorType 4
> bInterfaceNumber 0
> bAlternateSetting 0
> bNumEndpoints 2
> bInterfaceClass 255 Vendor Specific Class
> bInterfaceSubClass 0
> bInterfaceProtocol 0
> iInterface 0
> Endpoint Descriptor:
> bLength 7
> bDescriptorType 5
> bEndpointAddress 0x01 EP 1 OUT
> bmAttributes 2
> Transfer Type Bulk
> Synch Type None
> Usage Type Data
> wMaxPacketSize 0x0040 1x 64 bytes
> bInterval 0
> Endpoint Descriptor:
> bLength 7
> bDescriptorType 5
> bEndpointAddress 0x83 EP 3 IN
> bmAttributes 2
> Transfer Type Bulk
> Synch Type None
> Usage Type Data
> wMaxPacketSize 0x0040 1x 64 bytes
> bInterval 0
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1721909
>
> Title:
> Goodix GF3208 (fingerprint reader) not being recognised by
> kernel/system
>
> Status in Linux:
> New
> Status in linux package in Ubuntu:
> Confirmed
>
> Bug description:
> The Goodix GF3208 is not being recognised by the system (Dell Inspiron
> 15 7577). What's worse is that it isn't even showing the manufacturer
> vendor id information when do...

Read more...

Download full text (6.9 KiB)

Yup or install Windows 10 then clean it with a script. It's not that bad
really.

On Tue, Jan 15, 2019, 19:25 demonhun7er <<email address hidden> wrote:

> As it turns out, one could also live without it.
>
> On Tue, Jan 15, 2019 at 8:05 PM Henri Gomez <email address hidden>
> wrote:
>
> > Same problem on Dell Inspiron 15 7000 2-in-1 (CPU i7-8565U)
> >
> > # lsusb
> >
> > Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> > Bus 001 Device 005: ID 0c45:671b Microdia
> > Bus 001 Device 004: ID 27c6:538c
> > Bus 001 Device 007: ID 062a:5918 Creative Labs
> > Bus 001 Device 006: ID 8087:0aaa Intel Corp.
> > Bus 001 Device 002: ID 046d:0a4d Logitech, Inc. G430 Surround Sound
> Gaming
> > Headset
> > Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> >
> > 27c6:538c is not recognized
> >
> > # lsusb -s 001:004 -vv
> >
> > Bus 001 Device 004: ID 27c6:538c
> > Couldn't open device, some information will be missing
> > Device Descriptor:
> > bLength 18
> > bDescriptorType 1
> > bcdUSB 2.00
> > bDeviceClass 255 Vendor Specific Class
> > bDeviceSubClass 0
> > bDeviceProtocol 0
> > bMaxPacketSize0 64
> > idVendor 0x27c6
> > idProduct 0x538c
> > bcdDevice 1.00
> > iManufacturer 1
> > iProduct 2
> > iSerial 0
> > bNumConfigurations 1
> > Configuration Descriptor:
> > bLength 9
> > bDescriptorType 2
> > wTotalLength 32
> > bNumInterfaces 1
> > bConfigurationValue 1
> > iConfiguration 0
> > bmAttributes 0xa0
> > (Bus Powered)
> > Remote Wakeup
> > MaxPower 100mA
> > Interface Descriptor:
> > bLength 9
> > bDescriptorType 4
> > bInterfaceNumber 0
> > bAlternateSetting 0
> > bNumEndpoints 2
> > bInterfaceClass 255 Vendor Specific Class
> > bInterfaceSubClass 0
> > bInterfaceProtocol 0
> > iInterface 0
> > Endpoint Descriptor:
> > bLength 7
> > bDescriptorType 5
> > bEndpointAddress 0x01 EP 1 OUT
> > bmAttributes 2
> > Transfer Type Bulk
> > Synch Type None
> > Usage Type Data
> > wMaxPacketSize 0x0040 1x 64 bytes
> > bInterval 0
> > Endpoint Descriptor:
> > bLength 7
> > bDescriptorType 5
> > bEndpointAddress 0x83 EP 3 IN
> > bmAttributes 2
> > Transfer Type Bulk
> > Synch Type None
> > Usage Type Data
> > wMaxPacketSize 0x0040 1x 64 bytes
> > bInterval 0
> >
> > --
> > You received this bug notification because you are subscribed to the bug
> > report.
> > https://bugs.launchpad.net/bugs/1721909
> >
> > Title:
> > Goodix GF3208 (fingerprint ...

Read more...

demonhun7er (demonhun7er) wrote :
Download full text (9.4 KiB)

Install Windows only to make a fingerprint scanner work? I beg to differ.

On Tue, Jan 15, 2019 at 10:35 PM Yassine Imounachen <
<email address hidden>> wrote:

> Yup or install Windows 10 then clean it with a script. It's not that bad
> really.
>
> On Tue, Jan 15, 2019, 19:25 demonhun7er <<email address hidden>
> wrote:
>
> > As it turns out, one could also live without it.
> >
> > On Tue, Jan 15, 2019 at 8:05 PM Henri Gomez <email address hidden>
> > wrote:
> >
> > > Same problem on Dell Inspiron 15 7000 2-in-1 (CPU i7-8565U)
> > >
> > > # lsusb
> > >
> > > Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> > > Bus 001 Device 005: ID 0c45:671b Microdia
> > > Bus 001 Device 004: ID 27c6:538c
> > > Bus 001 Device 007: ID 062a:5918 Creative Labs
> > > Bus 001 Device 006: ID 8087:0aaa Intel Corp.
> > > Bus 001 Device 002: ID 046d:0a4d Logitech, Inc. G430 Surround Sound
> > Gaming
> > > Headset
> > > Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> > >
> > > 27c6:538c is not recognized
> > >
> > > # lsusb -s 001:004 -vv
> > >
> > > Bus 001 Device 004: ID 27c6:538c
> > > Couldn't open device, some information will be missing
> > > Device Descriptor:
> > > bLength 18
> > > bDescriptorType 1
> > > bcdUSB 2.00
> > > bDeviceClass 255 Vendor Specific Class
> > > bDeviceSubClass 0
> > > bDeviceProtocol 0
> > > bMaxPacketSize0 64
> > > idVendor 0x27c6
> > > idProduct 0x538c
> > > bcdDevice 1.00
> > > iManufacturer 1
> > > iProduct 2
> > > iSerial 0
> > > bNumConfigurations 1
> > > Configuration Descriptor:
> > > bLength 9
> > > bDescriptorType 2
> > > wTotalLength 32
> > > bNumInterfaces 1
> > > bConfigurationValue 1
> > > iConfiguration 0
> > > bmAttributes 0xa0
> > > (Bus Powered)
> > > Remote Wakeup
> > > MaxPower 100mA
> > > Interface Descriptor:
> > > bLength 9
> > > bDescriptorType 4
> > > bInterfaceNumber 0
> > > bAlternateSetting 0
> > > bNumEndpoints 2
> > > bInterfaceClass 255 Vendor Specific Class
> > > bInterfaceSubClass 0
> > > bInterfaceProtocol 0
> > > iInterface 0
> > > Endpoint Descriptor:
> > > bLength 7
> > > bDescriptorType 5
> > > bEndpointAddress 0x01 EP 1 OUT
> > > bmAttributes 2
> > > Transfer Type Bulk
> > > Synch Type None
> > > Usage Type Data
> > > wMaxPacketSize 0x0040 1x 64 bytes
> > > bInterval 0
> > > Endpoint Descriptor:
> > > bLength 7
> > > bDescriptorType 5
> > > bEndpointAddress 0x83 EP 3 IN
> > > bmAttributes 2
> > > Transfer Type Bulk
> > > Synch Type ...

Read more...

Download full text (3.8 KiB)

Please, fix the bug of fingerprint goodix
Linux 18.04.1 LTS
Kernel 4.20

#lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 8087:0a2a Intel Corp.
Bus 001 Device 004: ID 045e:0745 Microsoft Corp. Nano Transceiver v1.0 for Bluetooth
Bus 001 Device 007: ID 27c6:5740
Bus 001 Device 005: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 003: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 002: ID 058f:3841 Alcor Micro Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

#sudo lsusb -D /dev/bus/usb/001/007
Device: ID 27c6:5740
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 2.00
  bDeviceClass 239 Miscellaneous Device
  bDeviceSubClass 2 ?
  bDeviceProtocol 1 Interface Association
  bMaxPacketSize0 64
  idVendor 0x27c6
  idProduct 0x5740
  bcdDevice 1.00
  iManufacturer 1 HTMicroelectronics
  iProduct 2 Goodix Fingerprint Device
  iSerial 3 HTK32
  bNumConfigurations 1
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 75
    bNumInterfaces 2
    bConfigurationValue 1
    iConfiguration 0
    bmAttributes 0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower 100mA
    Interface Association:
      bLength 8
      bDescriptorType 11
      bFirstInterface 0
      bInterfaceCount 2
      bFunctionClass 2 Communications
      bFunctionSubClass 255
      bFunctionProtocol 1
      iFunction 2 Goodix Fingerprint Device
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 0
      bAlternateSetting 0
      bNumEndpoints 1
      bInterfaceClass 2 Communications
      bInterfaceSubClass 2 Abstract (modem)
      bInterfaceProtocol 1 AT-commands (v.25ter)
      iInterface 0
      CDC Header:
        bcdCDC 1.10
      CDC Call Management:
        bmCapabilities 0x00
        bDataInterface 1
      UNRECOGNIZED CDC: 04 24 ff 02
      CDC Union:
        bMasterInterface 0
        bSlaveInterface 1
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x82 EP 2 IN
        bmAttributes 3
          Transfer Type Interrupt
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0040 1x 64 bytes
        bInterval 255
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 1
      bAlternateSetting 0
      bNumEndpoints 2
      bInterfaceClass 10 CDC Data
      bInterfaceSubClass 0 Unused
      bInterfaceProtocol 0
      iInterface 0
      Endpoint Descriptor:
        bLength 7
        b...

Read more...

risafov (risafov) wrote :

Same for me:
ASUS UX370UA
Linux 18.10
Kernel 4.20

Please please please, pretty please xD

On Fri, Feb 1, 2019 at 4:41 PM risafov <email address hidden> wrote:

> Same for me:
> ASUS UX370UA
> Linux 18.10
> Kernel 4.20
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1721909
>
> Title:
> Goodix GF3208 (fingerprint reader) not being recognised by
> kernel/system
>
> Status in Linux:
> New
> Status in linux package in Ubuntu:
> Confirmed
>
> Bug description:
> The Goodix GF3208 is not being recognised by the system (Dell Inspiron
> 15 7577). What's worse is that it isn't even showing the manufacturer
> vendor id information when doing:
>
> $ lsusb
> Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> Bus 001 Device 004: ID 27c6:5301
> Bus 001 Device 003: ID 8087:0a2b Intel Corp.
> Bus 001 Device 002: ID 046d:c52f Logitech, Inc. Unifying Receiver
> Bus 001 Device 005: ID 0bda:5652 Realtek Semiconductor Corp.
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
>
> Note that the vendor id 27c6 should at least say "Shenzhen Huiding
> Technology Co., Ltd." as per
>
> https://github.com/torvalds/linux/blob/e19b205be43d11bff638cad4487008c48d21c103/Documentation/devicetree/bindings
> /vendor-prefixes.txt
>
> Will/has support been made for the Goodix GF3208 Fingerprint
> reader/scanner?
>
> Thanks in advance,
> Haz
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.04
> Package: linux-image-4.10.0-35-generic 4.10.0-35.39~16.04.1
> ProcVersionSignature: Ubuntu 4.10.0-35.39~16.04.1-generic 4.10.17
> Uname: Linux 4.10.0-35-generic x86_64
> ApportVersion: 2.20.1-0ubuntu2.10
> Architecture: amd64
> CurrentDesktop: Unity
> Date: Sat Oct 7 04:03:25 2017
> InstallationDate: Installed on 2017-10-01 (5 days ago)
> InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64
> (20170801)
> SourcePackage: linux-hwe
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linux/+bug/1721909/+subscriptions
>

Wow, lots of different devices have started shipping the same fingerprint scanner since I first raised this issue.

Is there anything we can do in the community to help? Clearly there is a need for this to be included.

David (davidrobson1182) wrote :

Likewise: Dell Inspiron 17 7000 2-in-1

# lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0c45:671b Microdia
Bus 001 Device 002: ID 27c6:538c
Bus 001 Device 004: ID 8087:0aaa Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Happy to help with testing (don't know much about coding).

Thanks in advance to anyone able to advance this.

Antonio Ospite (ospite) wrote :

Some more info and some experimental tools can be found in lifprint issue tracker: https://gitlab.freedesktop.org/libfprint/libfprint/issues?scope=all&utf8=%E2%9C%93&state=opened&search=27c6

I have the same bug on my new laptop, a Teclast F6:

lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 8087:0a2a Intel Corp.
Bus 001 Device 006: ID 27c6:5740
Bus 001 Device 005: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 003: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 002: ID 058f:3841 Alcor Micro Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Dzh (dzhuneyt) wrote :

Same issue with Dell G5 5587

lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 27c6:5381
Bus 001 Device 003: ID 0c45:6718 Microdia
Bus 001 Device 005: ID 8087:0aaa Intel Corp.
Bus 001 Device 002: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.2 LTS
Release: 18.04
Codename: bionic

You-Sheng Yang (vicamo) wrote :

This is not a kernel bug. `lsusb` from usbutils package (bionic/cosmic/disco) only read name strings from usb.ids [1] files. Upstream has merged a PR [2] to fallback to kernel sysfs attributes, and with that the names will be correctly shown.

[1]: http://www.linux-usb.org/usb.ids
[2]: https://github.com/gregkh/usbutils/pull/81

Changed in linux (Ubuntu):
status: Confirmed → Invalid
Changed in usbutils (Ubuntu):
status: New → Confirmed
no longer affects: linux (Ubuntu)
You-Sheng Yang (vicamo) on 2019-04-19
summary: Goodix GF3208 (fingerprint reader) not being recognised by
- kernel/system
+ lsusb(usbutils)
no longer affects: usbutils
affects: linux → usbutils
You-Sheng Yang (vicamo) on 2019-04-19
tags: added: cosmic disco

@vicamo what can we do to help figure this thing out? We have a ton of Dells with this sensor in our company running Ubuntu and could really benefit from this fingerprint reader.

You-Sheng Yang (vicamo) wrote :

@raphaelbs, I think most of the jobs to be done to fully bring up the device should fall on libfprint as pointed out in #41. If you only want it to be listed correctly, then a new usbutils release is expected.

USB Utilities. These hypothetical units won't measure satisfaction

On Mon, 22 Apr 2019, 09:05 You-Sheng Yang, <email address hidden>
wrote:

> @raphaelbs, I think most of the jobs to be done to fully bring up the
> device should fall on libfprint as pointed out in #41. If you only want
> it to be listed correctly, then a new usbutils release is expected.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1721909
>
> Title:
> Goodix GF3208 (fingerprint reader) not being recognised by
> lsusb(usbutils)
>
> Status in usbutils:
> New
> Status in usbutils package in Ubuntu:
> Confirmed
>
> Bug description:
> The Goodix GF3208 is not being recognised by the system (Dell Inspiron
> 15 7577). What's worse is that it isn't even showing the manufacturer
> vendor id information when doing:
>
> $ lsusb
> Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> Bus 001 Device 004: ID 27c6:5301
> Bus 001 Device 003: ID 8087:0a2b Intel Corp.
> Bus 001 Device 002: ID 046d:c52f Logitech, Inc. Unifying Receiver
> Bus 001 Device 005: ID 0bda:5652 Realtek Semiconductor Corp.
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
>
> Note that the vendor id 27c6 should at least say "Shenzhen Huiding
> Technology Co., Ltd." as per
>
> https://github.com/torvalds/linux/blob/e19b205be43d11bff638cad4487008c48d21c103/Documentation/devicetree/bindings
> /vendor-prefixes.txt
>
> Will/has support been made for the Goodix GF3208 Fingerprint
> reader/scanner?
>
> Thanks in advance,
> Haz
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.04
> Package: linux-image-4.10.0-35-generic 4.10.0-35.39~16.04.1
> ProcVersionSignature: Ubuntu 4.10.0-35.39~16.04.1-generic 4.10.17
> Uname: Linux 4.10.0-35-generic x86_64
> ApportVersion: 2.20.1-0ubuntu2.10
> Architecture: amd64
> CurrentDesktop: Unity
> Date: Sat Oct 7 04:03:25 2017
> InstallationDate: Installed on 2017-10-01 (5 days ago)
> InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64
> (20170801)
> SourcePackage: linux-hwe
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/usbutils/+bug/1721909/+subscriptions
>

Adnan Iftekhar (livenicely) wrote :

I have found a code for Goodix fingerprint sensor. That code is mainly written for Android devices. I have tried to compile it for Ubuntu 19.04. This code would be helpful to write a new driver.

https://github.com/adnanjee/Goodix-GF3208

Adnan Iftekhar (livenicely) wrote :

I have found a code for Goodix fingerprint sensor. That code is mainly written for Android devices. I have tried to compile it for Ubuntu 19.04. This code would be helpful to write a new driver. This code is written for the SPI interface. It would be useful if someone can try to rewrite this code for the USB interface.

https://github.com/adnanjee/Goodix-GF3208

rustyx (rustyx2) wrote :

Also an issue on Samsung Notebook 9 Pro / NP950SBE-K01US.

$ dmesg|grep -i finger
[ 1.911612] usb 1-5: Product: Fingerprint Device
$ lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 03eb:214e Atmel Corp.
Bus 001 Device 003: ID 1bcf:2cb7 Sunplus Innovation Technology Inc.
Bus 001 Device 002: ID 04e8:730a Samsung Electronics Co., Ltd
Bus 001 Device 005: ID 8087:0aaa Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

demonhun7er (demonhun7er) wrote :

Thank you for the information.

On Sat, 8 Jun 2019, 18:45 rustyx, <email address hidden> wrote:

> Also an issue on Samsung Notebook 9 Pro / NP950SBE-K01US.
>
> $ dmesg|grep -i finger
> [ 1.911612] usb 1-5: Product: Fingerprint Device
> $ lsusb
> Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> Bus 001 Device 004: ID 03eb:214e Atmel Corp.
> Bus 001 Device 003: ID 1bcf:2cb7 Sunplus Innovation Technology Inc.
> Bus 001 Device 002: ID 04e8:730a Samsung Electronics Co., Ltd
> Bus 001 Device 005: ID 8087:0aaa Intel Corp.
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1721909
>
> Title:
> Goodix GF3208 (fingerprint reader) not being recognised by
> lsusb(usbutils)
>
> Status in usbutils:
> New
> Status in usbutils package in Ubuntu:
> Confirmed
>
> Bug description:
> The Goodix GF3208 is not being recognised by the system (Dell Inspiron
> 15 7577). What's worse is that it isn't even showing the manufacturer
> vendor id information when doing:
>
> $ lsusb
> Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> Bus 001 Device 004: ID 27c6:5301
> Bus 001 Device 003: ID 8087:0a2b Intel Corp.
> Bus 001 Device 002: ID 046d:c52f Logitech, Inc. Unifying Receiver
> Bus 001 Device 005: ID 0bda:5652 Realtek Semiconductor Corp.
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
>
> Note that the vendor id 27c6 should at least say "Shenzhen Huiding
> Technology Co., Ltd." as per
>
> https://github.com/torvalds/linux/blob/e19b205be43d11bff638cad4487008c48d21c103/Documentation/devicetree/bindings
> /vendor-prefixes.txt
>
> Will/has support been made for the Goodix GF3208 Fingerprint
> reader/scanner?
>
> Thanks in advance,
> Haz
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.04
> Package: linux-image-4.10.0-35-generic 4.10.0-35.39~16.04.1
> ProcVersionSignature: Ubuntu 4.10.0-35.39~16.04.1-generic 4.10.17
> Uname: Linux 4.10.0-35-generic x86_64
> ApportVersion: 2.20.1-0ubuntu2.10
> Architecture: amd64
> CurrentDesktop: Unity
> Date: Sat Oct 7 04:03:25 2017
> InstallationDate: Installed on 2017-10-01 (5 days ago)
> InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64
> (20170801)
> SourcePackage: linux-hwe
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/usbutils/+bug/1721909/+subscriptions
>

sharvani (sharvani198) wrote :

Happens for me on new Dell Inspiron running Bionic. Hope to see some traction on this soon.

Don't, it's a lost cause. I have been tracking this bug for 1.5 years now :)

On Fri, Aug 2, 2019, 8:30 PM sharvani <email address hidden> wrote:

> Happens for me on new Dell Inspiron running Bionic. Hope to see some
> traction on this soon.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1721909
>
> Title:
> Goodix GF3208 (fingerprint reader) not being recognised by
> lsusb(usbutils)
>
> Status in usbutils:
> New
> Status in usbutils package in Ubuntu:
> Confirmed
>
> Bug description:
> The Goodix GF3208 is not being recognised by the system (Dell Inspiron
> 15 7577). What's worse is that it isn't even showing the manufacturer
> vendor id information when doing:
>
> $ lsusb
> Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> Bus 001 Device 004: ID 27c6:5301
> Bus 001 Device 003: ID 8087:0a2b Intel Corp.
> Bus 001 Device 002: ID 046d:c52f Logitech, Inc. Unifying Receiver
> Bus 001 Device 005: ID 0bda:5652 Realtek Semiconductor Corp.
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
>
> Note that the vendor id 27c6 should at least say "Shenzhen Huiding
> Technology Co., Ltd." as per
>
> https://github.com/torvalds/linux/blob/e19b205be43d11bff638cad4487008c48d21c103/Documentation/devicetree/bindings
> /vendor-prefixes.txt
>
> Will/has support been made for the Goodix GF3208 Fingerprint
> reader/scanner?
>
> Thanks in advance,
> Haz
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.04
> Package: linux-image-4.10.0-35-generic 4.10.0-35.39~16.04.1
> ProcVersionSignature: Ubuntu 4.10.0-35.39~16.04.1-generic 4.10.17
> Uname: Linux 4.10.0-35-generic x86_64
> ApportVersion: 2.20.1-0ubuntu2.10
> Architecture: amd64
> CurrentDesktop: Unity
> Date: Sat Oct 7 04:03:25 2017
> InstallationDate: Installed on 2017-10-01 (5 days ago)
> InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64
> (20170801)
> SourcePackage: linux-hwe
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/usbutils/+bug/1721909/+subscriptions
>

Download full text (4.3 KiB)

Lol same.

On Sat, 3 Aug, 2019, 12:35 Andrei Marinescu, <email address hidden>
wrote:

> Don't, it's a lost cause. I have been tracking this bug for 1.5 years
> now :)
>
> On Fri, Aug 2, 2019, 8:30 PM sharvani <email address hidden> wrote:
>
> > Happens for me on new Dell Inspiron running Bionic. Hope to see some
> > traction on this soon.
> >
> > --
> > You received this bug notification because you are subscribed to the bug
> > report.
> > https://bugs.launchpad.net/bugs/1721909
> >
> > Title:
> > Goodix GF3208 (fingerprint reader) not being recognised by
> > lsusb(usbutils)
> >
> > Status in usbutils:
> > New
> > Status in usbutils package in Ubuntu:
> > Confirmed
> >
> > Bug description:
> > The Goodix GF3208 is not being recognised by the system (Dell Inspiron
> > 15 7577). What's worse is that it isn't even showing the manufacturer
> > vendor id information when doing:
> >
> > $ lsusb
> > Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> > Bus 001 Device 004: ID 27c6:5301
> > Bus 001 Device 003: ID 8087:0a2b Intel Corp.
> > Bus 001 Device 002: ID 046d:c52f Logitech, Inc. Unifying Receiver
> > Bus 001 Device 005: ID 0bda:5652 Realtek Semiconductor Corp.
> > Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> >
> > Note that the vendor id 27c6 should at least say "Shenzhen Huiding
> > Technology Co., Ltd." as per
> >
> >
> https://github.com/torvalds/linux/blob/e19b205be43d11bff638cad4487008c48d21c103/Documentation/devicetree/bindings
> > /vendor-prefixes.txt
> >
> > Will/has support been made for the Goodix GF3208 Fingerprint
> > reader/scanner?
> >
> > Thanks in advance,
> > Haz
> >
> > ProblemType: Bug
> > DistroRelease: Ubuntu 16.04
> > Package: linux-image-4.10.0-35-generic 4.10.0-35.39~16.04.1
> > ProcVersionSignature: Ubuntu 4.10.0-35.39~16.04.1-generic 4.10.17
> > Uname: Linux 4.10.0-35-generic x86_64
> > ApportVersion: 2.20.1-0ubuntu2.10
> > Architecture: amd64
> > CurrentDesktop: Unity
> > Date: Sat Oct 7 04:03:25 2017
> > InstallationDate: Installed on 2017-10-01 (5 days ago)
> > InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64
> > (20170801)
> > SourcePackage: linux-hwe
> > UpgradeStatus: No upgrade log present (probably fresh install)
> >
> > To manage notifications about this bug go to:
> > https://bugs.launchpad.net/usbutils/+bug/1721909/+subscriptions
> >
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1721909
>
> Title:
> Goodix GF3208 (fingerprint reader) not being recognised by
> lsusb(usbutils)
>
> Status in usbutils:
> New
> Status in usbutils package in Ubuntu:
> Confirmed
>
> Bug description:
> The Goodix GF3208 is not being recognised by the system (Dell Inspiron
> 15 7577). What's worse is that it isn't even showing the manufacturer
> vendor id information when doing:
>
> $ lsusb
> Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> Bus 001 Device 004: ID 27c6:5301
> Bus 001 Device 003: ID 8087:0a2b Intel Corp.
> Bus 001 Device 002: ID 046d:c52f Logitech, Inc. Unifying Receive...

Read more...

Hassan Williamson (hazrpg) wrote :

lol, how do you think I feel? I started the bug report!

demonhun7er (demonhun7er) wrote :

i feel terrible for you

On Fri, Aug 9, 2019 at 12:50 AM Hassan Williamson <
<email address hidden>> wrote:

> lol, how do you think I feel? I started the bug report!
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1721909
>
> Title:
> Goodix GF3208 (fingerprint reader) not being recognised by
> lsusb(usbutils)
>
> Status in usbutils:
> New
> Status in usbutils package in Ubuntu:
> Confirmed
>
> Bug description:
> The Goodix GF3208 is not being recognised by the system (Dell Inspiron
> 15 7577). What's worse is that it isn't even showing the manufacturer
> vendor id information when doing:
>
> $ lsusb
> Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> Bus 001 Device 004: ID 27c6:5301
> Bus 001 Device 003: ID 8087:0a2b Intel Corp.
> Bus 001 Device 002: ID 046d:c52f Logitech, Inc. Unifying Receiver
> Bus 001 Device 005: ID 0bda:5652 Realtek Semiconductor Corp.
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
>
> Note that the vendor id 27c6 should at least say "Shenzhen Huiding
> Technology Co., Ltd." as per
>
> https://github.com/torvalds/linux/blob/e19b205be43d11bff638cad4487008c48d21c103/Documentation/devicetree/bindings
> /vendor-prefixes.txt
>
> Will/has support been made for the Goodix GF3208 Fingerprint
> reader/scanner?
>
> Thanks in advance,
> Haz
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.04
> Package: linux-image-4.10.0-35-generic 4.10.0-35.39~16.04.1
> ProcVersionSignature: Ubuntu 4.10.0-35.39~16.04.1-generic 4.10.17
> Uname: Linux 4.10.0-35-generic x86_64
> ApportVersion: 2.20.1-0ubuntu2.10
> Architecture: amd64
> CurrentDesktop: Unity
> Date: Sat Oct 7 04:03:25 2017
> InstallationDate: Installed on 2017-10-01 (5 days ago)
> InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64
> (20170801)
> SourcePackage: linux-hwe
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/usbutils/+bug/1721909/+subscriptions
>

Hello_ZB (hello-zb) wrote :

I have the same issue on my Dell Vostro 5581.

OS: Ubuntu 18.04 bionic
Kernel: x86_64 Linux 4.15.0-58-generic

lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 0bda:5521 Realtek Semiconductor Corp.
Bus 001 Device 003: ID 27c6:538c
Bus 001 Device 008: ID 8087:0aaa Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I'm ready to help with testing

Evan Booyens (evanbooyens) wrote :

I have the same issue on my Dell Inspiron 7577
OS: Ubuntu 18.04 bionic
Kernel: 5.3.6-050306-generic #201910111731 SMP Fri Oct 11 17:34:45 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

lsusb
Bus 002 Device 002: ID 0781:5583 SanDisk Corp.
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 27c6:5301
Bus 001 Device 003: ID 8087:0a2b Intel Corp.
Bus 001 Device 007: ID 0c45:6a08 Microdia
Bus 001 Device 006: ID 04b4:0033 Cypress Semiconductor Corp. Mouse
Bus 001 Device 004: ID 2516:007f
Bus 001 Device 002: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Good News

Its working in 19.10

adriaan@Dell7577:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 27c6:5301 HTMicroelectronics Goodix Fingerprint Device
Bus 001 Device 003: ID 8087:0a2b Intel Corp.
Bus 001 Device 002: ID 046d:c534 Logitech, Inc. Unifying Receiver
Bus 001 Device 005: ID 0c45:6a08 Microdia Integrated_Webcam_HD
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Antonio Ospite (ospite) wrote :

As a usbutils bug this can be closed IMHO, the changes mentioned in #44 landed upstream and usb.ids has also been updated for better strings: https://usb-ids.gowdy.us/read/UD/27c6

These new string will be used at some point when hwdb syncs with usb.ids.

As for an actual driver, experiments are still ongoing at the link from #41

hackel (hackel) on 2020-01-15
Changed in usbutils (Ubuntu):
status: Confirmed → Fix Released
Changed in usbutils:
status: New → Fix Released
Ivaylo Hubanov (sniffski) wrote :

working? or just showing the correct name in lsusb? I don't see this device loading any module in kernel to recognize and use it...

IXI (rustythorn) wrote :

so it works in 19.10? crap, i just had to roll back from 19.10 to 18.04 to run ROS2

Vincent Gerris (vgerris) wrote :

I think this should not be closed.
I have :
Bus 001 Device 003: ID 27c6:538c Shenzhen Goodix Technology Co.,Ltd. Fingerprint Reader
in my lsusb output, but there is no driver loaded and thus fprintd cannot be setup.

For this specific ticket there is a driver request at the project:
https://gitlab.freedesktop.org/libfprint/libfprint/-/issues/161

I think it should be linked to that.

Let's hope the folks there or perhaps Dell will fix this, or any other savvy developer.
Until then, I think this bug report should remain open to track it.
For other device IDs bugs should be opened too ideally.
I hope this helps.

Brian Chen (ihasdapie) wrote :

Kubuntu 20.04 recognizes the fingerprint scanner in lsusb but not much else can be done about it

Output of lsusb:

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 04f2:b6d9 Chicony Electronics Co., Ltd Integrated Camera
Bus 003 Device 002: ID 27c6:55a4 Shenzhen Goodix Technology Co.,Ltd. Goodix FingerPrint Device
Bus 003 Device 005: ID 062a:4c01 MosArt Semiconductor Corp. 2.4G Keyboard Mouse
Bus 003 Device 004: ID 0bda:c123 Realtek Semiconductor Corp. 802.11ac WLAN Adapter
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

aryan (aryan0154762) wrote :

same here on my avita liber
Operating System: Manjaro Linux
KDE Plasma Version: 5.18.4
KDE Frameworks Version: 5.69.0
Qt Version: 5.14.2
Kernel Version: 5.4.35-1-MANJARO
OS Type: 64-bit
Processors: 8 × Intel® Core™ i5-8250U CPU @ 1.60GHz
Memory: 7.7 GiB of RAM

[aryan@aryan-ns13a2 ~]$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 27c6:5740 Shenzhen Goodix Technology Co.,Ltd. Fingerprint Reader
Bus 001 Device 004: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 003: ID 8087:0a2a Intel Corp.
Bus 001 Device 002: ID 0817:7691 MSD 30FPS
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

the ID 27c6:5740 Shenzhen Goodix Technology Co.,Ltd. Fingerprint Reader
is not functioning in fingerprint-gui or fprintd though the system does recognize the device as can be seen in the above output screen

Goodix fingerprint device not recognized on HUAWEI Metbook D, with Ubuntu 20.04:
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 8087:0a2b Intel Corp.
Bus 001 Device 002: ID 0408:1020 Quanta Computer, Inc. hm1091_techfront
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Vincent Gerris (vgerris) wrote :

try the 5.4.x or 5.6.x oem kernel (I'm running Ubuntu 20.04 LTS).

Bus 001 Device 002: ID 27c6:538c Shenzhen Goodix Technology Co.,Ltd. Fingerprint Reader
works for me.

Also check:
https://www.reddit.com/r/Dell/comments/hq3kf3/xps_13_fingerprint_drivers_are_here/

They make my device with the above id work, it might work for yours.

Check :
https://git.launchpad.net/~oem-solutions-engineers/libfprint-2-tod1-goodix/+git/libfprint-2-tod1-goodix
for more info.

Also, you may need to run:
sudo pam-auth-update
and enable fingerprint to have it work for login.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.