[Gmail] can't switch to another account

Bug #1324848 reported by David Barth on 2014-05-30
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
The Webapps-core project
High
David Barth
URL Dispatcher
Incomplete
High
Unassigned
webbrowser-app (Ubuntu)
Undecided
Unassigned

Bug Description

When using the Gmail webapp it is currently impossible to switch to another account.

To reproduce:
- login in Gmail with your user account
- go to the left hand side menu button
- select the user account button at the top; you should see an Accounts dialog to switch users
- select 'Sign into another account...,"

Expected result: you go to the account signon page
Actual result: nothing happens.

Related branches

David Barth (dbarth) wrote :

Further investigations reveal this error in the logs:

Opening: popup window https://accounts.google.com/AddSession?hl=en&service=mail&continue=https://mail.google.com/mail/mu/mp/100/?login%3D1 in the browser window.
[0530/095138:ERROR:browser_main_loop.cc(240)] <unknown>: Unable to dispatch url 'https://accounts.google.com/AddSession?hl=en&service=mail&continue=https://mail.google.com/mail/mu/mp/100/?login%3D1':GDBus.Error:com.canonical.URLDispatcher.BadURL: URL 'https://accounts.google.com/AddSession?hl=en&service=mail&continue=https://mail.google.com/mail/mu/mp/100/?login%3D1' is not handleable by the URL Dispatcher

There are 2 issues here: url_dispatcher should be able to dispatch the link. But in the first place, the popup should open in the webapp container, since it is still part of the valid URL patterns.

David Barth (dbarth) on 2014-05-30
tags: added: webapps-hotlist
Changed in webapps-core:
status: New → Confirmed
importance: Undecided → High
Ted Gould (ted) on 2014-06-04
affects: urldispatcher → url-dispatcher
Ted Gould (ted) wrote :

Working with bfiller on IRC it seemed that the issue was with updating the URL Dispatcher database, we weren't able to recreate it, but felt like there was a chance it was happening more often. In that vein we're trying to get more data with a branch that will report recoverable errors on updates if we do get an issue. Hopefully that'll allow us to see if it was a one-off or a more systemic problem.

Marking this as Needs Information for now.

https://code.launchpad.net/~ted/url-dispatcher/recoverable-inserts/+merge/222058

Changed in url-dispatcher:
status: New → Incomplete
importance: Undecided → High
assignee: nobody → Ted Gould (ted)
Alexander Sack (asac) wrote :

Ted, my issue is 100% reproducible. see the duplicate bug and the screenshot to find the link that never works here on devel.

Alexander Sack (asac) wrote :

please update me on IRC. This stops me from doing my work as I dont have another phone anymore and I can't have my two main mail accounts used at the same time in the gmail webapp.

Ted Gould (ted) wrote :

Update, the recoverable error is happening on the smoke testing system, an example is here:

http://ci.ubuntu.com/smokeng/utopic/touch/mako/70:20140606:20140530/8429/calendar_app/

Looking at the error there and the log files along with other tests that also have it didn't lead to any conclusions so I've got an MR up to get more data to try and figure out what's up. My theory is that somehow the tables don't get created in the DB correctly, as it's the only reason that the SQL should fail to parse.

https://code.launchpad.net/~ted/url-dispatcher/error-data/+merge/222363

Ted Gould (ted) wrote :

Also, just to update people who might not have followed the conversation on IRC. The issue is that the cache database is missing data (specifically https). Once that happens, the webapps break is 100% reproducible. What's unclear is how the cache database ends up in that state. As a work around you can delete the cache database and it will get reconstructed.

rm ~/.cache/url-dispatcher/urls-1.db
<restart your session>

David Barth (dbarth) on 2014-06-11
Changed in webapps-core:
status: Confirmed → In Progress
assignee: nobody → David Barth (dbarth)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+14.10.20140612.1-0ubuntu1

---------------
webbrowser-app (0.23+14.10.20140612.1-0ubuntu1) utopic; urgency=low

  [ Ubuntu daily release ]
  * New rebuild forced

  [ David Barth ]
  * Accept navigation inside popups if the redirection stays within the
    set of accepted URLs. This helps support the account switching
    feature in Gmail for example. An additional heuristics ensures that
    trampoline URLs don't leave a blank window in their originating
    webapp, as we navigate back to the page just before the trampoline.
    This avoids regressions in Facebook, Twitter and other apps using
    popup redirects to open external links. (LP: #1324848)
 -- Ubuntu daily release <email address hidden> Thu, 12 Jun 2014 20:27:44 +0000

Changed in webbrowser-app (Ubuntu):
status: New → Fix Released
David Barth (dbarth) wrote :

The ability to switch between 2 gmail accounts has been fixed in the webapp itself.

Changed in webapps-core:
status: In Progress → Fix Released
Ted Gould (ted) on 2017-04-12
Changed in url-dispatcher:
assignee: Ted Gould (ted) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers