Upstart doesn't respond to control-c

Bug #67799 reported by GPLed on 2006-10-23
4
Affects Status Importance Assigned to Milestone
upstart
Undecided
Unassigned

Bug Description

sysvinit uses to respond to control-c for stopping a particular service immediately (since the services were basically scripts). Is there anyway to do this in upstart (except Ctrl-Alt-Del which shuts down the entire boot process)?

Yes, mark the jobs you wish to be able to send ^C to by editing the /etc/event.d file (probably rcS or rc2?) and adding the following line at the bottom:

  console owner

The reason this is disabled as default is that we send the output to /var/log/boot instead

Changed in upstart:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers