upstart works as expected, notify-dbus-address tests fail depending on system-wide session jobs

Bug #1315767 reported by Dimitri John Ledkov on 2014-05-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
upstart
Undecided
Unassigned
upstart (Ubuntu)
Undecided
Dimitri John Ledkov

Bug Description

not ok 204 - ensure Session Init connects to D-Bus session bus when notified
 wrong string value, expected 'init (upstart [0-9.][0-9.]*' got 'initctl: Name "com.ubuntu.Upstart" does not exist'
 at tests/test_initctl.c:17285 (test_dbus_connection).
/bin/bash: line 5: 6113 Aborted ${dir}$tst
FAIL: test_initctl

I've seen this failure on amd64, arm64 and powerpc. Retries did eventually pass the test-suite on amd64 & powerpc. However arm64 still fails on the official distro builders.

Related branches

Changed in upstart (Ubuntu):
assignee: nobody → James Hunt (jamesodhunt)
Dimitri John Ledkov (xnox) wrote :

After starting upstart i've asserted that no jobs are running, however there there a few of them running, including user session dbus job that did notify upstart of its dbus address. Later in the test when we tried to notify our test upstart with test dbus address, test upstart would not connect to test dbus since it only accept dbus connections once and was already running on the other dbus.

This is racy & dependant on the jobs configured in /usr/share/upstart/session/

I've resolved this using "--no-startup-event" option. But it is inherently racy, as potentially all user-session test upstart spawns are affected. Thus something generic should be implemented in the test_common_utilities, such that when test-upstart in user session mode is spawned global jobs are not executed.

summary: - intermitent test failure
+ upstart works as expected, notify-dbus-address tests fail depending on
+ system-wide session jobs
Changed in upstart:
status: New → Confirmed
Changed in upstart (Ubuntu):
assignee: James Hunt (jamesodhunt) → Dimitri John Ledkov (xnox)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upstart - 1.12.1-0ubuntu6

---------------
upstart (1.12.1-0ubuntu6) utopic; urgency=medium

  * Map force-reload to restart command in init-functions hook.
  * Use variable expansion, instead of basename as that is shipped in
    /usr.
  * Resolve test-failure, when dbus user session job is launched
    accidentally by unit-tests. (LP: #1315767)
 -- Dimitri John Ledkov <email address hidden> Wed, 07 May 2014 20:15:35 +0100

Changed in upstart (Ubuntu):
status: New → Fix Released
Changed in upstart:
status: Confirmed → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers