Kernel Panic when running 'sudo dpkg --configure -a' ?

Bug #1120660 reported by Rainer Rohde on 2013-02-09
58
This bug affects 10 people
Affects Status Importance Assigned to Milestone
upstart
High
James Hunt
upstart (Ubuntu)
High
James Hunt

Bug Description

Recently, I am seeing a few kernel panics. [ Assertion failed in log_serialise ]

The latest one happens when asked to run E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

I've also seen them when trying to change compiz settings.

They seem to have started a couple of days ago in the middle of an upgrade, I guess during some Xorg and/or nvidia related upgrades.

However, it happens now each and every time when running 'sudo dpkg --configure -a'.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: linux-image-3.8.0-5-generic 3.8.0-5.10
ProcVersionSignature: Ubuntu 3.8.0-5.10-generic 3.8.0-rc6
Uname: Linux 3.8.0-5-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: rrohde 2427 F.... pulseaudio
 /dev/snd/controlC0: rrohde 2427 F.... pulseaudio
Date: Sat Feb 9 16:33:02 2013
MachineType: ASUSTeK COMPUTER INC. G75VW
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 EFI VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-5-generic root=UUID=c8cd22e4-05f7-4b13-94d4-1899febff264 ro elevator=noop acpi_osi=linux splash acpi_backlight=vendor quiet
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-5-generic N/A
 linux-backports-modules-3.8.0-5-generic N/A
 linux-firmware 1.101
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/06/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: G75VW.222
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: G75VW
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrG75VW.222:bd11/06/2012:svnASUSTeKCOMPUTERINC.:pnG75VW:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnG75VW:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: G75VW
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

Related branches

Rainer Rohde (rainer-rohde) wrote :
Rainer Rohde (rainer-rohde) wrote :

Ok, just now tried to click on "software updater" from the Unity launcher, an I got a kernel panic right away. :(

Rainer Rohde (rainer-rohde) wrote :

To catch the kernel panic message, I ran apt-get update && apt-get dist-upgrade from the command-line. Please see screenshot attached. I can reproduce this every time.

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Rainer Rohde (rainer-rohde) wrote :

I guess it comes down to lib6c:i386. I believe I need this to run Crossover and Skype and whatnot...

Tobias Wolf (towolf) wrote :

I get this too and have narrowed it down to the re-exec of upstart in some packages dpkg postinst scripts.

To trigger the panic you can just run "sudo telinit u"

When I removed the Upstart rexec lines from libc6 and libjson0 postinst the dpkg configure went through.

affects: linux (Ubuntu) → upstart (Ubuntu)
description: updated
philuser (philuser) wrote :

 Me too am affected by this bug. after the last raring upgrade, the process is terminated with the message:
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

After running the command offered, I came across the bug 'kernel panics' see the attached picture.

The 'sudo telinit u' causes the same error panic.

No way to make another upgrade !
Y is there a way to delete the current dpkg?

James Hunt (jamesodhunt) wrote :

Rainer - thanks for reporting this bug.

Please could those affected by this bug comment on whether:

- /var/log/upstart/ exists and is writeable
- their disks are full ('df -h')

James Hunt (jamesodhunt) wrote :

... also, if you can recreate the problem via 'sudo telinit u', please can you run the following command (does not need to be run as root) and append the details to this bug:

initctl list

Thanks

philuser (philuser) wrote :
Download full text (10.4 KiB)

here is the results of the following command

philuser@meghost:~$ ls -la /var/log/upstart/
total 380
drwxr-xr-x 1 root root 3774 févr. 11 09:19 .
drwxr-xr-x 1 root root 1270 févr. 11 10:36 ..
-rw-r----- 1 root root 81 févr. 6 22:14 alsa-restore.log.1.gz
-rw-r----- 1 root root 81 févr. 5 09:00 alsa-restore.log.2.gz
-rw-r----- 1 root root 140 févr. 1 13:57 alsa-restore.log.3.gz
-rw-r----- 1 root root 66 févr. 4 07:39 console-setup.log.1.gz
-rw-r----- 1 root root 78 févr. 1 13:17 dbus.log.1.gz
-rw-r----- 1 root root 195 févr. 10 13:52 gdm.log
-rw-r----- 1 root root 116 févr. 1 15:56 gdm.log.1.gz
-rw-r----- 1 root root 70 févr. 11 10:36 gssd.log
-rw-r----- 1 root root 180 févr. 11 07:46 gssd.log.1.gz
-rw-r----- 1 root root 63 févr. 10 12:01 gssd.log.2.gz
-rw-r----- 1 root root 178 févr. 6 22:14 gssd.log.3.gz
-rw-r----- 1 root root 202 févr. 5 17:01 gssd.log.4.gz
-rw-r----- 1 root root 30 févr. 11 10:36 hybrid-gfx.log
-rw-r----- 1 root root 38 févr. 11 07:46 hybrid-gfx.log.1.gz
-rw-r----- 1 root root 38 févr. 10 12:01 hybrid-gfx.log.2.gz
-rw-r----- 1 root root 38 févr. 6 22:14 hybrid-gfx.log.3.gz
-rw-r----- 1 root root 38 févr. 5 17:01 hybrid-gfx.log.4.gz
-rw-r----- 1 root root 38 févr. 5 07:39 hybrid-gfx.log.5.gz
-rw-r----- 1 root root 38 févr. 4 07:39 hybrid-gfx.log.6.gz
-rw-r----- 1 root root 35 févr. 2 13:00 hybrid-gfx.log.7.gz
-rw-r----- 1 root root 53 févr. 4 07:39 kmod.log.1.gz
-rw-r----- 1 root root 366 févr. 11 10:36 libvirt-bin.log
-rw-r----- 1 root root 243 févr. 11 07:46 libvirt-bin.log.1.gz
-rw-r----- 1 root root 172 févr. 10 12:01 libvirt-bin.log.2.gz
-rw-r----- 1 root root 227 févr. 6 22:14 libvirt-bin.log.3.gz
-rw-r----- 1 root root 207 févr. 5 17:01 libvirt-bin.log.4.gz
-rw-r----- 1 root root 280 févr. 5 07:39 libvirt-bin.log.5.gz
-rw-r----- 1 root root 191 févr. 4 07:39 libvirt-bin.log.6.gz
-rw-r----- 1 root root 2432 févr. 11 10:36 modemmanager.log
-rw-r----- 1 root root 689 févr. 11 07:46 modemmanager.log.1.gz
-rw-r----- 1 root root 365 févr. 10 12:01 modemmanager.log.2.gz
-rw-r----- 1 root root 642 févr. 6 22:14 modemmanager.log.3.gz
-rw-r----- 1 root root 571 févr. 5 17:01 modemmanager.log.4.gz
-rw-r----- 1 root root 838 févr. 5 07:39 modemmanager.log.5.gz
-rw-r----- 1 root root 367 févr. 4 07:39 modemmanager.log.6.gz
-rw-r----- 1 root root 299 févr. 2 13:00 modemmanager.log.7.gz
-rw-r----- 1 root root 225 févr. 1 14:08 procps.log.1.gz
-rw-r----- 1 root root 216 févr. 6 17:41 procps-static-network-up.log.1.gz
-rw-r----- 1 root root 232 févr. 5 17:01 procps-static-network-up.log.2.gz
-rw-r----- 1 root root 237 févr. 5 07:39 procps-static-network-up.log.3.gz
-rw-r----- 1 root root 226 févr. 4 07:39 procps-static-network-up.log.4.gz
-rw-r----- 1 root root 229 févr. 2 13:00 procps-static-network-up.log.5.gz
-rw-r----- 1 root root 226 févr. 4 07:39 procps-virtual-filesystems.log.1.gz
-rw-r----- 1 root root 124 févr. 11 10:36 qemu-kvm.log
-rw-r----- 1 root root 84 févr. 11 07:46 qemu-kvm.log.1.gz
-rw-r----- 1 root root 82 févr. 10 12:01 qemu-kvm.log.2.gz
-rw-r----- 1 root root 82 févr. 6 22:14 qemu-kvm.log.3.gz
-rw-r----- 1 root root 82...

James Hunt (jamesodhunt) wrote :

@philuser - thanks, but pleaes can you run 'initctl list' on a system that exhibits the bug when 'sudo telinit u' is run?

philuser (philuser) wrote :

All my command were made ​​for the system affected by the bug, that after reboot because the bug completely freezes the computer.
I am a dipose perform other test, if you want.

philuser (philuser) wrote :

'sudo telinit u' crash immediaty the PC.

philuser (philuser) wrote :

'sudo telinit u' command crashes the pc with the symptom already described, then it is no longer possible to switch from another order

Tobias Wolf (towolf) wrote :
Download full text (3.3 KiB)

To chime in myself and give a differential diagnosis ...

I don’t have /var/log/upstart because /var/log is a tmpfs. Do I have to create this subfolder?

Here’s the output from my PC:

towolf@ovo:~$ initctl list
avahi-daemon start/running, process 845
mountall-net stop/waiting
mountnfs-bootclean.sh start/running
passwd stop/waiting
rc stop/waiting
rsyslog start/running, process 841
screen-cleanup stop/waiting
udev start/running, process 338
upstart-udev-bridge start/running, process 329
ureadahead-other stop/waiting
console-setup stop/waiting
hwclock-save stop/waiting
idmapd-mounting stop/waiting
plymouth-log stop/waiting
rpcbind-boot stop/waiting
failsafe stop/waiting
hybrid-gfx stop/waiting
mountall.sh start/running
rfkill-store stop/waiting
statd stop/waiting
atd start/running, process 977
dbus start/running, process 728
mounted-var stop/waiting
plymouth stop/waiting
portmap stop/waiting
resolvconf start/running
ssh start/running, process 718
udev-fallback-graphics stop/waiting
checkroot.sh start/running
control-alt-delete stop/waiting
hwclock stop/waiting
mounted-proc stop/waiting
network-manager start/running, process 838
alsa-store stop/waiting
cups-browsed start/running, process 956
setvtrgb stop/waiting
shutdown stop/waiting
statd-mounting stop/waiting
alsa-restore stop/waiting
cron start/running, process 5873
gdm start/running, process 962
lightdm stop/waiting
mountall stop/waiting
mounted-debugfs stop/waiting
mountkernfs.sh start/running
binfmt-support stop/waiting
console stop/waiting
mounted-run stop/waiting
acpid start/running, process 959
bluetooth stop/waiting
checkfs.sh start/running
checkroot-bootclean.sh start/running
kmod stop/waiting
mountnfs.sh start/running
plymouth-stop stop/waiting
rcS stop/waiting
wait-for-state stop/waiting
bootmisc.sh start/running
flush-early-job-log stop/waiting
friendly-recovery stop/waiting
gssd-mounting stop/waiting
rc-sysinit stop/waiting
cups stop/waiting
pulseaudio stop/waiting
upstart-socket-bridge start/running, process 861
anacron start/running, process 15918
mountdevsubfs.sh start/running
tty2 start/running, process 932
udevtrigger stop/waiting
container-detect stop/waiting
mounted-dev stop/waiting
mtab.sh start/running
tty3 start/running, process 934
udev-finish stop/waiting
hostname stop/waiting
mountall-reboot stop/waiting
gssd stop/waiting
mountall-shell stop/waiting
mounted-tmp stop/waiting
network-interface (lo) start/running
network-interface (wlan0) start/running
plymouth-splash stop/waiting
plymouth-upstart-bridge stop/waiting
portmap-wait stop/waiting
tty1 stop/waiting
udevmonitor stop/waiting
usb-creator-gtk stop/waiting
dmesg stop/waiting
mountall-bootclean.sh start/running
network-interface-security (network-manager) start/running
network-interface-security (network-interface/wlan0) start/running
network-interface-security (network-interface/lo) start/running
network-interface-security (networking) start/running
networking start/running
procps stop/waiting
rfkill-restore stop/waiting
console-font stop/waiting
idmapd stop/waiting
network-interface-container stop/waiting
ureadahead stop/waiting

towolf@ovo:~$ df -h /var/log/
Filesystem Size Used Avail Use% Mounted on
tm...

Read more...

James Hunt (jamesodhunt) wrote :

@Tobias - thanks for confirming. It seems this bug relates to directory /var/log/upstart/ not existing (it will have been auto-created on a default system).

So, one way to work around this issue is to simply create the directory:

$ sudo mkdir -p /var/log/upstart

(This avoids having to modify the postinst scripts which call 'telinit u':

/var/lib/dpkg/info/upstart.postinst
/var/lib/dpkg/info/libjson0:*.postinst
/var/lib/dpkg/info/libc6:*.postinst

)

Could you confirm that creating /var/log/upstart resolves the issue for you?

Tobias Wolf (towolf) wrote :

James, I cannot confitm that this fixes the issue.

Manually creating it with mkdir /var/log/upstart and doing telinit u still panicked the kernel.

Then I put mkdir /var/log/upstart into /etc/rc.local and it still panicked after a reboot.

Is it that the creation happens too late?

James Hunt (jamesodhunt) on 2013-02-11
Changed in upstart (Ubuntu):
importance: Undecided → High
assignee: nobody → James Hunt (jamesodhunt)
James Hunt (jamesodhunt) wrote :

I am now able to reproduce this issue.

The simplest way to work around this issue until we release an update is to boot with '--no-log' to stop Upstart logging any job output.

James Hunt (jamesodhunt) on 2013-02-11
Changed in upstart:
importance: Undecided → High
status: New → Confirmed
assignee: nobody → James Hunt (jamesodhunt)
philuser (philuser) wrote :

Right... it work for me

Thank

filip (bandit-s-fw) wrote :

workaround with --no-log worked

Lito (lito-eordes) wrote :

I have the same problem.

I have my /var/log/ folder in a tmpfs filesystem and the dpkg --configure -a and I have a script to create the default /var/log and /var/cache folders. The folder /var/log/upstart exists.

Please, can you explain me where I need to add the "--no-log" option?

Thanks :)

filip (bandit-s-fw) wrote :

@Lito
in the grub boot screen (if you don't see it, press shift right after bios, sometimes you need to try several times as for me it doesn't always works and it just boots right away)
use the 2nd entry (advanced i think it is called)
than highlight the first entry and hit e to edit
there you add the --no-log in between the commands quiet and (no)splash
I editted on 2 places, you will see there some kind of if loop.
than just hit F10 to boot. That worked for me.

Lito (lito-eordes) wrote :

Ok, it's the same line that I can edit in /etc/default/grub?

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash elevator=deadline"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash elevator=deadline --no-log"

Thanks.

James Hunt (jamesodhunt) on 2013-03-08
Changed in upstart:
status: Confirmed → Fix Released
Changed in upstart (Ubuntu):
status: Confirmed → Fix Released

Has this been fixed? I seem to be affected by this bug, yet I cannot update upstart to the newest version, as it triggers kernel panic when it's configured. I also cannot boot up with the --no-log option, because this causes a kernel panic immediately when the system begins to boot. I would welcome ideas on how to upgrade upstart while omitting the configuring phase, or getting around the kernel panic in some other way.

Should I report a new bug, or is it actually the same as this one, and it's just my system that cannot upgrade?

James Hunt (jamesodhunt) wrote :

@Rafal - yes, the problem has been fixed in Ubuntu. Are you sure you are specifying the "--no-log" option correctly (two leading dashes)? The problem that was fixed relates directly to logging and that option disables logging entirely.

If you still have a problem, please do the following:

1) modify the boot command line in grub to add "--no-log --debug" but also remove "quiet" and "splash".
2) boot
3) take a picture of the messages on the screen and attach to this bug if possible.

alien (nalex2004) wrote :

Almost every update now on Ubuntu 13.10 gives kernel panic during update.
Message like "kernel panic ..." something about "..init.."
next line "drm_kms_helper: panic occurred, switching back to text console"
lenovo g575. i386

James Hunt (jamesodhunt) wrote :

@alien: Please raise a new bug with full details - take a picture of the screen showing these messages if possible and attach to the bug.

My system, 64-bit Trusty, also got this bug when running 'sudo dpkg --configure -a'.
Alas, there are no log entries for this panic.
Please, take a look at the attachments and initctl list output below:

user-03-709@709-3:~$ initctl list
indicator-application start/running, process 2626
indicator-sync start/running, process 2628
unicast-local-avahi stop/waiting
update-notifier-crash stop/waiting
update-notifier-hp-firmware stop/waiting
xsession-init stop/waiting
dbus start/running, process 2328
update-notifier-cds stop/waiting
gnome-session start/running, process 2387
ssh-agent start/running
unity7 stop/waiting
unity-voice-service stop/waiting
upstart-dbus-session-bridge start/running, process 2374
logrotate stop/waiting
unity-panel-service start/running, process 2452
hud start/running, process 2381
im-config start/running
unity-gtk-module stop/waiting
session-migration stop/waiting
upstart-dbus-system-bridge start/running, process 2456
at-spi2-registryd stop/waiting
update-notifier-release stop/waiting
indicator-datetime start/running, process 2636
indicator-sound start/running, process 2638
upstart-file-bridge start/running, process 2373
gnome-settings-daemon start/running, process 2377
window-stack-bridge start/running, process 2340
re-exec stop/waiting
upstart-event-bridge start/running, process 2336
indicator-session start/running, process 2640

James Hunt (jamesodhunt) wrote :

@Aurel - please raise a new bug by running "ubuntu-bug upstart" as this will attach all relevant information to the bug to allow us to investigate the problem. Thanks.

Yep, got the same issue on trusty.

The last thing on the console I see is setting up libc6:amd64 and then it changes into a black screen with a blinking cursor.
When I boot by adding "text" to grub I see a kernel panic which I am unable to capture in a log file.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers