upstart needs explicit chroot tests

Reported by James Hunt on 2012-11-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
upstart
Medium
Unassigned

Bug Description

Upstart has no explicit tests for running jobs within a chroot environment. Once bug 1075976 and bug 1079358 are resolved, we should add a new autopkgtest which performs atleast the following tests:

- Ensure a job within a chroot is known to Upstart.
- Ensure a job within a chroot can be started.
- Ensure a job within a chroot can be stopped.
- Ensure a job within a chroot can be restarted.
- Ensure initctl within the chroot cannot control or access any system jobs outside the chroot.
- Ensure initctl within the chroot cannot control or access any user jobs outside the chroot.
- Ensure initctl running outside any chroot is unable to access and or manipulate any job within a chroot.
- Ensure that any jobs run from within the chroot log to /var/log/upstart/ *within* the chroot (see bug 1079710).

= "Nice-to-haves" =

- Ensure initctl within the chroot cannot control or access any jobs in *other* chroots.

James Hunt (jamesodhunt) on 2012-11-16
Changed in upstart:
importance: Undecided → Medium
Clint Byrum (clint-fewbar) wrote :

James, this would seem to be "Triaged", since those two bugs are now Fix Released.

Changed in upstart:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers