State target of SIGTERM more precisely

Reported by Don Jones on 2012-02-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Upstart Cookbook
Undecided
James Hunt
upstart (Ubuntu)
Undecided
James Hunt

Bug Description

The line "The SIGTERM signal is sent to the main process. See signal(7)." in section "Stopping a Job" [1] is not precise.

The SIGTERM signal is sent to the process group, if the group can be determined. This means that all processes belonging to this service will receive the SIGTERM signal.

[1] http://upstart.ubuntu.com/cookbook/#id106

James Hunt (jamesodhunt) wrote :

Thank you for reporting this issue.

Since this also affects upstart-events(7), I'm marking this as affecting Upstart in Ubuntu.

Changed in upstart-cookbook:
status: New → Confirmed
Changed in upstart (Ubuntu):
status: New → Confirmed
Changed in upstart-cookbook:
assignee: nobody → James Hunt (jamesodhunt)
Changed in upstart (Ubuntu):
assignee: nobody → James Hunt (jamesodhunt)
James Hunt (jamesodhunt) on 2012-04-18
Changed in upstart (Ubuntu):
status: Confirmed → Fix Released
Changed in upstart-cookbook:
status: Confirmed → In Progress
James Hunt (jamesodhunt) on 2012-04-26
Changed in upstart-cookbook:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers