please make distro-specific strings a build-time parameter

Bug #95168 reported by Robert Millan on 2007-03-23
4
Affects Status Importance Assigned to Milestone
Software Updater
Invalid
Wishlist
Unassigned
update-manager (Debian)
Fix Released
Undecided
Unassigned
update-manager (Ubuntu)
Wishlist
Unassigned

Bug Description

Please could you make distro-specific strings a build-time parameter? I.e. during
build, detect wether we're running on Ubuntu or Debian and build the strings
based on that.

For details, see:

  http://bugs.debian.org/415376

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

I will fix that, but most likely post-feisty (sorry, too much stuff).

Cheers,
 Michael

Changed in update-manager:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Robert Millan (rmh-aybabtu) wrote :

No big deal, the most significant strings can probably be quick-fixed for etch.

Thanks for your interest

Sven Arvidsson (sa) wrote :

There's a similar issue with the documentation. It would be great if this could be handled in a way that makes it easier for Debian (and Debian/Ubuntu derivatives) to add it's own changes and keep much of the manual generic.

See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=410916

Anyway, thanks for caring about this.

Sebastian Heinlein (glatzor) wrote :

We allready removed many hardcoded strings and make use of lsb_release to detect the distro. Debian has got a quite old version of update-manager.

Furthermore we should use the components and the corresponding labels from python-apt. Currently the Ubuntu repo componets are hardcoded.

I will talk to mdke, the docbook guru, about how to use variables in the documentation.

Cheers,

Sebastian

Changed in update-manager:
status: Confirmed → Triaged
Changed in update-manager:
status: Unknown → Confirmed
Changed in update-manager:
status: Confirmed → Invalid
Artur Rona (ari-tczew) wrote :

 update-manager (0.200.0~rc2-1) unstable; urgency=low

   [ Stephan Peijnik ]
   * New upstream release.
   * Fixed typo in software-properties-gtk invocation code (Closes: #543954).
   * Fixed incorrect gconf exception handling (Closes: #544009).
   * Removed backported patch for bashisms in
     data/bug_script/debian_reportbug.sh: fixed upstream.
   * Added patch for incorrect handling of SystemError exceptions in the
     python-apt backend.

   [ Emilio Pozuelo Monfort ]
   * debian/control.in: Clean up trailing whitespaces and change tabs with
     spaces.
   * Standards-Version is 3.8.3, no changes needed.
   * debian/pycompat: Removed, no longer needed since the switch to pysupport.

 -- Stephan Peijnik <email address hidden> Fri, 28 Aug 2009 10:56:07 +0200

Changed in update-manager (Debian):
importance: Unknown → Undecided
status: Confirmed → New
status: New → Fix Released
Michael Vogt (mvo) wrote :

We will switch to the 0.2xx version of update-manager in the karmic cycle.

Stephan Peijnik (speijnik) wrote :

I believe Michael meant karmic+1 there.

The 0.2xx series still has a few problems and Debian is being used as a huge testbed right now. Don't get me wrong, most things work perfectly well, but some things that are needed for Ubuntu (read: dist upgrading) have not been implemented yet.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.