do-release-upgrade report error on upgrading from ubuntu 10.04 to 10.10

Bug #658458 reported by alessio on 2010-10-11
102
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Software Updater
Incomplete
Undecided
Unassigned
xserver-xorg-video-nouveau (Ubuntu)
Medium
Unassigned

Bug Description

i tried to upgrade from ubuntu 10.04 to 10.10 Maverick (already in stable release)

it give me the following error (before starting the update, just after checking the software repositories):

"An unresolvable problem occurred while calculating the upgrade:
E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
 This can be caused by:
 * Upgrading to a pre-release version of Ubuntu
 * Running the current pre-release version of Ubuntu
 * Unofficial software packages not provided by Ubuntu
If none of this applies, then please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bug report."

Thanks
---
Architecture: i386
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x800 1280x720 1152x768 1024x768 800x600 848x480 720x480 640x480
 edid-base64: AP///////wBMowAAAAAAAAAQAQOAIRV4Cof1lFdPjCcnUFQAAAABAQEBAQEBAQEBAQEBAQEBxxsAoFAgFzAwICYAS88QAAAZAAAADwAAAAAAAAAAACOHAmQAAAAA/gBERDI4MgQxNTRYMwogAAAA/gAnQFBagbDZ/wEBCiAgAJ0=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
DistroRelease: Ubuntu 10.10
GdmLog:
 Error: command ['kdesudo', '--', 'cat', '/var/log/gdm/:0.log'] failed with exit code 1: QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
 QFileSystemWatcher: failed to add paths: /home/alessio/.config/ibus/bus
 Bus::open: Can not get ibus-daemon's address.
 IBusInputContext::createInputContext: no connection to ibus-daemon
 cat: /var/log/gdm/:0.log: No such file or directory
GdmLog1: Error: command ['kdesudo', '--', 'cat', '/var/log/gdm/:0.log.1'] failed with exit code 1: cat: /var/log/gdm/:0.log.1: No such file or directory
GdmLog2: Error: command ['kdesudo', '--', 'cat', '/var/log/gdm/:0.log.2'] failed with exit code 1: cat: /var/log/gdm/:0.log.2: No such file or directory
InstallationMedia: Kubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100427)
MachineType: Dell Inc. Vostro 1000
Package: xserver-xorg-video-nouveau (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic root=UUID=bc580c13-5189-46f6-82f5-ad5b9c189b54 ro i8042.reset=quiet splash
ProcEnviron:
 LANGUAGE=
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-22.34-generic 2.6.35.4
Tags: maverick maverick
Uname: Linux 2.6.35-22-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 08/23/2006
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 2.6.1
dmi.board.name: 0WY383
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: Not Specified
dmi.modalias: dmi:bvnDellInc.:bvr2.6.1:bd08/23/2006:svnDellInc.:pnVostro1000:pvrNotSpecified:rvnDellInc.:rn0WY383:rvr:cvnDellInc.:ct8:cvrNotSpecified:
dmi.product.name: Vostro 1000
dmi.product.version: Not Specified
dmi.sys.vendor: Dell Inc.
glxinfo: Error: [Errno 2] Nessun file o directory
system:
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.35-22-generic

alessio (alessio-sammarco) wrote :

i also attach the log file in the dist-upgrade folder, it seems there are problems with some xorg-server package...

thanks in advance

Alessio

Book 'em Dano (heymrdjd) on 2010-10-11
affects: ubuntu → xserver-xorg-video-nouveau (Ubuntu)
Changed in xserver-xorg-video-nouveau (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Robin (r1579) wrote :

I too am having this problem and as a result I can not upgrade to 10.10.

Manfred Hampl (m-hampl) wrote :

could be a duplicate of #658581

Robin (r1579) wrote :

Yes it might be but 658581 is dealing with an alt ISO. My problem arises from a software update via software sources.

Robin (r1579) wrote :

I should have said my problem arises from a software update via the Update Manager.

Book 'em Dano (heymrdjd) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal (Applications ¸ Accessories ¸ Terminal):

apport-collect 658458

This will help us to find and resolve the problem. Bear in mind that you may need to install the python-launchpadlib package from the universe repository. Additionally, when prompted to give apport-collect permissions for Launchpad you will need to give it at least the ability to "Change Non-Private" data as it will be adding information to your bug report. If there is any other log files in '/var/log/dist-upgrade/' could you please add the log files to this bug report as separate attachments? Thanks in advance.

When reporting bugs in the future please use apport, either via the appropriate application's "Help -> Report a Problem" menu or using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

tags: added: lucid2maverick
Changed in update-manager:
status: New → Incomplete

Architecture: i386
CheckboxSubmission: b230f4cb57d72626ffab7a8e79a1747d
CheckboxSystem: 736534bbe09cc5f4b565ea35d72c2d2d
DistroRelease: Ubuntu 10.10
NonfreeKernelModules: nvidia
Package: xserver-xorg-video-nouveau 1:0.0.16+git20100805+b96170a-0ubuntu1
PackageArchitecture: i386
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-25.44-generic 2.6.32.21+drm33.7
Tags: maverick
Uname: Linux 2.6.32-25-generic i686
UnreportableReason: The drivers from nvidia.com are not supported by Ubuntu. Please uninstall them and test whether your problem still occurs.
UserGroups: adm admin cdrom dialout lp lpadmin netdev plugdev pulse sambashare
system:
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.32-25-generic

tags: added: apport-collected

apport information

apport information

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

alessio (alessio-sammarco) wrote :

Thanks for your support,

I confirm that I've been able to do the upgrade to maverick after removing the package:

xserver-xorg-video-nouveau

and the related package

xserver-xorg-video-all

thank you, if you need further information contact me.

Alessio

Book 'em Dano (heymrdjd) wrote :

alessio, I think I have taken the wrong approach with this bug. Per your initial report and what information was gathered by apport, the nouveau package was not installed on your computer.

"...MachineType: Dell Inc. Vostro 1000
Package: xserver-xorg-video-nouveau (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic root=UUID=..."

I know that you said that you were able to upgrade to maverick once you removed nouveau but perhaps the issue was something else. Can you check "/var/log/dist-upgrade/" again and attach to this report any and all logs located there. Also attach any Xorg files in "/var/log/"

alessio (alessio-sammarco) wrote :

The report you are considering, has been posted after the package nouveau was removed. In fact if you look at my first atachment (apt.log in dist-upgrade, posted on 2010-10-11:), you will find error messages about broken dependencies on the package xserver-xorg-video-nouveau.

I'm sorry but when you asked me to execute the "apport-collect 658458" command (look at the post written by Book'em Dano on 2010-10-16) i had already removed the nouveau package.

I am on maverick right now. Had no problem upgrading after removing the nuoveau package (tha was also marked as "experimental").

Anyway here are the attachment you requested.

Contact me if you need further informations.

Alessio

alessio (alessio-sammarco) wrote :
alessio (alessio-sammarco) wrote :
alessio (alessio-sammarco) wrote :
alessio (alessio-sammarco) wrote :
Bryce Harrington (bryce) on 2010-11-23
tags: added: kubuntu
tags: added: lucid maverick
Neil McLeish (nmcleish) wrote :

Hi all.
I too am having great difficulty with this.

I have removed the xserver-xorg-video-nouveaux package but to no avail.

These lines appear near the end of the dist-upgrade/main.log:-

2011-03-21 23:53:21,327 DEBUG needServerMode(): run in 'desktop' mode, (because of key deps for 'ubuntu-desktop')
2011-03-21 23:55:40,470 ERROR Dist-upgrade failed: 'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'
2011-03-21 23:55:40,471 DEBUG abort called

full main.log is attached

It suggests that some packages on my system are causing the problem, but does not go into any further detail.

Any suggestions would be most welcome.

Very best regards,

Neil.

Manfred Hampl (m-hampl) wrote :

@Neil: It seems that the file you attached is not the most recent one. The log files from the last execution are in /var/log/dist-upgrade. The files in the subdirectory /var/log/dist-upgrade/20110405-2234/ are those from the previous attempt on March 21.
Please attach main.log and apt.log from /var/log/dist-upgrade

I hope you have made sure that your lucid packages are up-to-date ("sudo apt-get update; sudo apt-get upgrade", try also "sudo apt-get dist-upgrade"). Some people have reported that skype has caused such error messages, try "sudo apt-get remove --purge skype". (You can reinstall skype later.)

Tim Casey (tjcasey) wrote :
bugbot (bugbot) wrote :

Hey alessio,

Hi, have you had a chance to test if this bug is still present in natty?

If it does (and if you're the original reporter), please boot into natty
and run the command:

  apport-collect <bug-number>

which will update the bug with fresh logs and tag the bug as affecting
natty. (It is best to run this right after reproducing the problem.)

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Triaged → Incomplete

just upgraded to natty... everything went fine for me...

Il 28/04/2011 06:28, bugbot ha scritto:
> Hey alessio,
>
>
> Hi, have you had a chance to test if this bug is still present in natty?
>
> If it does (and if you're the original reporter), please boot into natty
> and run the command:
>
> apport-collect<bug-number>
>
> which will update the bug with fresh logs and tag the bug as affecting
> natty. (It is best to run this right after reproducing the problem.)
>
>
> ** Changed in: xserver-xorg-video-nouveau (Ubuntu)
> Status: Triaged => Incomplete
>

--

Alessio Sammarco

EUROTEC Srl
Via Lirone 60/i
40013 Castel Maggiore BO
Tel. 051/6321595 Fax 051/6321354
e-mail: <email address hidden>
<mailto:<email address hidden>>
cell: 3356570484
web: www.eurotecsrl.com <http://www.eurotecsrl.com>

bugbot (bugbot) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.