Upgrade 10.10 fails due to blacklisted blcr-dkms

Reported by Aaron Wolen on 2010-10-10
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Software Updater
New
Undecided
Unassigned

Bug Description

While trying to upgrade from 10.04 to 10.10 the installer halts with the following message:

Calculating the changes

Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade:
Trying to install blacklisted version 'blcr-dkms_0.8.2-13'

This can be caused by:
* Upgrading to a pre-release version of Ubuntu
* Running the current pre-release version of Ubuntu
* Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug against the
'update-manager' package and include the files in
/var/log/dist-upgrade/ in the bug report.

Peter Smit (peter-smitmail) wrote :

A workaround (which basically means de-installing the package) I posted on http://askubuntu.com/q/5615/1418

Nuno Bento (ngpbento) wrote :

I can confirm the previously posted workaround works. I had the "blcr-dkms" package installed by the "openmpi-bin" package (and a few others), removing those allowed me to proceed with the distribution upgrade.

Scott Lawrence (bytbox) wrote :

Workaround worksforme. I didn't have to actually uninstall openmpi, because blcr stuff was just 'recommended'.

RedSingularity (redsingularity) wrote :

Duplicate of bug #555729

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers