When NM doesn't detect internet, Install button is insensitive

Bug #624894 reported by Jonathan Meek on 2010-08-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Software Updater
Fix Released
Undecided
Mohamed Amine Ilidrissi
update-manager (Ubuntu)
High
Mohamed Amine Ilidrissi

Bug Description

When the Network Manager doesn't detect a connection, even if there is one (such as dial-up, which it does not handle), the Update Manager doesn't allow users to install any updates as it forcibly disables the Install option in the window.

Related branches

Michael Vogt (mvo) on 2010-08-26
Changed in update-manager (Ubuntu):
status: New → Confirmed
importance: Undecided → High
milestone: none → ubuntu-10.10-beta

This bug has been fixed in update-manager 1:0.142.8
---
update-manager (1:0.142.8) maverick; urgency=low

  * UpdateManager/Core/utils.py:
    - fix typo (LP: #615923)
  * UpdateManager/UpdateManager.py:
    - when NM thinks we have no network, do not disable the buttons
      because for dialup users NM is frequently wrong and does not
      get that there is a network-connection (thanks to "gambs")

 -- Michael Vogt <email address hidden> Thu, 12 Aug 2010 11:53:47 +0200
---

Changed in update-manager (Ubuntu):
status: Confirmed → Fix Released
Changed in update-manager:
status: New → Fix Released
Jonathan Meek (shroudedcloud) wrote :

I am well aware of that fix, BUT, that only affects the "Check" button. For some reason, "Install" is still desensitized.

Changed in update-manager (Ubuntu):
status: Fix Released → New
Changed in update-manager:
status: Fix Released → New
status: New → Confirmed
Changed in update-manager (Ubuntu):
status: New → Confirmed

Is that true? Sorry for that.

Changed in update-manager (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Mohamed Amine IL Idrissi (ilidrissi.amine)
Changed in update-manager:
assignee: nobody → Mohamed Amine IL Idrissi (ilidrissi.amine)
status: Confirmed → In Progress
Michael Vogt (mvo) on 2010-08-27
Changed in update-manager (Ubuntu):
status: In Progress → Fix Committed
Changed in update-manager:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.142.10

---------------
update-manager (1:0.142.10) maverick; urgency=low

  * UpdateManager/UpdateManager.py:
    - when NM thinks we have no network, do not disable the
      install button because for dialup users NM is frequently wrong
      and does not get that there is a network-connection (LP: #624894)
      (thanks to Mohamed Amine IL Idrissi)
 -- Michael Vogt <email address hidden> Fri, 27 Aug 2010 10:54:42 +0200

Changed in update-manager (Ubuntu):
status: Fix Committed → Fix Released
Changed in update-manager:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers