don't hide treeview and notebook when some package is available but not installable

Bug #601127 reported by Nicolò Chieffo on 2010-07-02
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Software Updater
Fix Released
Undecided
Unassigned
update-manager (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: update-manager

When you update the list and there are only pending packages that can't be installed (because they need to be kept for dependancies problems) the treeview and the notebook are set not sensitive.
This would be valid only if there is no package at all, so my patch insert another check to see if there are kept packages.

Please review :)

Related branches

Nicolò Chieffo (yelo3) wrote :

new patch, corrects a stupid error

Vish (vish) on 2010-08-10
summary: - don't hide treeview and notebook when some package is avialable but not
- installabel
+ don't hide treeview and notebook when some package is available but not
+ installable
Philip Muškovac (yofel) wrote :

Filed a merge request with a slight change:
I replaced
if not self.cache.keepCount == 0:
with
if self.cache.keepCount() == 0:
as that gives me the intended behaviour

Changed in update-manager (Ubuntu):
importance: Undecided → Low
status: New → Triaged
tags: added: patch-forwarded-upstream
removed: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.142.7

---------------
update-manager (1:0.142.7) maverick; urgency=low

  [ Mohamed Amine IL Idrissi ]
  * Cache is no
  longer initialized when an operation is not authorized.
    LP: #394608
  * List of updates is active when there are only kept packages.
    LP: #601127 (thanks, Nicolò Chieffo)

  [ Michael Vogt ]
  * merged lp:~simono/update-manager/fixes-bug-563640, many thanks
    (LP: #563640)
  * merged lp:~yofel/update-manager/lp601127 (LP: #601127)

  [ Jean-Baptiste Lallement ]
  * UpdateManager/Core/MyCache.py:
    - catch network error when fetching 3rd party changelogs
      (LP: #565896)

  [ Brian Murray ]
  * UpdateManager/UpdateManager.py: grammar fix
 -- Michael Vogt <email address hidden> Wed, 11 Aug 2010 09:04:47 +0200

Changed in update-manager (Ubuntu):
status: Triaged → Fix Released
Michael Vogt (mvo) on 2010-08-11
Changed in update-manager:
status: New → Fix Released
Philip Muškovac (yofel) on 2010-08-11
tags: added: patch-accepted-upstream
removed: patch-forwarded-upstream
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers