package synopsis/tagline/summary should be first, not package name

Reported by Jean-François Fortin Tam on 2009-06-12
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Andrew
Software Updater
Fix Released
Undecided
Andrew
update-manager (Ubuntu)
Low
Unassigned
Nominated for Lucid by Jean-François Fortin Tam

Bug Description

Consider the following attachments comparing update-manager to packagekit. In PackageKit, packages' "taglines" such as "Firmware for Intel PRO/Wireless 3945 A/B/G/ netw..." are shown proeminently on the first line instead of the package name (such as "iwl3945-firmware-foobar-3453245").

In ubuntu's case, we show the package names in front of the taglines. I'd argue that this is not useful for non-geeks. I mean, that's probably the reason that /apps/update-manager/show_versions = False by default, right? ;)

Vish (vish) wrote :

I think you make a valid point.

But is there an easy fix? that has to be decided.

Changed in hundredpapercuts:
status: New → Confirmed
Vish (vish) wrote :

assigning to mpt , as he is currently fixing issues with update manager.

Changed in hundredpapercuts:
assignee: nobody → Matthew Paul Thomas (mpt)
importance: Undecided → Low
status: Confirmed → Triaged

PIng for the 100 paper cuts? My naïve understanding (IANAD etc.) is that this would be trivial to fix, maybe even a one-liner.

Vish (vish) wrote :

Screenshot of the latest update manager in Lucid. update-manager 1:0.132.1
This bug seems partially improved. but still a problem

Changed in update-manager (Ubuntu):
importance: Undecided → Low
status: New → Triaged

No it isn't solved, it hasn't changed at all. Your screenshot illustrates the same thing as mine (except that mine has version numbers toggled on).

This bug is about having summary be on top of the package names instead of the other way around. Currently you see the package names in big bold letters, and only geeks will understand them.

Vish (vish) wrote :

@Jean-François Fortin Tam,
hmm.. i didnt say solved. I mentioned partially improved ;) [which was the removal of the version numbers]

Its still a problem , the bug is set to triaged , since it has the necessary info.

I know, I just wanted to make it clear for those stumbling on the bug
report :)

Vish (vish) wrote :

Assigning to Maverick milestone.

Changed in hundredpapercuts:
milestone: none → maverick-round-9-potpourri
Vish (vish) on 2010-06-17
Changed in hundredpapercuts:
milestone: maverick-round-9-potpourri → maverick-round-4-potpourri
Andrew (and471) wrote :

I have created a branch that puts the package summary before the package name (as shown in the pictures in the description). I have also created a gconf key so that users can set it back to the old behaviour. The related branch is attached.

Waiting for merge :-)

Changed in update-manager:
status: New → Confirmed
assignee: nobody → Andrew (and471)
Changed in hundredpapercuts:
status: Triaged → In Progress
Changed in update-manager:
status: Confirmed → In Progress

Is this going to be mandatory? I like it the way it is now, and I'm sure I'm not the only one.

papukaija (papukaija) wrote :

@Ronake: It seems that yes, but if you raed Andrew's comment above, then you would know that you can change it.

Andrew (and471) wrote :

Exactly as papukaija said :-)

I considered this when packaging as defnitely some users (I was thinking of sysadmins :-] ) will want package names, so the gconf key is available to set it back.

Andrew (and471) on 2010-07-01
Changed in update-manager:
status: In Progress → Fix Committed
Changed in hundredpapercuts:
status: In Progress → Fix Committed
Vish (vish) on 2010-07-03
Changed in update-manager (Ubuntu):
status: Triaged → Fix Committed
Vish (vish) wrote :

This is fixed in Maverick in version update-manager (1:0.142.4)

Changed in hundredpapercuts:
assignee: Matthew Paul Thomas (mpt) → Andrew (and471)
status: Fix Committed → Fix Released
Changed in update-manager:
status: Fix Committed → Fix Released
Changed in update-manager (Ubuntu):
status: Fix Committed → Fix Released

If anyone wants to disable this change (as Andrew mentioned), here are the details: open gconf-editor and browse to /apps/update-manager, then uncheck "summary_before_name".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers