"distribution upgrade" hangs during update to hardy

Bug #186465 reported by Martin Pool on 2008-01-27
62
Affects Status Importance Assigned to Milestone
Software Updater
Fix Released
Undecided
Unassigned
Nominated for Main by Christopher Berner
update-manager (Ubuntu)
Undecided
Rolf Leggewie
Hardy
Undecided
Unassigned

Bug Description

Here is the test-case for the update-manager SRU it has no "test-the-bug" section as I have no way to reproduce it.

TEST CASE:
1. install gutsy
2. run "update-manager --proposed"
3. if you are affected by this bug, verify that it works now (if not, verify that there are no regressions)

I tried upgrading to Hardy using "update-manager -d". After checking for updates, I get a button to upgrade to 8.04, which I pressed. This brings up the distribution upgrade dialog, showing the various steps its going to do. This dialog shows the progress bar advancing a bit, and then it becomes totally unresponsive, not even repainting its own window.

see also http://ubuntuforums.org/showthread.php?t=676090

The terminal shows

mbp@lithe% sudo update-manager -d
warning: could not initiate dbus
extracting '/tmp/tmpT6yx7G/hardy.tar.gz'
authenticate '/tmp/tmpT6yx7G/hardy.tar.gz' against '/tmp/tmpT6yx7G/hardy.tar.gz.gpg'
zsh: quit (core dumped) sudo update-manager -d

/var/log/dist-upgrade/main.log has

2008-01-28 10:00:50,223 INFO release-upgrader version '0.87.4' started
2008-01-28 10:00:50,762 DEBUG Using 'DistUpgradeViewGtk' view
2008-01-28 10:00:50,948 DEBUG lsb-release: 'gutsy'
2008-01-28 10:00:50,949 DEBUG _pythonSymlinkCheck run
2008-01-28 10:00:52,279 DEBUG checkViewDepends()

Martin Pool (mbp) wrote :

I tried running the 'hardy' script from that unpacked directory, and it also displays the window and then just hangs.

I should have mentioned that previously when it was hung, I checked for network traffic using tshark, and there was none.

The hang seems to be

root@lithe# strace -f -p 14963
Process 14963 attached - interrupt to quit
futex(0xb7066794, FUTEX_WAIT, 2, NULL

root@lithe# pstree 14771 -a
zsh
  └─hardy ./hardy
      ├─http
      ├─http
      ├─http
      ├─http
      ├─http
      └─http

Invoking the ./hardy script directly asking for the text frontend it does not hang -- at least it successfully gets up to telling me this may take several hours, etc.

So I think

./hardy --frontend DistUpgradeViewText

is probably the best workaround for now.

Martin Pool (mbp) wrote :

I upgraded my other machine today and did not encounter this problem there.

Christopher Berner (cberner) wrote :

I just tried upgrading to Hardy on a spare computer, and I encountered this bug. Just like the OP said, it hangs during the first step. I let it sit for about an hour and nothing happened.

fragro (frank-grossmann) wrote :

same for me here!

Changed in update-manager:
status: New → Confirmed

Same problem for me. Where can I find the ./hardy script mentioned above?

Christopher Berner (cberner) wrote :

This is still an issue in the Beta, and it happens whether I do "update-manager -d" or Alt+F2 then "update-manager --devel-release"

Same here. I had a similar problem already with gutsy and upgraded finally with apt-get.

I have the same problem on one of my machines.

I have done quite a lot of python development on this machine and installed many development versions of python libraries, for instance pyGtk - and I see that the upgrade scripts are written in python, perhaps this is the problem?

Christopher Berner (cberner) wrote :

I don't think that's the only problem, but maybe it contributes to it. I haven't done any Python programming on my computer, although I have done some C as I work on WINE.

Paul Webster (pwebster) wrote :

I don't know if mine is the same bug or a different one. I am already running hardy but today the update manager started hanging. I have been running the hardy beta for about a week. It says there are 155 updates. I have attached a screenshot.

I did a little more research on this one, and it seems the gui thread freezes at some point (at various places it seems), and then the worker thread goes on somewhat longer, until the next communication point with the gui thread. Why do I suspect this?
* If I comment out places in the code where the worker thread contacts the gui thread (the "view" object), I can make the installation go on a bit further.
* I can also see through logging that there is some further activity in the worker thread when the gui has frozen its repainting.

Therfore I think it makes sense to focus on DistUpgradeViewGtk.py.

I tried uninstalling some GTK/python development tools, that did not change anything

  • unnamed Edit (5.4 KiB, application/ms-tnef; name="winmail.dat")

Has anyone been successful skipping any pieces of the upgrade. I tried deselecting random pieces but never had any more apparent success. However, I was running through the update gui. There were 155 updates so it is pretty hard to figure out which one or more is the problem.

pw

________________________________

From: <email address hidden> on behalf of jan.tore.korneliussen
Sent: Sat 4/5/2008 11:38 AM
To: Paul Webster
Subject: [Bug 186465] Re: "distribution upgrade" hangs during update to hardy

I did a little more research on this one, and it seems the gui thread freezes at some point (at various places it seems), and then the worker thread goes on somewhat longer, until the next communication point with the gui thread. Why do I suspect this?
* If I comment out places in the code where the worker thread contacts the gui thread (the "view" object), I can make the installation go on a bit further.
* I can also see through logging that there is some further activity in the worker thread when the gui has frozen its repainting.

Therfore I think it makes sense to focus on DistUpgradeViewGtk.py.

I tried uninstalling some GTK/python development tools, that did not
change anything

--
"distribution upgrade" hangs during update to hardy
https://bugs.launchpad.net/bugs/186465
You received this bug notification because you are a direct subscriber
of the bug.

Status in Update Manager: Confirmed

Bug description:
I tried upgrading to Hardy using "update-manager -d". After checking for updates, I get a button to upgrade to 8.04, which I pressed. This brings up the distribution upgrade dialog, showing the various steps its going to do. This dialog shows the progress bar advancing a bit, and then it becomes totally unresponsive, not even repainting its own window.

see also http://ubuntuforums.org/showthread.php?t=676090

The terminal shows

mbp@lithe% sudo update-manager -d
warning: could not initiate dbus
extracting '/tmp/tmpT6yx7G/hardy.tar.gz'
authenticate '/tmp/tmpT6yx7G/hardy.tar.gz' against '/tmp/tmpT6yx7G/hardy.tar.gz.gpg'
zsh: quit (core dumped) sudo update-manager -d

/var/log/dist-upgrade/main.log has

2008-01-28 10:00:50,223 INFO release-upgrader version '0.87.4' started
2008-01-28 10:00:50,762 DEBUG Using 'DistUpgradeViewGtk' view
2008-01-28 10:00:50,948 DEBUG lsb-release: 'gutsy'
2008-01-28 10:00:50,949 DEBUG _pythonSymlinkCheck run
2008-01-28 10:00:52,279 DEBUG checkViewDepends()

Christopher Berner (cberner) wrote :

How do I skip parts of the upgrade? I'd be happy to test that.

Paul Webster (pwebster) wrote :
  • unnamed Edit (4.9 KiB, application/ms-tnef; name="winmail.dat")

There are checkmarks by the different pieces of the update GUI. However, there are 155 pieces (or so it said) and they appear in alphabetic or semi-alphabetic order. I don't know whether they load in that order or if they load based on dependencies. The problem may lie in dependencies.
pw

________________________________

From: <email address hidden> on behalf of raccoonone
Sent: Sat 4/5/2008 1:36 PM
To: Paul Webster
Subject: [Bug 186465] Re: "distribution upgrade" hangs during update to hardy

How do I skip parts of the upgrade? I'd be happy to test that.

--
"distribution upgrade" hangs during update to hardy
https://bugs.launchpad.net/bugs/186465
You received this bug notification because you are a direct subscriber
of the bug.

Status in Update Manager: Confirmed

Bug description:
I tried upgrading to Hardy using "update-manager -d". After checking for updates, I get a button to upgrade to 8.04, which I pressed. This brings up the distribution upgrade dialog, showing the various steps its going to do. This dialog shows the progress bar advancing a bit, and then it becomes totally unresponsive, not even repainting its own window.

see also http://ubuntuforums.org/showthread.php?t=676090

The terminal shows

mbp@lithe% sudo update-manager -d
warning: could not initiate dbus
extracting '/tmp/tmpT6yx7G/hardy.tar.gz'
authenticate '/tmp/tmpT6yx7G/hardy.tar.gz' against '/tmp/tmpT6yx7G/hardy.tar.gz.gpg'
zsh: quit (core dumped) sudo update-manager -d

/var/log/dist-upgrade/main.log has

2008-01-28 10:00:50,223 INFO release-upgrader version '0.87.4' started
2008-01-28 10:00:50,762 DEBUG Using 'DistUpgradeViewGtk' view
2008-01-28 10:00:50,948 DEBUG lsb-release: 'gutsy'
2008-01-28 10:00:50,949 DEBUG _pythonSymlinkCheck run
2008-01-28 10:00:52,279 DEBUG checkViewDepends()

According to the update manager developers the gui should no longer hang. If anyone is still experiencing this problem please let us know and we can look more closely

Changed in update-manager:
importance: Undecided → Medium
status: New → Fix Released
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

If anyone can still reproduce this, I would be interessted in a strace and a pstree and if the error is reproducable. If it is, I would like to sent you some test code.

Thanks,
 Michael

Changed in update-manager:
importance: Medium → Undecided
status: Fix Released → Incomplete

I can certainly reproduce this in the update manager gui. I am already
on 8.04 though. I loaded it from the CD on a freshly wiped hard drive
last week. Tell me what to do if you want me to trace something. I am
a newbie but know how to open the terminal.

pw

On Mon, 2008-04-07 at 19:08 +0000, Michael Vogt wrote:
> Thanks for your bugreport.
>
> If anyone can still reproduce this, I would be interessted in a strace
> and a pstree and if the error is reproducable. If it is, I would like to
> sent you some test code.
>
> Thanks,
> Michael
>
> ** Changed in: update-manager (Ubuntu)
> Importance: Medium => Undecided
> Status: Fix Released => Incomplete
>

Christopher Berner (cberner) wrote :

I can confirm that this bug is *not* fixed. I can reproduce it 100% of the time on my machine. "update-manager -d" causes the GUI to hang. How do I run strace and pstree, could you point me to detailed directions? I'd be happy to run some test code for you as well. Just let me know what to do.

darKnighte (darknighte) wrote :

I am seeing this problem too. This is on a fresh install of the 64 bit version of 8.04 beta. Everything was working fine for updates for a while. After multiple updates via the synaptic package manager, I am now getting hangs. I've attached an some output files (strace, pstree, and command line stuff).

  Any developers out there, I'm happy to collect more data/run more tests.

Christopher Berner (cberner) wrote :

Here are some logs Michael. Let me know if you need anything else. I'm still unable to run update-manager -d without it freezing.

Changed in update-manager:
status: Incomplete → Confirmed
SteveLee (steve-fullmeasure) wrote :

Yep - I'm seeing it.
So trying procedure in Mark's blog http://www.markshuttleworth.com/archives/142

Steve,

If you can reproduce it reliably it would be a big help if you could get an strace and pstree output as per Michael Vogt's request higher up. You can find instructions for strace here https://wiki.ubuntu.com/Strace. I'm still looking for pstree.

OK looking back over Martin Pool's post the following should be enough to get a pstree output. At a terminal type:

ps -e | grep hardy

This will return a process number. Then run the following

pstree process-number-here -a

Then post the output here. I suppose for the sake of completeness I should check that the 'it' you see is the hanging update manager window.

SteveLee (steve-fullmeasure) wrote :

I'm sorry Richard but I've now upgraded as I needed to work today. I'll do my desktop next week and if I had problems will do so.

FYI I had a bad experience and my wifi is now not available, though bluetooth and wired lan work OK.
I couldn't do thesecond step in Mark's blog as my meta file didn't have a hardy entry. I ran 'aptitude update/upgrade' which got something after several hundred files but was very broken (eg couldn't find human at login and panels missing stuff). I then found update-manager -c-d got several hundred more packages and everything basically works. This morning I got another 20 packages but still no wifi :-(
All I get in nm-applet is a new 'edit wireless networks. When I unplug wired lan nm-applet vanishes.

Not to worry Steve. Could you please attach the log files from /var/log/dist-upgrade for your troublesome upgrade. It sounds like your wireless issue could be a separate bug but we'll need to look in the logs to tell.

Also. the recommended instructions for upgrading are here rather than Mark's blog althought they're actually pretty similar https://help.ubuntu.com/community/HardyUpgrades#head-e7f287c730b93116f89de7ea7e05efbe95fa6dd1

SteveLee (steve-fullmeasure) wrote :

Could you please attach the log files from /var/log/dist-upgrade for your troublesome upgrade.
OK Richard

>It sounds like your wireless issue could be a separate bug but we'll need to look in the logs to tell.
Probably, I can't find the right info on the web at all.
module iwl3945 is loaded, lshw shows it as wmaster0 but ifup eth1 is the only one that [almost] works as before Hardy upgrade.
Get 'wmaster0: unknown hardware address type 801' and never DHCP associates and sleeps.
nm never lets me set wireless (OK button disabled)
nm-applet stuck on 'manual config'

> Also. the recommended instructions for upgrading are here rather than Mark's blog althought they're actually pretty similar
> https://help.ubuntu.com/community/HardyUpgrades#head-e7f287c730b93116f89de7ea7e05efbe95fa6d

Yeah, that's the one I tried first and that hung at end of 2nd step as others have reported.
One point is that when you run it the panel update notification appears and it's not at all clear if you should use that or continue interacting with the dist upgrade.

Still a problem for me even after today's updates to the update-manager (core?). Can't check versions as the stalled update has the lock...

neilw@neilw-laptop:~$ ps -e | grep hardy
 7427 ? 00:00:01 hardy
neilw@neilw-laptop:~$ pstree 7427 -a
hardy /tmp/tmp_e0CMd/hardy
  ├─http
  ├─http
  └─http

neilw@neilw-laptop:/var/log/dist-upgrade$ ls -l
total 80
-rw-r--r-- 1 root root 68292 2008-04-16 16:50 apt.log
-rw-r--r-- 1 root root 288 2008-04-16 16:50 main.log
-rw-r--r-- 1 root root 1375 2007-10-05 17:43 main_pre_req.log
-rw-r--r-- 1 root root 0 2008-04-16 16:50 term.log

Logs staying the same size, no changes or growth.

Christopher Berner (cberner) wrote :

using the directions in Mark's blog I was able to upgrade. that seems to be a good workaround.

Neil, thanks for providing the extra info. From your apt.log it looks like the upgrade actually proceeds to completion. There aren't any obvious errors it just fails to exit. If you can reproduce the bug reliably then an strace as per Micheal Vogts request would be a big help

Steve, I think your bug may be a separate issue that happens to have similar symptoms. Your log files are quite different to the others in this thread.

I don't seem to have an updated system here... Looks and smells like a Gutsy Gibbon still!

When started under strace the program appears to exit (vanishes) rather than hanging.

Strace output attached.

Michael Vogt (mvo) wrote :

@Neil:

I see in your logs the following string:
[pid 7733] 19:01:11.385940 write(2, "must be setuid root", 19 <unfinished ...>

Could you please run (in a terminal):
$ ls -l /usr/bin/sudo

and paste the result here?

neilw@neilw-laptop:~$ ls -l /usr/bin/sudo
-rwsr-xr-x 2 root root 91776 2007-06-15 13:49 /usr/bin/sudo
neilw@neilw-laptop:~$

/usr/bin/sudo is highlighted as (white text on) red background in my console.

mvo asked if I could reproduce this. I don't have any more gutsy
systems, and I'm not sure how I could test for it otherwise.

SteveLee (steve-fullmeasure) wrote :

As I'm upgraded now I guess I'm happy even though it was a bit painfull.
I've also fixed the nm wifi issue. After hours it turns out you now need to comment out (#) any lines in /etc/network/interfaces for interfaces you want nm to manage (arrgg)

Michael Vogt (mvo) wrote :

After some discussion on #ubuntu+1 (thanks to katad0tls) I *think* this can be triggered by unreachable mirrors. I added a

iptables -A OUTPUT -p tcp --dport 80 -j DROP

rule to a test VM and the updater appeared to be frozen forever. I'm not sure if that is the only way to trigger it (and/or if this is unreleated). I will try to find out more.

Michael Vogt (mvo) wrote :

The screenshot I have seen when it hangs indicates that this is not the real issue for the bug. The screenshot shows a window that is hanging complettely (does not get redrawn) and the last content on it is (greek) "Checking package manager" (it appears).

Michael Vogt (mvo) wrote :

I also got reports that the same system works with the cli version of the upgrader but *not* with the gtk version. Locale is el_GR

Michael Vogt (mvo) wrote :

@raccoonone: using the directions in marks blog means "do-release-upgrade -d" ? If so, did you still had a GUI (gtk) upgrade or did you use the command line?

24 comments hidden view all 104 comments
Michael Vogt (mvo) wrote :

Thanks again! I think we are gettig closer :) I put another tarball up now:

http://people.ubuntu.com/~mvo/update-manager/release-upgrader-0.87.26-debug3.tar.gz

it contains even more debug code and a possible fix (fingers crossed :)

Please let me know how if that tarball works and if not, please include the main.log file.

Thanks,
 MIchael

Same freeze, I'm afraid.

Neil

Michael Vogt (mvo) wrote :

Thanks again for the test. Here is the next tarball:

http://people.ubuntu.com/~mvo/update-manager/release-upgrader-0.87.26-debug4.tar.gz

This is definitely a tricky problem, it hangs at a place where it should be pretty much impossible and I'm currently trying to figure out how this can happen. The new log is even more detailed, I changed the code again so that it might fix the issue (but that is less likely).

If it still hangs, can you think of anything special in your gtk configuration? A theme maybe or use of something like the gutsy-backports repository etc? I would love to be able to reproduce the problem here.

Thanks, your help is really appreciated!

Michael Vogt (mvo) wrote :

@xfx: my apologize, it looks like it is indeed hanging in the while gtk.events_pending(): gtk.main_iteration() loop. It is pretty mysterious currently how this can happen, it should stop once there are no events left.

Ok, version four... I'm afraid still freezing as before.

The system on which it is giving trouble is a Lenovo 3000 N100 laptop, with a Centrino duo processor. Gutsy backports repository is turned on, as is the 'Partners' one. Folding at home is installed and running, but I'm stopping it before trying the upgrader. No Machine's NX server, node and client are also installed.

Neil

(For the record, I updated one of my desktop machines a couple of nights ago without any problems.)

Michael Vogt (mvo) wrote :

Thanks for the added information. Please try:

http://people.ubuntu.com/~mvo/update-manager/release-upgrader-0.87.26-debug5.tar.gz

If that does not fix the hang, I think we need to try to run another strace on it, maybe with reduced output, I will post instructions.

Still behaving the same way I'm sorry to say.

Neil

SteveLee (steve-fullmeasure) wrote :

Neil Woolford wrote:
>The system on which it is giving trouble is a Lenovo 3000 N100 laptop, with a Centrino duo processor

Snap! That is the same machine I had the above mentioned problems on.
Still not tried upgrading my main desktop machine yet as can't afford the downtime.

Michael Vogt (mvo) wrote :

Thanks, I'm currently trying to gather more data about it. I wonder if it helps if you switch to a different theme or (if you use a nvidia driver) switch to the free "nv" driver instead. I currently suspect its a bug in python and/or gtk that update-manager triggers.

I'm currently using the default 'Human' theme, so wouldn't put that very high up the list of possible triggers. (I'm happy to try others of course).

Compiz is installed on the machine; I did turn off the effects for my last round of testing, though not before. Compiz is still installed even though visual effects are off.

The video system on the Lenovo is an Intel integrated one, the Intel 9nn (945?) family. (Package 915 resolution is loaded for this to work with the 1280x800 screen

Other oddities on my system, restricted drivers for VMWare and the Intel 3945 wireless card are installed and in use.

I'm happy to change settings around for testing.

Martin Pool (mbp) wrote :

I'm pretty sure (it was several months ago and I cannot reproduce it now) that I was using either the human default theme, or maybe the Industrial theme. This occurred on a Lenovo x61s laptop, with an Intel GM965/GL960 video card, which is an interesting coincidence with the other reports.

Christopher Berner (cberner) wrote :

The computer that I had problems with has an nvidia graphics card, and I was using the restricted driver.

The computers I had problems on used an ATI card using the restricted fglrx driver and an Nvidia card using their restricted driver, respectively. (But does not most people use that nowadays?)

ledlincoln (ldietrich) wrote :

New person reporting here. Mine also hangs on the Distribution Upgrade dialog. Attaching screenshot. This is on a Dell D600 laptop, ATI Radeon driver, pretty ordinary Gutsy installation. If you want more info, or for me to run one of your tools, let me know.

Michael Vogt (mvo) wrote :

After some more investigation I was able to reproduce a similar hang as described here with a similar strace pattern. Could you please try http://people.ubuntu.com/~mvo/update-manager/release-upgrader-0.87.26-debug6.tar.gz and see if that works for you and does not hang? It worked in my tests but my test-setup is a bit artificial as I can not reproduce the hang on a normal machine. Feedback is very welcome.

It looks much better. Certainly the process runs without the freeze right at the start.

Unfortunately my system hasn't got quite enough room on / for the upgrade process, so it did stop later on. (As it should.) After this stop, the gui window greyed out and had to be killed again. But that is much less of a problem, and maybe only happens if the process is stopped by another technical difficulty.

I will clear space on the machine and try again later today.

Neil

Michael Vogt (mvo) wrote :

Thanks a bunch Neil! Your help is really invaluable. I'm happy that I am on the right track now, please do not complete the upgrade just yet, I think I will need at least another test version. For this one I removed the "stop" button in the fetch progress in the main window. It looks like it is some sort of strange problem with the gtk svg loader, definitely something pretty deep down. But I think I know now how to workaround the problem.

Michael Vogt (mvo) wrote :

Here is a another build that (hopefully) fixes the issue:
http://people.ubuntu.com/~mvo/update-manager/release-upgrader-0.87.27-test2.tar.gz

Please give it a go and let me know if it helps. If so, I will do a SRU with the fix.

Ok. Looking good. (I still can't complete the upgrade because I don't have enough free space on / yet, I need to repartition so it isn't trivial on a production machine.)

However, when I run 0.87.27-test2 from the command line the process starts properly and runs on to the point where it tells me I need more space. After this, when I click (OK) to cancel, the window now displays the information about resetting to the pre-upgrade state before exiting properly.

Busy day with work tomorrow (Thursday) so may not be able to do final testing until Friday. I think you could safely start the SRU process before then...

Neil

Matt Turner (baksiidaa) wrote :

Thanks for the most recent fix--it worked for me.

agrech (f-agrech) wrote :

I suppose the fix wasn't yet in the mirrors because I got the problem a few minutes ago.
I've worked around it by deactivating at-spi (gnome-at-properties).
I suppose at-spi was conflicting somewhere with update-manager.
I thought I would share my finding with the community and I found this bug which was solved 10 hours ago.

Michael Vogt (mvo) wrote :

The workaround is now in my bzr tree I prepare a SRU for it. Thanks everybody for your patience and for the testing.

Changed in update-manager:
status: Confirmed → Fix Released
milestone: none → ubuntu-8.04.1
SteveLee (steve-fullmeasure) wrote :

Thanks Michael, FWIIW I had accessibility on as well.

xtrender (rhc-smk) wrote :

same thing here... the window becomes grey on preparing to upgrade

ledlincoln (ldietrich) wrote :

My upgrade went smoothly today, with build 0.87.27-test2. Thanks for your great and speedy work!

xtrender (rhc-smk) wrote :

mine too... a some error ocurred during the instalation.. but until now works fine.
i got one question:
how can i do the instalation without internet? i already hav the alternate cd.

bonnyrsa (jonathan-sparks) wrote :

Hi,

I am relatively new to linux. I am having problems getting the updated build to work. Is there a associated thread on the forums where a step by step guide can be found. I don't want to post my problems here if not appropriate.

Thanks

Michael Vogt (mvo) wrote :

I uploaded the fix into hardy-proposed now, but please note that its not in the archive yet (will likely take ~24h) and that you will have to run "update-manager --proposed" to get it. After successful testing it will be moved to the hardy-updates repository and then everybody gets the fix automatically.

Thanks,
 Michael

description: updated
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in update-manager:
milestone: ubuntu-8.04.1 → none
status: New → Fix Committed
Steve Langasek (vorlon) on 2008-05-09
Changed in update-manager:
milestone: none → ubuntu-8.04.1

Test case seems to be working fine here; I'm using the Lenovo 3000 laptop which this bug was preventing me upgrading.

update-manager --proposed started up an instance of the Update Manager that offered me a button to upgrade to 8:04.

Upon pressing that button I was asked for a password, taken through the information panels about what would happen and asked to confirm.

On confirmation, the system has started the upgrade. It is currently downloading the files; sadly it appears that traffic shaping is quick to cut in, so it will be midnight here before they are all downloaded.

However, it is behaving correctly so far, thus I believe the workaround/fix as uploaded to 'proposed' works properly.

Thank you Michael.

Bjorn Hansen (holomorph) wrote :

I can also confirm it appears to be working. I tried to do an upgrade earlier today and it hung at "preparing to upgrade". After some digging I discovered this fixed, ran with --proposed and now I'm "Getting new packages", so all appears well.

SteveLee (steve-fullmeasure) wrote :

I just tried the upgrade on my Desktop and it hung.
So I thought I'd disabled accessibility (AT-SPI) and guess what, it works.
So that definitely indicates you are on the right track.

SteveLee (steve-fullmeasure) wrote :

So that indicates we need a bit more testing with a11y on until it gets left on by default ;-

Brian Murray (brian-murray) wrote :

On a system not affected by this bug, I used "update-manager --proposed" to successfully upgrade from Gutsy to Hardy without experiencing any regressions.

Martin Pitt (pitti) wrote :

Although not all fixed bugs have been verified, four tests from Brian showed that update-manager is still able to upgrade from dapper and gutsy, and fixed some bugs. Due to the urgency of some bugs I have copied this to hardy-updates now.

Changed in update-manager:
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

Is this still an issue in lucid or was closing this task just forgotten?

Changed in update-manager (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
status: Confirmed → Incomplete

I upgraded two machines to lucid, including one previously affected by
this, and it did not hang. I think this bug is obsolete.

--
Martin <http://launchpad.net/~mbp/>

David Kovar (kowy) wrote :

Yes, I also successfully upgrade to Lucid. From my side this bug is obsolete. Thank you for support

Rolf Leggewie (r0lf) wrote :

Martin and David, thank you for reporting back. I will close this task now. If anybody else still experiences this, please feel free to reopen.

Changed in update-manager (Ubuntu):
status: Incomplete → Fix Released
JJK (jensjk) wrote : Akut hjælp

Jeg håber, at dette når dig i tide, lavede jeg en tur til Leeds,
Storbritannien, og min tegnebog blev stjålet med min internationale pas og
mit kreditkort indeni. Ambassaden er villig til at hjælpe mig med at tage
et fly, uden mit pas, jeg bare nødt til at betale for billetten og hotel
regninger. Til min forfærdelse, jeg kan ikke få adgang til mine penge uden
mit kreditkort og kontakt med min bank, men de har brug for mere tid til at
give mig et nyt kort. I denne uheldige situation, tænkte jeg tale om et
avlöningsdagslån at jeg kan betale tilbage, så snart du vender tilbage. Jeg
har virkelig brug for at være på det næste fly. Jeg har brug for 1,300
pounds Fortæl mig om jeg kan hjælpe mig gennem western union, fordi det er
den bedste mulighed jeg har. De gav mig et midlertidigt pas på ambassaden,
så er ikke noget problem, hvis du har penge, kan du sende dem via western
union kontor og inden for 20 minutter, de skal være der. Jeg kan sende
oplysninger om, hvordan midlerne kan sendes til mig.
Jeg ser frem til dit svar.

Med venlig hilsen.

Jens-Jørgen Kjærgaard
Tuenvej 818
9870 Sindal
Denmark
+45212041417
www.jensjk.dk

Displaying first 40 and last 40 comments. View all 104 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers