update-manager API change breaks apturl

Bug #1020980 reported by Al Duarte on 2012-07-04
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Software Updater
New
Undecided
Unassigned
apturl (Ubuntu)
High
Barry Warsaw
Quantal
High
Barry Warsaw

Bug Description

não permitiu eu instalar o compartilhamento de pastas

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: apturl 0.5.1ubuntu5
ProcVersionSignature: Ubuntu 3.5.0-3.3-generic 3.5.0-rc5
Uname: Linux 3.5.0-3-generic i686
ApportVersion: 2.2.5-0ubuntu2
Architecture: i386
Date: Wed Jul 4 11:46:36 2012
ExecutablePath: /usr/bin/apturl-gtk
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120404)
InterpreterPath: /usr/bin/python3.2mu
ProcCmdline: /usr/bin/python3 /usr/bin/apturl-gtk apt:samba,libpam-smbpass
PythonArgs: ['/usr/bin/apturl-gtk', 'apt:samba,libpam-smbpass']
SourcePackage: apturl
Title: apturl-gtk crashed with TypeError in __init__(): __init__() takes exactly 3 arguments (2 given)
UpgradeStatus: Upgraded to quantal on 2012-07-02 (2 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Al Duarte (alduarteheroi) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apturl (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon) wrote :

This appears to be trivially reproducible with any invocation of apturl in quantal. Barry, could you take a look at this?

visibility: private → public
Changed in apturl (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
assignee: nobody → Barry Warsaw (barry)
Barry Warsaw (barry) on 2012-07-18
Changed in apturl (Ubuntu Quantal):
status: Triaged → In Progress
Barry Warsaw (barry) wrote :

This was caused by an incompatible API change in update-manager:

See LP: #1026257 which unfortunately I can't seem to link to above.

I'm not sure whether it's worth fixing u-m in the way I describe in that bug report, but this could potentially affect other subclasses of InstallBackend, so it might be worth it. In the meantime, I have a hack for apturl to work around the API change.

Barry Warsaw (barry) on 2012-07-18
summary: - apturl-gtk crashed with TypeError in __init__(): __init__() takes
- exactly 3 arguments (2 given)
+ update-manager API change breaks apturl
Changed in apturl (Ubuntu Quantal):
milestone: none → quantal-alpha-3
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apturl - 0.5.1ubuntu6

---------------
apturl (0.5.1ubuntu6) quantal; urgency=low

  * AptUrl/gtk/backend/InstallBackendAptdaemon.py: Work around
    incompatible Update Manager API change (as described in Launchpad
    bug #1026257). LP: #1020980
 -- Barry Warsaw <email address hidden> Wed, 18 Jul 2012 13:38:02 -0400

Changed in apturl (Ubuntu Quantal):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers