ParsingError in parse()

Bug #1077932 reported by Pablo180 on 2012-11-12
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unsettings
High
Florian Diesch

Bug Description

When I attempt to run Unsettings I get the following errors:

/usr/lib/python2.7/dist-packages/gobject/constants.py:24: Warning: g_boxed_type_register_static: assertion `g_type_from_name (name) == 0' failed
  import gobject._gobject
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Traceback (most recent call last):
  File "/usr/bin/unsettings", line 9, in <module>
    load_entry_point('unsettings==0.08', 'console_scripts', 'unsettings')()
  File "/usr/lib/python2.7/dist-packages/unsettings/__init__.py", line 26, in main
    _main()
  File "/usr/lib/python2.7/dist-packages/unsettings/main.py", line 257, in main
    app = Unsettings(args[0])
  File "/usr/lib/python2.7/dist-packages/unsettings/main.py", line 58, in __init__
    self.init_theme_lists()
  File "/usr/lib/python2.7/dist-packages/unsettings/main.py", line 132, in init_theme_lists
    self.update_theme_lists()
  File "/usr/lib/python2.7/dist-packages/unsettings/main.py", line 138, in update_theme_lists
    self.obj('cbox_themes_cursor'))
  File "/usr/lib/python2.7/dist-packages/unsettings/themes.py", line 217, in load_themes
    themes = get_all_themes()
  File "/usr/lib/python2.7/dist-packages/unsettings/themes.py", line 183, in get_all_themes
    theme = Theme(dir)
  File "/usr/lib/python2.7/dist-packages/unsettings/themes.py", line 26, in __init__
    self._check_theme()
  File "/usr/lib/python2.7/dist-packages/unsettings/themes.py", line 31, in _check_theme
    self._check_index_theme()
  File "/usr/lib/python2.7/dist-packages/unsettings/themes.py", line 63, in _check_index_theme
    parser = xdg.IniFile.IniFile(fname)
  File "/usr/lib/python2.7/dist-packages/xdg/IniFile.py", line 24, in __init__
    self.parse(filename)
  File "/usr/lib/python2.7/dist-packages/xdg/IniFile.py", line 75, in parse
    raise ParsingError("Parsing error on key, group missing", filename)
xdg.Exceptions.ParsingError: ParsingError in file '/home/paul/.themes/Darker theme/index.theme', Parsing error on key, group missing

I have never been able to run Unsettings since I first tried in 12.04, despite the updates. I am now using 12.10 and kernel 3.5.0-18-generic.

Jim Dier (jdier) wrote :

I am having the same problem running a fresh install of 12.04.

ran fine initially, then stopped working.

Florian Diesch (diesch) wrote :

Thanks for reporting this bug. There seems to be a problem reading the file /home/paul/.themes/Darker theme/index.theme
Could you please attach that file?

As a workaround removing this file should allow you to start Unsettings until I've fixed this.

Changed in unsettings:
status: New → Incomplete
importance: Undecided → High
assignee: nobody → Florian Diesch (diesch)
Pablo180 (paultait22) wrote :

Sorry for taking so long. I have attached the file to this message. It seems that there is an erroneous 'w' at the beginning of the file. When this is removed Unsettings runs. I am not sure what this theme is from or for or even if I have ever used it.

Florian Diesch (diesch) wrote :

I'll fix Unsettings so it doesn't crash on such invalid theme files but just ignores them.

Changed in unsettings:
status: Incomplete → In Progress
Florian Diesch (diesch) on 2012-11-29
Changed in unsettings:
status: In Progress → Fix Committed
mateolan (mclange) wrote :

I am having the same problem, and I just downloaded new version from repo. I don't see which file was the fix.

mateolan (mclange) wrote :

BTW, the parser error is barfing on:
 ParsingError in file '/home/mclange/.icons/default/index.theme', Parsing error on key, group missing

But my icon theme file seems fine, containing only:

# This file is written by LXAppearance. Do not edit.[Icon Theme]
Name=Default
Comment=Default Cursor Theme
Inherits=Adwaita

mateolan (mclange) wrote :

OK, solved--it appears that there was no line break between the comment and the '[Icon Theme]' line...after putting that in, it appears to be running fine.

Changed in unsettings:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers