[WallpaperClock] WallpaperClock doesn't work on XFCE

Bug #263310 reported by Julien Lavergne on 2008-08-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Individual Screenlets
Medium
Unassigned
Universal Applets
Undecided
Unassigned
screenlets (Debian)
Fix Released
Unknown
screenlets (Ubuntu)
Undecided
Unassigned
screenlets-extra-pack (Kiwi Linux)
Undecided
Unassigned

Bug Description

On XFCE, the WallpaperClock just doesn't work. When you try to apply the WallpaperClock, nothing happens.

Related branches

Natan Yellin (aantny) wrote :

Have you tried enabling the XFCE workaround under the options dialog?

Julien Lavergne (gilir) wrote :

I tried but it doesn't work, with no output in the terminal.
It was also reported in Debian : http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=497222

Changed in screenlets:
status: Unknown → New
Changed in screenlets:
status: New → Confirmed
Natan Yellin (aantny) wrote :

Do you know if this is specific to any versions of XFCE?

Julien Lavergne (gilir) wrote :

I can only test with the 4.4.2 version. I don't know if others versions are affected.

Julien Lavergne (gilir) wrote :

The cause of the bug is that the applet change the key in gconf-editor, which can't work. It need to modify a config file in .config/xfce4/ and tell xfce to update the path.

Well I found it in .config/xfce4/mcs_settings/desktop.xml
But it's seems that xfdesktop --reload didn't reload the settings, a log
out is necessarry.

On Wed, 2009-01-14 at 20:06 +0000, Julien Lavergne wrote:
> The cause of the bug is that the applet change the key in gconf-editor,
> which can't work. It need to modify a config file in .config/xfce4/ and
> tell xfce to update the path.
>

Patch to fix the problem on XFCE >= 4.5.93.
If there is no objection, I'll commit it for Universal-applets

Natan Yellin (aantny) wrote :

Thanks for the patch.

Feel free to commit.

Julien Lavergne (gilir) on 2009-03-12
Changed in universal-applets:
status: New → Fix Committed
JinYoung (classpath) wrote :

I upgraded my laptop from Xubuntu 9.04 to Xubuntu 9.10. This bug also happens again on XFCE. The background image is updated only when I input 'xfdesktop --reload' command. Is there any workaround?

I use XFCE 4.6.1 with Xubuntu 9.10.

Julien Lavergne (gilir) wrote :

Fix committed in revision 469.

Changed in screenlets:
status: New → Fix Committed
importance: Undecided → Medium
Papp Bence (sclegnrbs) on 2010-12-27
affects: screenlets → indiv-screenlets
Papp Bence (sclegnrbs) on 2010-12-27
summary: - WallpaperClock doesn't work on XFCE
+ [WallpaperClock] WallpaperClock doesn't work on XFCE
Märt Põder (boamaod) on 2011-06-27
Changed in indiv-screenlets:
status: Fix Committed → Fix Released
Changed in screenlets (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.