unity launcher integration addon doesn't work

Bug #772845 reported by Musl1m on 2011-04-29
68
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Thunderbird Unity Launcher Integration
High
Unassigned

Bug Description

I've installed Thunderbird 3.3a4pre on Ubuntu 11.04 using the Mozilla daily ppa and installed the Unity launcher integration add-on and it doesn't seem to be doing anything. The 3.3a4pre version of Thunderbird is called Shredder and has installed as a separate application to Thunderbird, this may have something to do with the problem.

Mike Conley (mconley) wrote :

Thanks for the bug report - I found a compatibility issue with another extension.

I just released 0.4 with the fix. Please let me know if that's fixed the issue.

Changed in unitylauncher-extension:
importance: Undecided → High
status: New → Fix Released
status: Fix Released → Confirmed

The unread badge now appeared on the launcher the first time I ran it but then disappeared after a few minutess and the quick-lists didn't appear at all.

The badge seems to work correctly now but still no luck with the quicklists

whochismo (whochismo) wrote :

In Thunderbird 3.1.10 it doesn't let you install the plugin either. I'm using the amd64 version from Ubuntu Natty.

Mike Conley (mconley) wrote :

Musl1m:

Yeah, the quicklists are a bit of a pain. Fix (hopefully) coming soon.

whochismo:

Hey - unfortunately, the way that this extension connects to the Unity launcher is only possible with TB 3.3+. TB 3.1.x will not be supported. Sorry!

-Mike

Similar sort of issue with thunderbird 3.4a1pre, the version from the mozilla daily ppa that superceded 3.3a4pre - and the plugin at 0.4 - I've really gotten used to having the unread count displayed on the unity bar :P but 0.4's not compatible and I have to keep opening thunderbird (shredder) to check if there's new mail lol

Hopefully version 0.5 (sic) to come soon? :)

Ahmose Solomon (rasa-ahmose) wrote :

"Hey - unfortunately, the way that this extension connects to the Unity launcher is only possible with TB 3.3+. TB 3.1.x will not be supported. Sorry!"

When TB 3.1 is really the only one people are using.
Rather silly.

 thanks anyway though.
would be nice if it worked on something other than a beta version. :/

Mike Conley (mconley) wrote :

> When TB 3.1 is really the only one people are using.
> Rather silly.

I understand how it might seem silly, but also keep in mind that Thunderbird is about to adopt a rapid release cycle. When the process is completed, it'll mean new TB versions every 6 weeks.

So TB 3.3 is not far off. In fact, it's going to beta this week, and should be released 6 weeks after.

So please be patient! Thanks for your bug report.

-Mike

Mike Conley (mconley) wrote :

Antonius:

What versions of TB do you have installed now?

-Mike

@Mike

I use the packages from the ubuntu-mozilla-daily ppa - so i had thunderbird 3.4a1pre, the version from the mozilla daily ppa that superceded 3.3a4pre - and the plugin at 0.4. That all changed a while back, when 3.4/3.3 was renamed on the ppa as 7.0a1 (or 'thunderbird-trunk') and the unity launcher integration addon was compatible only with 3.3a4, so wouldn't work on any other version, even with compatibility checking off.

Actually, now i've went back to the latest 3.1.x from the ppa (3.1.11pre) and have switched to the addon "Unity unread count" (version 1.03) which gives me the unread count in unity i desired :D

BehzadSh (behzadsh) wrote :

Hi, I have this problem since I upgrade it to 5.0b1 (from ppa:mozillateam/thunderbird-next) while it was working on 3.3b3pre

Jon (jonbrewin) wrote :

I can confirm BehzadSH's issue. Moved to 5.0b1 last night. Extension remains installed and active, but does not show counts.

Mike Conley (mconley) wrote :

Thanks all for the bug reports!

I'll look into this in a day or two.

-Mike

Jon (jonbrewin) wrote :

Thanks Mike! But how am I supposed to know if I get any mail in the next day or two? ;)

Mike Conley (mconley) wrote :

Jon:

Well, if you really can't wait, I hear Messaging Menu 6.0 is working pretty well: https://addons.mozilla.org/en-US/thunderbird/addon/messaging-menu-integration/versions/

Let me know what you think. :)

-Mike

Mike Conley (mconley) wrote :

I've added version 0.6 onto AMO:

https://addons.mozilla.org/en-US/thunderbird/addon/unity-launcher-integration/versions/

Give it a whirl, and let me know if it works for you,

-Mike

Changed in unitylauncher-extension:
status: Confirmed → Fix Committed
BehzadSh (behzadsh) wrote :
John (john-helsby) wrote :

Mike

I just tried unity-launcher 0.6 with Thunderbird 5b1.

Still not getting a quick-list on right click or new mail notification?

Thanks,

John

Mike Conley (mconley) wrote :

John:

Hey - so here's the problem with the QuickList:

In order for the QuickList entry to appear (and to exist even when TB is not running) a .desktop entry needs to be written in just the right spot. Unfortunately, this text-file business is the only way to go here.

The method I had used to locate/write that .desktop file was really fragile, and I haven't come up with a better solution yet. What's likely to happen is that, at some point, the Canonical developers will add the appropriate entries to the .desktop files.

If you'd like to add the QuickList entries yourself on your machine, find the .desktop file associated with your version of Thunderbird, then add this to the bottom of it:

X-Ayatana-Desktop-Shortcuts=Compose;Contacts

[Compose Shortcut Group]
Name=Compose a New Message
Exec=thunderbird -compose
TargetEnvironment=Unity

[Contacts Shortcut Group]
Name=Contacts
Exec=thunderbird -addressbook
TargetEnvironment=Unity

Hope that helps!

-Mike

Jon (jonbrewin) wrote :

Mike,
Thanks for the great work - and so quickly, too! I did add the messaging menu indicator at your suggestion, and it works great, as well. Would it be possible to add the same prefs. dialogue to the Unity indicator (Show Mail, Show RSS, Show Newsfeed)?

Pavlo Bohmat (bohm) wrote :

Extension 0.4 doesn't work with the new TB5.0b1 for Unity 3.8.14 (Ubuntu ~11.10). Pls, fix it.
Need show new: Mail, RSS, Newsfeed...

Manually make a quick list for launcher is possible without expansion. Where the indication of new messages?

Mike Conley (mconley) wrote :

Pavlo:

For TB5.0b1, you'll want version 0.6:

https://addons.mozilla.org/en-US/thunderbird/addon/unity-launcher-integration/versions/

It hasn't been reviewed yet by AMO, which is why it hasn't shown up yet in searches. But this one should work with TB 5.0.

-Mike

Mike Conley (mconley) wrote :

Jon:

> Would it be possible to add the same prefs. dialogue to the Unity indicator (Show Mail, Show RSS, Show Newsfeed)?

Added as bug 798208 (https://bugs.launchpad.net/unitylauncher-extension/+bug/798208)

Thanks,

-Mike

Juan Simón (simonbcn) wrote :

v0.6 with TB 5 on Natty 64 bits doesn't show nothing in context menu.
Moreover, I've disabled "Keep it in the launcher" and now it doesn't show nothing when TB is open. :-(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers