Should close indicators when triggered anotification or an application

Reported by Michał Sawicz on 2013-10-10
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Bluetooth Menu
Undecided
Unassigned
Network Menu
Undecided
Unassigned
Ubuntu UX
Undecided
Unassigned
Unity 8
High
Nick Dedekind
unity8 (Ubuntu)
High
Nick Dedekind

Bug Description

Indicators panel should close when a snap decision or application was triggered.

Related branches

lp:~nick-dedekind/unity8/lp1238182
Merged into lp:unity8 at revision 585
Andrea Cimitan: Approve on 2013-12-11
PS Jenkins bot: Approve (continuous-integration) on 2013-11-22
Michał Sawicz (saviq) wrote :

Adding ubuntu-ux for design guidance.

Changed in unity8:
status: New → Incomplete
Changed in indicator-network:
status: New → Incomplete
Changed in indicator-bluetooth:
status: New → Incomplete
Changed in indicator-datetime:
status: New → Incomplete
Changed in indicator-location:
status: New → Incomplete
Changed in indicator-messages:
status: New → Incomplete
Changed in indicator-power:
status: New → Incomplete
Matthew Paul Thomas (mpt) wrote :

An indicator menu should close even *before* a dialog or app is focused. By default, it should close as soon as you select an item in the menu, or as soon as you focus anything else. Individual items may make exceptions to this: for example, items to reply to messages in the messaging menu keep the menu open. And when you select a switch item, the switch should visibly toggle before the menu closes. But apart from that, the menu should close immediately.

Changed in ubuntu-ux:
status: New → Fix Committed
Changed in unity8:
status: Incomplete → Confirmed
Michał Sawicz (saviq) wrote :

I believe it must be the indicators' responsibility to tell unity8 when to hide the panel. It can be as simple as marking those that shouldn't result in hiding, or as flexible as the indicators sending a HIDE_PANEL request on each activation.

Lars Uebernickel (larsu) wrote :

Michał, I disagree. The indicators are menus, and they should behave as such: activating a menu item closes the menu. Relying on indicators to send a message to close the menu sounds error prone and wasteful.

However, I agree with Matthew that there are some exceptions. Keeping the menu open to display the switch changing is just a special case of the above rule. For the other cases, we could have a flag on the menu item that signifies that the shell should keep the menu open after the item is activated. I imagine this is by far the minority, so it should be opt-in.

On 17.10.2013 22:55, Lars Uebernickel wrote:
> Michał, I disagree. The indicators are menus, and they should behave as
> such: activating a menu item closes the menu. Relying on indicators to
> send a message to close the menu sounds error prone and wasteful.
 >
> However, I agree with Matthew that there are some exceptions. Keeping
> the menu open to display the switch changing is just a special case of
> the above rule. For the other cases, we could have a flag on the menu
> item that signifies that the shell should keep the menu open after the
> item is activated. I imagine this is by far the minority, so it should
> be opt-in.

I'm not sure we disagree, actually, I wrote:

"It can be as simple as marking those that shouldn't result in hiding [...]"

So this is exactly what you're saying? I just wouldn't like to have to
build that knowledge into the UI, where some checkboxes should probably
close the indicators and other shouldn't. I'm good with closing by
default, and opt-in to persistency.

--
Michał (Saviq) Sawicz <email address hidden>
Canonical Services Ltd.

Michał Sawicz (saviq) on 2013-10-17
Changed in unity8:
status: Confirmed → Triaged
importance: Undecided → High
Lars Uebernickel (larsu) wrote :

> I'm not sure we disagree, actually, I wrote:

Ah, I misread that part. Sorry about that. Glad we agree!

Lars Uebernickel (larsu) on 2013-10-21
no longer affects: indicator-datetime
no longer affects: indicator-location
no longer affects: indicator-messages
no longer affects: indicator-power
Changed in indicator-bluetooth:
status: Incomplete → Invalid
Changed in indicator-network:
status: Incomplete → Invalid
Nick Dedekind (nick-dedekind) wrote :

Perhaps we should just make the distinction between menu item activation and change state. Activate closes and change state does not.
Anything further to this would require explicit opt-in/out to control specific behaviour.

Changed in unity8:
status: Triaged → In Progress
assignee: nobody → Nick Dedekind (nick-dedekind)
kevin gunn (kgunn72) on 2013-12-09
Changed in unity8 (Ubuntu):
status: New → Triaged
assignee: nobody → Nick Dedekind (nick-dedekind)
importance: Undecided → High
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity8 at revision 585, scheduled for release in unity8, milestone phone-v1-freeze

Changed in unity8:
status: In Progress → Fix Committed
Michał Sawicz (saviq) on 2013-12-11
Changed in unity8 (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 7.84+14.04.20131212-0ubuntu1

---------------
unity8 (7.84+14.04.20131212-0ubuntu1) trusty; urgency=low

  [ Michał Sawicz ]
  * Add PyDev project files for autopilot tests. Also tweak .bzrignore
    to not ignore generic Eclipse project definitions.
  * Retry unlocking the greeter three times.
  * Reduce code duplication and clean up CMakeLists and includes in
    indicator tests.

  [ Nick Dedekind ]
  * Replaced indicator page dynamic menuSelected binding with Connection
    to listview selectedIndex property. (LP: #1243146)
  * Indicators close when menu items are activated. (LP: #1238182)
  * Fixed up connections for changes to model data. (LP: #1253810)

  [ Albert Astals ]
  * dashItemSelected -> showDashHome Because we are not using the index
    at all in the upper layers.
  * Fix filtering colllapsing/expanding again Also the delegate creation
    range stuff flows up->down not down->up so rearrange the bindings.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 590
 -- Ubuntu daily release <email address hidden> Thu, 12 Dec 2013 21:41:19 +0000

Changed in unity8 (Ubuntu):
status: Fix Committed → Fix Released
Michał Sawicz (saviq) on 2013-12-23
Changed in unity8:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers