[Dash] Category expansion transition has varaible speeds

Reported by Oren Horev on 2013-09-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UX
High
Oren Horev
Unity 8
High
Unassigned
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

When a category expands in the Dash it executes the animation in a given duration. Because the extent of content that will be revealed (distance of travel) varies between one row to many rows. This caused the animation to appear fast when the travel distance is big and slow when it is small.

to reproduce :
in dash home expand frequent application category for slow speed
in apps scope - expand installed category for fast speed

desired behaviour :
animation should be maintained at a given speed taking into consideration the distance of travel expected

Related branches

lp:~nicolas-doffay/unity8/expansion-transition-fix
Merged into lp:unity8 at revision 440
Michał Sawicz: Approve on 2013-10-11
PS Jenkins bot: Needs Fixing (continuous-integration) on 2013-10-08
Nick Dedekind: Needs Fixing on 2013-10-08
lp:~nicolas-doffay/unity8/category-transition-speed-fix
Superseded for merging into lp:unity8
PS Jenkins bot: Needs Fixing (continuous-integration) on 2013-11-29
Michał Sawicz: Needs Fixing on 2013-11-22
Albert Astals Cid: Needs Information on 2013-11-22
Oren Horev (oreneeshy) on 2013-09-12
Changed in ubuntu-ux:
status: New → Fix Committed
assignee: nobody → Oren Horev (oreneeshy)
tags: added: dash-july-13
kevin gunn (kgunn72) on 2013-09-13
Changed in unity8:
assignee: nobody → Nicolas d'Offay (nicolas-doffay)
importance: Undecided → High
Michał Sawicz (saviq) on 2013-09-19
Changed in unity8:
status: New → Triaged
Changed in unity8 (Ubuntu):
status: New → Confirmed
Changed in unity8:
milestone: none → ubuntu-13.09
Oren Horev (oreneeshy) on 2013-09-30
Changed in ubuntu-ux:
importance: Undecided → High
Michał Sawicz (saviq) on 2013-10-09
Changed in unity8:
status: Triaged → In Progress
Changed in unity8 (Ubuntu):
status: Confirmed → In Progress
Michał Sawicz (saviq) wrote :

Actually this is still to fix - we need to make it ease linearly, otherwise there will always be speed-up / slow-down at the bounds.

Changed in unity8:
status: In Progress → Fix Released
Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Changed in unity8:
status: Fix Released → Triaged
Changed in unity8:
status: Triaged → Fix Committed
Michał Sawicz (saviq) wrote :

Nicolas, please read above (comment #1).

Changed in unity8:
status: Fix Committed → In Progress
milestone: ubuntu-13.09 → ubuntu-13.10
Michał Sawicz (saviq) on 2013-10-15
Changed in unity8:
assignee: Nicolas d'Offay (nicolas-doffay) → Michał Sawicz (saviq)
Michał Sawicz (saviq) on 2013-10-15
Changed in unity8:
status: In Progress → Incomplete
Changed in ubuntu-ux:
status: Fix Committed → Confirmed
Changed in unity8:
status: Incomplete → In Progress
Michał Sawicz (saviq) wrote :

This is a tad more complicated than it looks - we need to make it a two-step animation, taking into account the visible portion of the category, not just the target height.

Will revert the change that made it actually worse.

Changed in unity8:
status: In Progress → Triaged
assignee: Michał Sawicz (saviq) → nobody
Michał Sawicz (saviq) on 2013-10-15
Changed in unity8:
milestone: ubuntu-13.10 → none

I think we should also revert the change that brought in the current
behavior. That does not looks good. or maybe increase the speed of that
animation will help.

On Tue, Oct 15, 2013 at 3:12 PM, Michał Sawicz
<email address hidden>wrote:

> ** Changed in: unity8
> Milestone: ubuntu-13.10 => None
>
> --
> You received this bug notification because you are subscribed to Unity
> 8.
> Matching subscriptions: qml-phone-shell
> https://bugs.launchpad.net/bugs/1224552
>
> Title:
> [Dash] Category expansion transition has varaible speeds
>
> Status in Ubuntu UX bugs:
> Confirmed
> Status in The Unity 8 shell:
> Triaged
> Status in “unity8” package in Ubuntu:
> Fix Released
>
> Bug description:
> When a category expands in the Dash it executes the animation in a
> given duration. Because the extent of content that will be revealed
> (distance of travel) varies between one row to many rows. This caused
> the animation to appear fast when the travel distance is big and slow
> when it is small.
>
> to reproduce :
> in dash home expand frequent application category for slow speed
> in apps scope - expand installed category for fast speed
>
> desired behaviour :
> animation should be maintained at a given speed taking into
> consideration the distance of travel expected
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-ux/+bug/1224552/+subscriptions
>

tags: added: needs-qml-test
Changed in unity8:
assignee: nobody → Nicolas d'Offay (nicolas-doffay)
Changed in unity8:
status: Triaged → In Progress
Changed in unity8:
assignee: Nicolas d'Offay (nicolas-doffay) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers