[HUD] HUD invocation doesn't follow edge gesture sequence

Reported by Oren Horev on 2013-09-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UX
High
Oren Horev
Unity 8
Medium
Andrea Cimitan
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

When performing a bottom edge swipe the HUD invocation sequence should follow through the following steps :

[NOTE : GU coordinates refer to distance from bottom edge]

Hint - when user's finger passes 8GU HUD icon should fade-in from 0 to 50% at lower position (34G)
Reveal - when user finger passes 10GU HUD icon should start moving towards upper position (36GU)
Commit - when the user finger passes 14GU HUD icon should fade-in from 50 to 100% at upper position (36GU).

When the user finger is between 10GU - 14GU the direction of icon travel should be in correlation to users finger direction of travel. (note that there will be a gap between the user finger position and the HUD icon position)

Related branches

lp:~cimi/unity8/unity8.hud-2_hint-reveal-commit
Merged into lp:unity8 at revision 383
PS Jenkins bot: Approve (continuous-integration) on 2013-10-03
Michael Zanetti: Approve on 2013-10-02
Michał Sawicz: Needs Fixing on 2013-09-25
lp:~cimi/ubuntu-ui-toolkit/panel_export-position
Merged into lp:ubuntu-ui-toolkit at revision 782
Michał Sawicz: Approve on 2013-10-03
PS Jenkins bot: Approve (continuous-integration) on 2013-09-24
Oren Horev (oreneeshy) on 2013-09-12
Changed in unity8:
assignee: nobody → Andrea Cimitan (cimi)
Changed in ubuntu-ux:
assignee: nobody → Oren Horev (oreneeshy)
status: New → Fix Committed
importance: Undecided → High
tags: added: hud-july-13
Michał Sawicz (saviq) on 2013-09-19
Changed in unity8:
status: New → Triaged
milestone: none → ubuntu-13.10
importance: Undecided → Medium
Changed in unity8 (Ubuntu):
status: New → Confirmed
Andrea Cimitan (cimi) on 2013-09-20
Changed in unity8:
status: Triaged → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity8 at revision None, scheduled for release in unity8, milestone ubuntu-13.09

Changed in unity8:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package unity8 - 7.82+13.10.20131004.1-0ubuntu1

---------------
unity8 (7.82+13.10.20131004.1-0ubuntu1) saucy; urgency=low

  [ Michał Sawicz ]
  * Bump to indicate support for extended snap decisions.
  * Make Tile themeable, add renderers for Dash Plugins and weather.
    (LP: #1231948)
  * Drop network agents now that they're in indicator-network instead.

  [ Michal Hruby ]
  * Differentiate generic and music carousels.
  * Use the thumbnailer image provider for scope results that don't
    specify icon as well as for previews.
  * Added an indicator which is displayed in the search bar whenever a
    search is in progress. Added accompanying test in tst_PageHeader.
  * Expose rendererHint to shell.

  [ Albert Astals ]
  * Update pot file. (LP: #1232374)
  * Only enable the animation when the item is on screen (i.e. !culled)
    . (LP: #1200374)
  * Do not crash on positionAtBeginning if the list is empty .
  * Enable/disable running apps height animation in a less error prone
    way.

  [ Michael Terry ]
  * Use a chevron after 'Skip intro' and drop the underlining.
  * Load testability driver when QT_LOAD_TESTABILITY is set. (LP:
    #1226234)
  * Listen to the system setting StatsWelcomeScreen, which tells us
    whether to show user-specific infographic data in the greeter. (LP:
    #1207857)

  [ Gerry Boland ]
  * WM: ensure focusedApplicationWhenUsingScreenshots reset when unused,
    and only used when set. Fixes window focus conflict between shell
    and ApplicationManager.

  [ Nick Dedekind ]
  * Removed deprecated Unity.IndicatorsLegacy plugin.
  * Added actionState parser to the indicators-client text printer so
    that we get the icon.
  * Moved indicator page titles to the root action state of menu model.
    (LP: #1223635)

  [ Mirco Müller ]
  * Added rendering- and interaction-support for the first three
    extended snap-decision dialog-cases password-entry, user-
    authentication and simunlock.

  [ Daniel d'Andrada ]
  * Revert the reversion of r304 since it doesn't seem to crash anymore
    Original commit was Reset apps scope when returning from app to dash
    (LP #1193419) If an app is on foreground and you perform a long
    left-edge swipe to minimize it, and therefore return to the dash,
    the dash should be in the Applications scope and showing the
    running/recents applications. (LP: #1193419)

  [ Andrea Cimitan ]
  * Add behaviours to the hud reveal. (LP: #1224480, #1224633)
  * Make Tile themeable, add renderers for Dash Plugins and weather.
    (LP: #1231948)

  [ Michael Zanetti ]
  * fix inserting into quicklistmodel.
  * Drop useStorage argument and use exising LAUNCHER_TESTING define for
    this decision.

  [ Omer Akram ]
  * Make the volume/brightness slider changes realtime. (LP: #1227595)

  [ Nicolas d'Offay ]
  * Fixed black colour on the first of the month due to division. (LP:
    #1233657)
  * Added an indicator which is displayed in the search bar whenever a
    search is in progress. Added accompanying test in tst_PageHeader.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 390
 -- Ubuntu daily release <email address hidden> ...

Read more...

Changed in unity8 (Ubuntu):
status: Confirmed → Fix Released
Michał Sawicz (saviq) on 2013-10-04
Changed in unity8:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+13.10.20131007-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+13.10.20131007-0ubuntu1) saucy; urgency=low

  [ Zoltán Balogh ]
  * Add default tools (LP: #1233709). (LP: #1233709)

  [ Loïc Molinari ]
  * Added URI handler support.
  * Fixed UbuntuShape warnings when using a ShaderEffectSource as an
    image.

  [ <email address hidden> ]
  * Added test cases for text field testing.
  * Minor change to make the OptionSelector more testable by adding
    objectName property to uniquely identify the object. (LP: #1234020)

  [ Christian Dywan ]
  * Set offline storage path and add a unit test. (LP: #1231863)
  * Emit domainChanged from bindtextdomain to trigger updates. (LP:
    #1220395)
  * Support TextArea used with an action.
  * Support option selector used with an action.
  * Add haptic feedback to AbstractButton. (LP: #1189537)

  [ Zsombor Egri ]
  * Fix Picker module deployment.
  * index property added to Tab to be able to reference the Tab number.
    Fixes bug #1233402. (LP: #1233402)

  [ Jussi Pakkanen ]
  * Adds thumbnailer image provider.

  [ Christopher Lee ]
  * Preparing autopilot tests for an upcoming update in autopilot 1.3.

  [ Andrea Cimitan ]
  * Export a position value of the toolbar through dbus, setting the
    value of the dbus service created by the shell. (LP: #1224480)

  [ Guenter Schwann ]
  * Better handle the case of dismissing the OSK and focusing the text
    again fixes LP: #1228155. (LP: #1228155)

  [ Renato Araujo Oliveira Filho ]
  * Added "confirmRemoval" in ListItem.Empty This will ask for
    confirmation before remove the item. (LP: #1213046)
  * Disabled confirmation on swipe to delete as default.

  [ Leo Arias ]
  * index property added to Tab to be able to reference the Tab number.
    Fixes bug #1233402. (LP: #1233402)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 786
 -- Ubuntu daily release <email address hidden> Mon, 07 Oct 2013 04:36:33 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
tags: added: has-test
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers