[SIDESTAGE] Dash isn't visible when only sidestage app running

Reported by Oren Horev on 2013-02-17
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
Critical
Vesa Rautiainen
Unity 8
Medium
Michael Zanetti
unity8 (Ubuntu)
Medium
Unassigned

Bug Description

When only sidestage app is running the Dash should be view darken under the sidestage in a backdrop max position.
as described in spec https://docs.google.com/a/canonical.com/document/d/1FC_-5yz5kPy_ZvTphaqxOgI5BPnALFbxRAO4eJkzlf8/edit#heading=h.9yax8sckqagu

Related branches

lp:~mzanetti/unity8/right-edge-2
Superseded for merging into lp:unity8
Gerry Boland: Approve on 2014-03-27
Mirco Müller: Approve on 2014-03-26
PS Jenkins bot: Needs Fixing (continuous-integration) on 2014-03-25
Albert Astals Cid: Needs Fixing on 2014-03-25
Ubuntu Unity PS integration team: Pending (packaging) requested 2014-03-04
Vesa Rautiainen: Pending requested 2014-02-07
Changed in manhattan:
status: New → Confirmed
milestone: none → update-1
Oren Horev (oreneeshy) on 2013-02-18
tags: removed: script
Florian Boucault (fboucault) wrote :

Will require MIR do fix it as right now the shell surface is always stacked on top of the apps.

Changed in manhattan:
assignee: Florian Boucault (fboucault) → nobody
Andrea Cimitan (cimi) on 2013-02-27
tags: added: unity-public
Andrea Cimitan (cimi) on 2013-02-27
tags: added: unity-private
removed: unity-public
Bill Filler (bfiller) on 2013-02-28
Changed in manhattan:
milestone: update-1 → none
importance: Critical → High
assignee: nobody → Michał Sawicz (saviq)
Michał Sawicz (saviq) on 2013-07-09
information type: Private → Public
affects: manhattan → unity8
Changed in unity8:
assignee: Michał Sawicz (saviq) → Gerry Boland (gerboland)
importance: High → Medium
Michał Sawicz (saviq) on 2013-07-12
Changed in unity8:
status: Confirmed → Triaged
Michał Sawicz (saviq) wrote :

Can we please get a confirmation the designed from description is still correct?

tags: removed: unity-private
Changed in unity8:
status: Triaged → Incomplete
Oren Horev (oreneeshy) on 2013-09-27
Changed in ubuntu-ux:
assignee: nobody → Oren Horev (oreneeshy)
Oren Horev (oreneeshy) wrote :

@saviq yes this is still correct

description: updated
description: updated
Changed in ubuntu-ux:
status: New → Fix Committed
Changed in unity8:
status: Incomplete → New
Oren Horev (oreneeshy) on 2013-09-30
Changed in ubuntu-ux:
importance: Undecided → Critical
kevin gunn (kgunn72) on 2013-10-04
Changed in unity8:
status: New → Triaged
kevin gunn (kgunn72) on 2013-12-09
Changed in unity8 (Ubuntu):
status: New → Triaged
kevin gunn (kgunn72) wrote :

Design team feedback:
There has been some discussion to add dash to application stack.
In that case this is invalid because sidestage should be able to co-exist with dash.
At least I wouldn't spend time on fixing this at this point.

kevin gunn (kgunn72) on 2014-02-19
Changed in unity8 (Ubuntu):
importance: Undecided → Medium
tags: added: mwcdemo2014
Michał Sawicz (saviq) on 2014-02-20
Changed in unity8:
assignee: Gerry Boland (gerboland) → Albert Astals Cid (aacid)
status: Triaged → In Progress
Changed in unity8 (Ubuntu):
status: Triaged → In Progress
Andrea Cimitan (cimi) on 2014-02-26
tags: added: needs-test
Changed in unity8:
assignee: Albert Astals Cid (aacid) → Michael Zanetti (mzanetti)
Vesa Rautiainen (vesar) wrote :

The spec has changed and this is not a valid bug any more: https://docs.google.com/a/canonical.com/document/d/1FC_-5yz5kPy_ZvTphaqxOgI5BPnALFbxRAO4eJkzlf8/edit#heading=h.9yax8sckqagu

We don't want to disable 2/3 of our screen estate when there is no a very good reason to do that. Dash and sidestage can easily co-exist.

Changed in ubuntu-ux:
assignee: Oren Horev (oreneeshy) → Vesa Rautiainen (vesar)
status: Fix Committed → Invalid
Changed in unity8:
status: In Progress → Fix Released
Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers