[Shell, UI Toolkit] white page is displayed before app opens

Bug #1124265 reported by Chris Gagnon on 2013-02-13
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
Medium
Unassigned
Ubuntu UX
High
Oren Horev
Unity 8
Fix Released
Medium
Gerry Boland
ubuntu-ui-toolkit (Ubuntu)
Medium
Unassigned
unity8 (Ubuntu)
Medium
Unassigned

Bug Description

version:
phablet build #80 on maguro

Description:
white page is displayed before app opens

Steps to reproduce:
1. open telephony-app
2. open camera
3. open gallery

Expected results:
app opens without a white page being displayed first

Actual results:
a white page is displayed before the app opens.

-------------------------------------------------

Desired solution :

Every application should provide a loading screen. This screen will be displayed When the app starts-up from a quit state. When the app resumes from suspended state the app screenshot displayed in the Dash should take the focus until the app resumes and is ready to render its screen. When the app is ready a crossfade animation should switch between the screen shot and the resumed render.

Related branches

lp:~fboucault/unity8/animated_splash
Merged into lp:unity8 at revision 949
Michael Zanetti: Approve on 2014-05-27
PS Jenkins bot: Needs Fixing (continuous-integration) on 2014-05-26
Changed in manhattan:
status: New → Confirmed
Andrea Cimitan (cimi) on 2013-02-27
tags: added: unity-public
Pat McGowan (pat-mcgowan) wrote :

Not sure the expected behavior so will copy UX

information type: Proprietary → Public
affects: manhattan → touch-preview-images
Changed in touch-preview-images:
assignee: nobody → Michał Sawicz (saviq)
Michał Sawicz (saviq) on 2013-07-09
Changed in unity8:
status: New → Incomplete
John Lea (johnlea) on 2013-07-16
Changed in ubuntu-ux:
assignee: nobody → Oren Horev (oreneeshy)
Oren Horev (oreneeshy) on 2013-07-16
summary: - white page is displayed before app opens
+ [W/M] white page is displayed before app opens

we need splash / loading screens for applications. Is that a global toolkit issue or per app issue?

Changed in ubuntu-ux:
status: New → Confirmed
Changed in unity8:
status: Incomplete → New
Oren Horev (oreneeshy) on 2013-09-09
summary: - [W/M] white page is displayed before app opens
+ [SHell, UI Tollkit] white page is displayed before app opens

I think we need a mixture of:
* default splash (some background + app icon)
* custom splash (app author provided a splash screen)
* app screenshot (if app was running before and wasn't removed from the recent apps list)

Oren Horev (oreneeshy) wrote :

Captured desired solution section in bug description

description: updated
Changed in ubuntu-ux:
importance: Undecided → High
status: Confirmed → Fix Committed
Oren Horev (oreneeshy) on 2013-09-09
summary: - [SHell, UI Tollkit] white page is displayed before app opens
+ [Shell, UI Tollkit] white page is displayed before app opens
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Changed in unity8 (Ubuntu):
status: New → Confirmed
Michał Sawicz (saviq) on 2013-09-19
Changed in unity8:
status: New → Triaged
assignee: nobody → Gerry Boland (gerboland)
Changed in unity8 (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Changed in ubuntu-ui-toolkit:
status: New → Confirmed
importance: Undecided → Medium
kevin gunn (kgunn72) on 2013-09-27
Changed in unity8:
importance: Undecided → Medium
Changed in touch-preview-images:
importance: Undecided → Medium
Changed in ubuntu-ui-toolkit (Ubuntu):
importance: Undecided → Medium
Leo Arias (elopio) wrote :

Confirmed in today's 100 image.

tags: added: qa-touch
Colin Watson (cjwatson) on 2014-03-07
summary: - [Shell, UI Tollkit] white page is displayed before app opens
+ [Shell, UI Toolkit] white page is displayed before app opens
Chris Gagnon (chris.gagnon) wrote :

This is still an issue, but now the white background makes it a little less obvious.

The start time is a long time for every app that opens.

Michał Sawicz (saviq) on 2014-05-29
Changed in unity8:
status: Triaged → In Progress
Changed in unity8 (Ubuntu):
status: Triaged → In Progress
no longer affects: touch-preview-images
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 7.88+14.10.20140606-0ubuntu1

---------------
unity8 (7.88+14.10.20140606-0ubuntu1) utopic; urgency=low

  [ Michał Sawicz ]
  * Make lockscreen buttons translatable.

  [ Albert Astals ]
  * Correctly mark these functions as overrides
  * Remove connections to non existant signal
  * Better test name
  * Improvements for headerless categories LVPWH: No section name -> no
    header LVPWH: New hasSectionHeader context property for delegates
    GSV: Add topMargin if no hasSectionHeader (LP: #1326415)
  * Make tryVerticalJournal, tryHorizontalJournal and tryOrganicGrid
    work again

  [ Michael Zanetti ]
  * Don't crash when we get an invalid app from ApplicationManager (LP:
    #1309162)

  [ Andrea Cimitan ]
  * Workaround for lp1324159 (LP: #1322233, #1324159)

  [ CI bot ]
  * Resync trunk

  [ Florian Boucault ]
  * Application startup: changed splash rectangle to be black instead of
    white and added a neat little animation. (LP: #1124265)
 -- Ubuntu daily release <email address hidden> Fri, 06 Jun 2014 11:38:53 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Michał Sawicz (saviq) on 2014-06-07
Changed in unity8:
status: In Progress → Fix Released
Changed in ubuntu-ui-toolkit:
status: Confirmed → Fix Released
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers