[SRU Regression] Launcher and Global Menu are completely black after exiting fullscreen from certain apps

Bug #1064155 reported by Aaron Johnson on 2012-10-09
114
This bug affects 33 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Christopher Townsend
5.0
Fix Committed
High
Christopher Townsend
7.0
Fix Released
High
Christopher Townsend
unity (Ubuntu)
High
Christopher Townsend
Nominated for Precise by Christopher Townsend
Nominated for Raring by Alan Pope 🍺🐧🐱 🦄
Raring
Undecided
Unassigned

Bug Description

[Impact]

Regression in launcher / global menu drawing.

[Test Case]

Exit fullscreen mode from programs such as VirtualBox and KRDC the Unity Launcher on the left of the screen and the Global Menu at the top screen both disappear, and come back after clicking with a mouse. Expected result would be that they do not disappear.

[Regression Potential]

None known, draws the menus when full screen app is minimized. Automatic tests included.

---

UPDATE: I have uninstalled the customized version of unity (ikarosdev-unity-revamped) using the following command:
sudo apt-get purge unity unity-services unity-common libunity-core-5.0-5

I then removed the custom unity ppa from my system and proceeded to install the official version of unity 5.6.

I AM STILL EXPERIENCING THE SAME ISSUES WHICH ARE DESCRIBED BELOW:

After upgrading to Unity 5.6 on Ubuntu 12.04 32-bit, now when I exit fullscreen mode from programs such as VirtualBox and KRDC the Unity Launcher on the left of the screen and the Global Menu at the top screen both disappear.

All I have to do to get them to reappear is click anywhere on the screen, which seems entirely unnecessary... I did not experience this behavior with Unity 5.4. Also I am experiencing this behavior on two different laptops that are both running 12.04 32-bit with different hardware and software configurations.

Screenshot is attached.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.16.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-31.50-generic-pae 3.2.28
Uname: Linux 3.2.0-31-generic-pae i686
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu13
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Mon Oct 8 21:18:01 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 vboxhost, 4.2.0, 3.2.0-31-generic-pae, i686: installed
 vboxhost, 4.2.0, 3.5.0-17-generic, i686: installed
 vboxhost, 4.2.0, 3.6.0-994-generic, i686: installed
 vboxhost, 4.2.0, 3.6.0-l840, i686: installed
GraphicsCard:
 Intel Corporation Ivy Bridge Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Toshiba America Info Systems Device [1179:fb50]
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release i386 (20120817.3)
MachineType: TOSHIBA Satellite L840
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-31-generic-pae root=UUID=526d8ee5-709c-4635-aa7c-ba40c46cab5c ro quiet splash i915.semaphores=1 vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/26/2012
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: 1.80
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: Type2 - Board Product Name1
dmi.board.vendor: Type2 - Board Vendor Name1
dmi.board.version: Type2 - Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: OEM Chassis Manufacturer
dmi.chassis.version: OEM Chassis Version
dmi.modalias: dmi:bvnInsydeCorp.:bvr1.80:bd06/26/2012:svnTOSHIBA:pnSatelliteL840:pvrPSK8GU-08S00D:rvnType2-BoardVendorName1:rnType2-BoardProductName1:rvrType2-BoardVersion:cvnOEMChassisManufacturer:ct10:cvrOEMChassisVersion:
dmi.product.name: Satellite L840
dmi.product.version: PSK8GU-08S00D
dmi.sys.vendor: TOSHIBA
version.compiz: compiz 1:0.9.7.8-0ubuntu1.4
version.libdrm2: libdrm2 2.4.39-0ubuntu1.0~ppa1.1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.3+8.0.2-0ubuntu3.2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.3+8.0.2-0ubuntu3.2
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10.8
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1.2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.8-0ubuntu2.1~precise2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build3

Related branches

Aaron Johnson (acjohnson) wrote :
Omer Akram (om26er) on 2012-10-09
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
summary: - Launcher and Global Menu are hidden after exiting fullscreen from
- certain apps
+ [SRU Regression] Launcher and Global Menu are completely black after
+ exiting fullscreen from certain apps
Changed in unity:
milestone: none → 6.14.0
Aaron Johnson (acjohnson) wrote :

How is this not something that everyone is complaining about? On literally every Intel based laptop I've tried I am having the same problem, and I haven't tested it on anything but Intel. The only difference is that some computers show the background behind the launcher and the global menu, and some show black bars, but either way the issue is the same on all machines. Am I doing something wrong?

Omer Akram (om26er) on 2012-10-15
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
fate2 (faterr) wrote :

I have the same problem. after i change focus from fullscreen krdc, or change unity desktops when krdc full screen is opened - launch bar and global menu disappears.and it will appear again if i click on something another application or place were disappeared global menu is located.

fate2 (faterr) wrote :

some additions this problem was started when i update my system 12.04 one ore two weeks ago.
now i have upgraded system to 12.10 and issue didn't resloved.

Changed in unity:
assignee: nobody → Nick Dedekind (nick-dedekind)
status: Confirmed → In Progress
status: In Progress → Triaged
assignee: Nick Dedekind (nick-dedekind) → nobody
status: Triaged → Confirmed
Ori Hoch (ori-uumpa) wrote :

The issue started for me in 12.10 (in 12.04 it didn't occur)

quite a harmless bug but very annoying...

Changed in unity:
milestone: 6.14.0 → none
Changed in unity:
status: Confirmed → In Progress
assignee: nobody → Christopher Townsend (townsend)
Aaron Johnson (acjohnson) wrote :

Christopher-

I just thought I'd mention (and I'm sure you are already aware) that this issue still exists even in 13.04 except for instead of a seeing a black screen, the screen of the fullscreen app continues to be displayed until clicking on an active program windows (clicking the desktop, launcher, or global menu bar does not seem to bring the desktop back into display).

Thank you :)

Christopher Townsend (townsend) wrote :

Hi Aaron,

Yes indeed, that is the behavior in the 13.04. I have a fix already on the way for the fullscreen app continuing to be shown (bug #1053895) and I'm getting close to a fix for this particular bug.

Stay tuned!

no longer affects: unity/7.1
Changed in unity:
milestone: none → 7.1.0
Changed in unity (Ubuntu):
assignee: nobody → Christopher Townsend (townsend)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.1.0

Changed in unity:
status: In Progress → Fix Committed
Aaron Johnson (acjohnson) wrote :

Christopher-

I went ahead and patched unity and compiz using your code on ubuntu raring 64-bit and it appears to have fixed the issue :)

I really wish I knew how to program... It's amazing that the fix for this bug was just a single line change to plugins/unityshell/src/unityshell.cpp.

The compiz patch you wrote is a bit more in-depth though...

Thanks again!

Hi Aaron,

Thanks for testing out the code. Glad you confirmed it works for you:)

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity/7.0 at revision None, scheduled for release in unity, milestone 7.0.1

description: updated
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu Raring):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :
Download full text (12.1 KiB)

This bug was fixed in the package unity - 7.0.0daily13.06.07-0ubuntu1

---------------
unity (7.0.0daily13.06.07-0ubuntu1) saucy; urgency=low

  [ Ted Gould ]
  * gtk_icon_info_free() is deprecated for g_object_unref().
  * Upstart event for when the indicators are loaded by the panel
    service.
  * Add an upstart job to unity-common.
  * Manage Unity Panel Service's lifecycle with Upstart.

  [ Didier Roche ]
  * add dep on autopilot-desktop.
  * Revert the panel on upstart from ted, it doesn't respawn as expected
    when another service try to communicate with the panel service and
    the consequence is a lot of tests failing

  [ Nick Dedekind ]
  * Uses a gobject weak ref to test for object deletion in the
    GLibObject tests. Previously was checking with G_IS_OBJECT on an
    invalid pointer, which was causing a segfault

  [ Manuel de la Pena ]
  * Adds support for payment previews that will allow users to buy music
    from within the dash. .

  [ Mathieu Trudel-Lapierre ]
  * Increase timeouts for hud functional and search tests.

  [ Francis Ginther ]
  * Handle StateNotFoundError when querying the label of a hud button.

  [ Łukasz 'sil2100' Zemczak ]
  * Now that we're using the new HUD, there have been some changes that
    typically cause test_hud tests to fail. Fix the tests to fit the new
    model. The first one is that generally we do not have indicator
    entries visible in the HUD anymore. Only application menu entries
    are in it now. The second one - the way the results are displayed is
    different. Now, instead of "Menu > Entry" we have "Entry (Menu)"
    etc.
  * Fix two HUD failures related to HUD slow action activation.
  * Fix some autopilot test failures, some related to test_shortcut_hint
    and some to test_scroll in launcher.
  * Modify all the hud_query_check lambdas to be more smart and error-
    checking. Same for the selected_hud_button method in the HUD
    emulator. Also, get rid of the troublesome test_gedit_undo and
    change it into test_gedit_save, which is easier to test and anyway
    tests what we want. Besides that we also now try to handle the
    StateNotFoundError exception in the HUD emulator, another cause of
    some AP failures.
  * Add a flag for -Wno-error=unused-local-typedefs, since this causes a
    FTBFS on ARM

  [ Michal Hruby ]
  * Don't activate a result twice after pressing Enter. (LP: #1188191)

  [ Sebastien Bacher ]
  * Use '%s:' string for preview hints, rather than just appending ':'.
    (LP: #1074038)

  [ Marco Trevisan (Treviño) ]
  * IconRenderer: preprocess an icon if its emblem has been shown/hidden
    In that way we can update its transformation. (LP: #1171476,
    #1171663)
  * UnityWindow: don't draw the panel shadow above a fullscreen window.
    (LP: #1171934)
  * UnityCore: add GtkWrapper to handle GtkIconInfo correctly for
    different GTK versions Fix a memory leak in LauncherIcon. (LP:
    #1180790)
  * SwitcherController: use proper long long types for
    WindowActiveNumber Otherwise an overflow can cause bad window
    selection after long uptime.
  * Unity: "s/unsigned long long/uint64_t/g".

  [ Chris Townsend ]
  * Fixes issue where minimiz...

Changed in unity (Ubuntu):
status: In Progress → Fix Released

Hello Aaron, or anyone else affected,

Accepted unity into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.0.0daily13.06.19~13.04-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Raring):
status: Confirmed → Fix Committed
tags: added: verification-needed
Halász Tibor (tibor-halasz) wrote :

Hello,

The fix is working.

Many thanks for all who help to fix this bug!!!
At last I can switch from KDE to Unity again:)

tags: added: verification-done
removed: verification-needed
Halász Tibor (tibor-halasz) wrote :

Hello,

This problem is fixed in Ubuntu 12.04 (Precise) too?

Timo Jyrinki (timo-jyrinki) wrote :

The fix for the problem is currently targeted at the next Ubuntu 12.04 Unity update, 5.22 (5.20 was just released to all users). It's already committed to the lp:unity/5.0 branch.

Halász Tibor (tibor-halasz) wrote :

About when the 5.22 Unity update will be available?

Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.1.0.

Changed in unity:
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.0.0daily13.06.19~13.04-0ubuntu1

---------------
unity (7.0.0daily13.06.19~13.04-0ubuntu1) raring; urgency=low

  [ William Hua ]
  * Revert 3196 to fix menu highlighting issues with LibreOffice.
    Revision 3196 prevents LibreOffice's menu items from highlighting.
    See Launchpad bug #1153350. (LP: #1153350)

  [ Chris Townsend ]
  * Fixes issue where minimizing a full screen window would not draw the
    Launcher and Panel after minimization. This is a backport of
    lp:unity revno. 3320. (LP: #1064155)

  [ Marco Trevisan (Treviño) ]
  * SwitcherController: use proper long long types for
    WindowActiveNumber Otherwise an overflow can cause bad window
    selection after long uptime. (LP: #1181367)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3319 (bootstrap)
  * Automatic snapshot from revision 3320

unity (7.0.0daily13.05.08~13.04-0ubuntu1) raring; urgency=low

  [ Sebastien Bacher ]
  * Some untranslatable and wrong strings in the previews (LP: #1074038)

  [ Andrea Azzarone ]
  * [alt-tab] Disable detail view for webapp icons. (LP: #1169340)

  [ Marco Trevisan (Treviño) ]
  * Launcher - count label pops out in auto-hide mode (LP: #1171476)
  * Panel shadow is drawn above full-screen windows when notifications
    are shown (LP: #1171934)
  * [regression] Icon count is not shown if the icon is not transformed
    (LP: #1171663)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3314
 -- Ubuntu daily release <email address hidden> Wed, 19 Jun 2013 04:02:40 +0000

Changed in unity (Ubuntu Raring):
status: Fix Committed → Fix Released
Boza (nemanja-boki92) wrote :

I have this bug on 13.10. Version of Unity is 7.1.2.

How to reproduce:
Open video on youtube and use html5 player instead of flash. (youtube.com/html5 to enable it).
Make video fullscreen, watch it for 5-10 sec and unmaximize it. You should see textures of launcher and upper panel don't get redraw. Now you have to click on some of indicators to get it back, or to click Super button and then click left mouse button anywhere.

I attached screenshot.

I can confirm that this bug exists in Unity 7.1.2.

- It happens consistently when I put google-chrome into fullscreen mode with F11 (or watch non-flash videos in fullscreen mode).
- The bug does not appear to affect fullscreen mode in Firefox.
- The bug does affect the fullscreen mode (F11) of evince.

Ubuntu 13.10
Unity 7.1.2
Google Chrome 32.0.1700.107
Mozilla Firefox 26.0
(evince) GNOME Document Viewer 3.10.0

tags: added: rls-w-incoming
To post a comment you must log in.