Unity video lens doesn't work when installing in Cuba country

Bug #993002 reported by Rafael Jacobo Hidalgo Urbino on 2012-05-02
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
David Callé
Unity Videos Lens
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
unity-lens-video (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

[Problem]
The video lens crashes with some locales

[Impact]
Users using es_CU (maybe other locales too, but it's the only bug reported) can't use this lens.

[Development Fix]
The bug has been reviewed by experimented ubuntu-translators and they have proposed gettext fix which has been applied and tested in various locales.

[Stable Fix]
THe fix is in trunk. http://bazaar.launchpad.net/~unity-lens-videos/unity-lens-videos/trunk/revision/73

[Test Case]
1. Change your locale to es_CU
2. Log out / Log in
2. Open the video lens

Broken Behavior: It doesn't display anything.
Fixed Behavior: It display videos from your Video folder and Online recommendations.

[Regression Potential]
Unlikely to cause regressions

########

When we install Ubuntu 12.04 in Cuba we use Cuba as our location during the install process, but once installed the system, we log in it and the first thing we receive is an error message that tell us that Ubuntu has found an error and we need to restart the computer, but if we expand the report we can see that the trouble is in Unity video lens.

So I launched unity video lens from the terminal:

python /usr/lib/unity-lens-video/unity-lens-video

and it prints this message:
ValueError: unknown locale: es_CU

the problem is that in unity-lense-video code there is a step that try to recognize de best language for the actual user and it seems that ES_CU language is not found. Because of this error everyone that has installed Ubuntu 12.04 and slected Cuba as country should have received this message too.

I found a solution for me, I edited my user settings, so I changed my language to English from EE.UU, then I restarted the computer and when I login again Unity viodeo lens works fine. Then I changed my language again to Spanish form Spain, and my Video lens works fine, so the problem is with the language ES_CU, I think that this language has not been created yet and this is the cause of this problem.

Steps to see the bug:
1- Install Ubuntu and select Cuba as your country in the installation process.
2- Once installed go to the video lens, It should not work fine.

Greetings, me. Sorry about my English, I just want to tell you what is happening on my country when we install Ubuntu 12.04.

David Callé (davidc3) wrote :

Thank you for your report.
I'm investigating the issue.

I have added to more images describing the problem.

I also have in /etc/default/locale this:
LANG="es_CU"
LANGUAGE="es_CU:es"
LC_NUMERIC="es_CU.UTF-8"
LC_TIME="es_CU.UTF-8"
LC_MONETARY="es_CU.UTF-8"
LC_PAPER="es_CU.UTF-8"
LC_IDENTIFICATION="es_CU.UTF-8"
LC_NAME="es_CU.UTF-8"
LC_ADDRESS="es_CU.UTF-8"
LC_TELEPHONE="es_CU.UTF-8"
LC_MEASUREMENT="es_CU.UTF-8"

I think that es_CU language does not exist in Linux, This could also be a problem in the Ubuntu installer.

David Callé (davidc3) wrote :

Could you please test an update to see if it's fixed?

sudo add-apt-repository ppa:davidc3/dev
sudo apt-get update && sudo apt-get upgrade
Log out / Log in

If it works for you, it will then land for every users.

Changed in unity:
status: New → Fix Committed
assignee: nobody → David Callé (davidc3)

It works very nice. Thanks a lot.

David Callé (davidc3) on 2012-05-04
description: updated
David Callé (davidc3) on 2012-05-04
description: updated
Changed in unity-lens-videos:
status: New → Fix Committed
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-video - 0.3.5-0ubuntu2

---------------
unity-lens-video (0.3.5-0ubuntu2) quantal; urgency=low

  * Bug fixes
    - Gettext update for a crash on some locales, like es_CU (LP: #993002)
 -- David Calle <david@quetzal> Wed, 30 May 2012 18:52:35 +0200

Changed in unity-lens-video (Ubuntu):
status: New → Fix Released

Hello Rafael, or anyone else affected,

Accepted unity-lens-video into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity-lens-video (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Omer Akram (om26er) on 2012-06-05
Changed in unity:
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

Could you try if the update works for you?

tags: added: verification-done
removed: verification-needed
Brian Murray (brian-murray) wrote :

Some information about how you tested the package in -proposed would be helpful to confirm that the verification was really done.

Scott Kitterman (kitterman) wrote :

Or if someone else wants to test it and report how they did it ...

Hi everybody, now it works perfectly. I made this test:

I installed Ubuntu 12.04 in new system selecting Cuba as my country and the Spanish languague, when I loged in I saw the message that say that Ubuntu found an error and should be restarted, the problem is in the video lens as expected, then I updated all my system including the video-lens package, then I logout and login again and everything work perfect.
This was corrected, thanks a lot for your work, I and a lot of people in Cuba too appreciate you .

Sorry for the time to answer, I didn't have a PC for installing a new Ubuntu, so I had to reinstall my personal PC to test this.

I have another bug but I do not know where to submit it, the problem is that our personal Video folder in Ubuntu is called "Vídeo", but in Cuba we pronounce and write it as "Video" not "Vídeo", problem is in the "i", People in Spain pronounce Vídeo, but that is in Spain not in Cuba, so I think that if we install Ubuntu and select Cuba as our country during the install process our video folder should be renamed to Video. Where can I report this bug ?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-video - 0.3.5-0ubuntu1.1

---------------
unity-lens-video (0.3.5-0ubuntu1.1) precise-proposed; urgency=low

  * Bug fixes
    - Gettext update for a crash on some locales, like es_CU (LP: #993002)
 -- David Calle <david@quetzal> Wed, 30 May 2012 18:52:35 +0200

Changed in unity-lens-video (Ubuntu Precise):
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) wrote :

@rjhidalgo-s:

I'm a member of the Ubuntu Spanish Translators team. Please contact us at <email address hidden> to discuss your issue.

Changed in unity-lens-videos:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
Jaime Pérez (jaime-91) on 2015-10-13
Changed in unity (Ubuntu Precise):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers