[regression] Dash - Arrow keys not working in the search bar on second use

Bug #987294 reported by Michal Hruby on 2012-04-23
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Medium
Andrea Azzarone
Unity
Fix Released
Medium
Andrea Azzarone
nux (Ubuntu)
Medium
Andrea Azzarone
Precise
Medium
Andrea Azzarone
unity (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

If the search bar's text is not an empty string, the arrow keys and the whole interaction with the search bar is in a weird state. To reproduce:

1) Open dash and search for "gedit"
2) Close the dash using the super key
3) Open the dash again
4) You should see the "gedit" search string selected, but pressing left/right arrow keys doesn't move the cursor, pressing enter doesn't activate the result, and using mouse to deselect the search string is showing weird inverted behaviour

When in state 4) pressing the escape or backspace keys (or any key to replace the selection) fixes the weird state of the search bar.

Related branches

Michal Hruby (mhr3) wrote :

As a note - this used to work in earlier 5.x versions.

Changed in unity:
status: New → Confirmed
assignee: nobody → Andrea Azzarone (andyrock)
importance: Undecided → Medium
Changed in unity (Ubuntu):
status: New → Confirmed
description: updated
Changed in unity (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
summary: - [regression] Arrow keys not working in dash's search bar
+ [regression] Dash - Arrow keys not working in the search bar on second
+ use
Andrea Azzarone (azzar1) on 2012-04-25
Changed in unity:
milestone: none → 5.12.0
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Andrea Azzarone (azzar1) on 2012-04-25
Changed in nux:
status: New → In Progress
assignee: nobody → Andrea Azzarone (andyrock)
Changed in nux (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
status: New → In Progress
Changed in nux:
importance: Undecided → Medium
Andrea Azzarone (azzar1) on 2012-04-25
Changed in nux:
status: In Progress → Fix Committed
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in nux (Ubuntu):
status: In Progress → Fix Committed
Omer Akram (om26er) on 2012-04-26
no longer affects: unity (Ubuntu)
Changed in nux (Ubuntu):
importance: Undecided → Medium
Changed in nux (Ubuntu Precise):
status: Fix Committed → Confirmed
Didier Roche (didrocks) on 2012-04-27
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released

Hello Michal, or anyone else affected,

Accepted nux into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in nux (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
B. Clausius (barcc) wrote :

The bug is only partially solved. It depends on the position of the mouse cursor.

1. press super key to open the dash
2. type: gedit
3. position the mouse oven an icon
4. press super key to close the dash
5. press super key to open the dash
6. press left or right key -> the cursor does not move

If the mouse is not over an icon in the dash it works as expected

Andrea Azzarone (azzar1) wrote :

@barcc That is a different issue. I need to talk with the designers.

Yann Dìnendal (yannbreliere) wrote :

It's fixed for me. And I can't reproduce barcc's test case.

Yann Dìnendal (yannbreliere) wrote :

Oh sorry, I could reproduce it by moving the mouse on the launcher after re-opening it. When it happens, the focus doesn't go back on the search field even if I mouse back over it.

Martin Pitt (pitti) on 2012-04-29
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 2.12.0-0ubuntu1

---------------
nux (2.12.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - [regression] Dash - Arrow keys not working in the search bar on second
      use (LP: #987294)
    - dash doesn't ever respond to <enter> when the previous search is
      recalled (LP: #980184)
 -- Didier Roche <email address hidden> Fri, 27 Apr 2012 07:57:55 +0200

Changed in nux (Ubuntu):
status: Confirmed → Fix Released
Changed in nux (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
Jaime Pérez (jaime-91) on 2015-10-13
Changed in unity (Ubuntu Precise):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers