alt-backtick flickers between windows

Bug #987156 reported by Alan Pope 🍺🐧🐱 🦄 on 2012-04-23
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Łukasz Zemczak
5.0
Fix Released
Low
Łukasz Zemczak
unity (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

[Test Case]
1. Open a few same-application windows (e.g. 3 terminal windows)
2. Focus one of the opened application windows.
3. Quickly tap Alt+keyabovetab (meaning only tap once, do not hold)
4. Repeat at least a few times
   -> On every quick-tap, there should be no switcher visible (if done fast enough). The focus should just simply switch to the next same-application window.

[Regression Potential]
Problems with displaying the switcher during Alt+Tab and Alt+keyabovetab.

Original description:

Open two windows of an application
Quickly alt-backtick between them
Note the alt-backtick window appears briefly between windows.

This seems inconsistent with "quick alt-tab" behaviour where the alt-tab window does not appear if you press alt-tab quickly.

Here's a video showing it: http://youtu.be/7LTyEuGclUQ

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: compiz 1:0.9.7.6-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu6
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Mon Apr 23 09:05:42 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.1.12, 3.2.0-20-generic, x86_64: installed
 virtualbox, 4.1.12, 3.2.0-23-generic, x86_64: installed
EcryptfsInUse: Yes
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21da]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120203)
MachineType: LENOVO 4287CTO
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=86ea7114-6b69-4161-b91c-44ccb7fcfd67 ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/15/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8DET52WW (1.22 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4287CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8DET52WW(1.22):bd09/15/2011:svnLENOVO:pn4287CTO:pvrThinkPadX220:rvnLENOVO:rn4287CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4287CTO
dmi.product.version: ThinkPad X220
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.7.6-0ubuntu2
version.ia32-libs: ia32-libs 20090808ubuntu35
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in compiz (Ubuntu):
assignee: nobody → Łukasz Zemczak (sil2100)
status: Confirmed → In Progress
Łukasz Zemczak (sil2100) wrote :

About this bug... I now notice that there is not much difference between the reaction in alt+tab and alt+`. It seems I can also tap alt+` fast enough that the switcher does not appear. And vice-versa: I can tap alt+tab and accidentally get the switcher blinking.

Changed in unity:
assignee: nobody → Łukasz Zemczak (sil2100)
status: New → In Progress
Changed in compiz (Ubuntu):
status: In Progress → Invalid
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in unity:
importance: Undecided → Low
Changed in compiz (Ubuntu):
importance: Undecided → Low
Sparhawk (sparhawkthesecond) wrote :

Unlike comment #3, I see this differently on my system. No matter how fast I press alt-`, the switcher *always* appears. OTOH, I can press alt-tab slightly more slowly than this (but still quick-ish), and prevent the switcher from appearing.
(Ubuntu 12.04, Unity 5.12-0ubuntu1, Compiz 1:0.9.7.8-0ubuntu1)

Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-06-05
Changed in unity:
milestone: none → 5.14.0
Omer Akram (om26er) wrote :

@sil2100 could you also propose it to unity/5.0 series?

no longer affects: compiz (Ubuntu)
Changed in unity (Ubuntu Precise):
importance: Undecided → Low
status: New → Triaged
Omer Akram (om26er) on 2012-06-05
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Changed in unity (Ubuntu Precise):
status: Triaged → Fix Committed
description: updated
Changed in unity:
milestone: 5.14.0 → 6.0
Didier Roche (didrocks) on 2012-07-10
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.8 KiB)

This bug was fixed in the package unity - 6.0.0-0ubuntu1

---------------
unity (6.0.0-0ubuntu1) quantal-proposed; urgency=low

  [ Didier Roche ]
  * debian/rules, debian/control, debian/unity-autopilot.install:
    - install new unity-autopilot package, containing autopilot bindings and
      test for Unity
    - add some python build-dep for executing setup.py
    - use dh_python2 and add some python:Depends dep for automatic python
      version detection
  * debian/control:
    - remove gnome-desktop dependency: not needed upstream anymore
    - unity Breaks older lenses due to path change
    - remove libgdu in build-dep
  * debian/libunity-core-6.0-5.install, debian/libunity-core-6.0-dev.install,
    debian/control:
    - version bump in libunity-core, change soname

  [ Matthieu Baerts (matttbe) ]
  * Update apport hook for python3 ; thanks to Edward Donovan (LP: #1013171)

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - compiz crashed with SIGSEGV in get_current_slide() from
      unity::BGHash::OnSlideshowTransition() (LP: #889625)
    - Unity is visible on top of fullscreen apps (LP: #734908)
    - App icon on the Unity Launcher lost track of running instance
      (LP: #772063)
    - unity crashed with NameError in reset_unity_compiz_profile(): global
      name 'GError' is not defined (LP: #778470)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      [compizminimizedwindowhandler.h] from unity::UnityWindow::glPaint()
      (LP: #851982)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - [regression] Launcher is silent to screen reader users (LP: #949448)
    - still some accent issues with unity/nux (LP: #950740)
    - [regression] [precise] 3D apps run much slower under Unity (LP: #987304)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - Locked smuxi launcher icon does not indicate smuxi running status
      (LP: #999820)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - Much slower OpenGL frame rates with unityshell loaded, than plain compiz
      (LP: #988079)
    - Port to libudisks2 (LP: #1012000)
    - Desktop, Launcher and menu bar still visible when screen locked
      (LP: #886605)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dragged icons rendered under dash (LP: #1021541)
    - Regression in Launcher keyboard navigation (with Alt+F1) (LP: #1021549)
    - Unity dash is is much slower/laggy after revision 2469. (LP: #1021665)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - Dash - when a file is dragged from the Dash (Dash home, file lens, or
      music lens) and dropped on a Launcher icon, the Dash should
      automatically close (LP: #865168)
    - Refreshing active blur makes the dash painfully slow (LP: #874230)
    - Open dash, press Alt+f1 - dash remains open (LP: #919209)
    - application reopens itself when last instance is closed from
      windows/application switcher (LP: #926406)
    - HUD D...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Precise):
status: Fix Committed → In Progress

Hello Alan, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.14.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed

This doesn't seem fixed to me. I am ALT+`ing as fast as I possibly can, but still see the window pop up.

http://www.youtube.com/watch?v=gEwiUGMkKVk here's a video showing it still happening on both precise with proposed and on quantal.

Łukasz Zemczak (sil2100) wrote :

I tried reproducing the problem as mentioned by Alan, but could not reproduce. I also taped the behavior on my system but had problems uploading this to youtube currently.

Łukasz Zemczak (sil2100) wrote :

I also tried on my slower precise machine - cannot reproduce as well.

Miklos Juhasz (mjuhasz) wrote :

I tested it on 2 machines: not perfect, but better than before. If I am fast enough I can switch without flickering. It was always flickering before.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package unity - 5.14.0-0ubuntu1

---------------
unity (5.14.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Unity launcher shows internal partitions after they have been unmounted
      (LP: #994163)
    - can't click to dismiss hud in the area where dynamic hud results are
      meant to appear (LP: #962651)
    - Spread/Scale should exit if Dash is invoked (LP: #944033)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dash - The search bar gets the focus when pressing invalid keys
      (LP: #931393)
    - unity crashed with NameError in reset_unity_compiz_profile(): global name
      'GError' is not defined (LP: #778470)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      from unity::UnityWindow::glPaint() (LP: #851982)
    - "Keyboard Shortcuts" overlay can cause annoyance (LP: #934062)
    - padding between last quicklist item and bottom edge is non-deterministic
      (changes randomly) (LP: #955158)
    - HUD Draws improperly while searching for results (LP: #932531)
    - compiz crashed with SIGSEGV in
      unity::ui::KeyboardUtil::GetKeycodeAboveKeySymbol() (LP: #920258)
    - Launcher - when a user starts dragging a item, any folded launcher icons
      that are valid drop receptacles should unfold (LP: #839717)
    - Dragging image from firefox/chrome to dock causes lagg/freeze
      (LP: #772445)
    - dash should open when pressing "super" in scale mode (LP: #1023811)
    - Multimonitor, Launcher - When the Launcher is set to autohide and
      'Sticky edges' are turned off, 'Launcher Edge Stop Overcome Pressure'
      seems to be broken when revealing the Launcher (LP: #987955)
    - Software Center add to launcher icon animation is delayed when the
      launcher is in auto-hide mode (LP: #1012896)
    - Purchased items are not being added to the Unity launcher (LP: #925014)
    - Unity Launcher Fails To Auto-Hide When Enabled & Installing Commercial
      Software (LP: #1002440)
    - Regression: shift+click on a launcher icon to open a new application
      instance gone (LP: #754565)
    - Regression: Installing apps causes a terrible visual glitch-- have to
      restart X.org. (LP: #981168)
    - Duplicated applications icons on quick application restart (LP: #1003574)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - alt-backtick flickers between windows (LP: #987156)
    - [Hud] The result grid is not drawn in proximity of the search entry
      (LP: #1008603)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - [hud] The last button is not rounded (LP: #1008656)
    - Hud flickers when show up (LP: #1011507)
    - Dash maximise button changed location (LP: #987674)
    - launcher reordering "line" doesn't go to the bottom slot (LP: #971421)
    - Dash/HUD should close on "Spread" (LP: #870284)
    - Nothing should be written into the dash/hud searchbar whe...

Read more...

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
Sparhawk (sparhawkthesecond) wrote :

I just upgraded to unity 5.14, and I agree with most of the comments. The bug isn't fixed, really. It feels like it occurs less, perhaps, but still happens about half the time. I'm pressing alt-` pretty quickly. It doesn't feel like I'm hitting alt-` (much) slower on the occasions where I see the bug, so it could be random.

Sparhawk (sparhawkthesecond) wrote :

I'm going to change the tag from verification-done to verification-failed, since it seems that three out of four of us still see the bug.

Also, it seems that there's a major regression introduced with the latest Unity 5.14.0-0ubuntu1. If I press and hold alt-`, then release it (after a second, say), then the SAME (original) window is selected, and no switching occurs. The switcher preview is also strange. Let's call the top window A, and the second window B. Then, sometimes the switcher shows A selected at the top, sometimes it shows B selected at the top, and sometimes it shows B, then quickly swaps the position of A and B. Regardless of what the switcher shows, A is always selected. If the second option is shown (i.e. B at the top), I can repress ` to swap selection to the next window, and this also swaps the position of A and B, as per the third option.

tags: added: verification-failed
removed: verification-done
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers