Dash ignores custom background color setting

Reported by Dave Gorski on 2012-04-06
720
This bug affects 151 people
Affects Status Importance Assigned to Milestone
Unity
Low
Marco Biscaro
unity (Ubuntu)
Low
Marco Biscaro

Bug Description

After the latest update in the trunk, the option to have a custom background color for the dash and launcher is broken. No matter what color you select, it quickly reverts to the default chameleonic look when you open the dash.

Screenshot included: Notice the the selected green color in CCSM.

Related branches

lp:~marcobiscaro2112/unity/custom-bg
Merged into lp:unity at revision 2653
MC Return (community): Approve on 2012-09-03
Andrea Azzarone: Approve on 2012-09-01
Nick Dedekind: Approve on 2012-08-22
Daniel van Vugt: Pending requested 2012-09-03
Thomi Richards: Pending requested 2012-07-12
Omer Akram: Pending requested 2012-07-12
Dave Gorski (gorski-dave) wrote :
Hernando Torque (htorque) wrote :

It works until I click on the launcher bar or open the dash, then it reverts back to the wallpaper average.

Changed in unity:
status: New → Confirmed
thom (tsk) wrote :

indeed....and this behaviour is both in unity AND unity-2d

thom (tsk) wrote :

correction...only in 3D it is broken

Jobi Carter (keacarter) wrote :

Same issue.

VinDSL (perfect-pecker) wrote :

Me too...

In my case, I use a greenish wallpaper, and the "Launcher" and "Dash" take on an ugly greenish tint, once they are focused, regardless of which custom background color I choose.

Example: Let's say I choose "#000000" (black) as the custom background color, for the "Dash". When I boot, the background is black initially, but quickly changes to a greenish tint, once it focuses on the desktop.

No amount of tinkering with MyUnity, CCSM, Ubuntu-Tweak, et cetera, changes this.

Jason Kern (jaskerx) wrote :

Would love the ability to turn this chameleonic effect off, don't feel like editing the middle pixel of all my wallpapers so my dash stays the same color.

Doug McMahon (mc3man) wrote :

Really a shame that this break in 5.10 isn't targeted for SR0, especially considering how minor some of the bugs that are

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
ngsupb (ngsupb) wrote :

had to set the wallpaper to some black one. Please fix this issue.

l_uke (l-uke) wrote :

Please fix this, it's really annoying!

Changed in unity:
assignee: nobody → Varga-Dudás Gergő (vargadgergo)
assignee: Varga-Dudás Gergő (vargadgergo) → nobody
Michael (amemain) wrote :

I agree, this is driving me nuts. I want a plain jane semi transparent launcher without color.

Bathroom Humor (bafroomhumor) wrote :

This is one of those things new users are going to notice if they ever learn about CCSM/myunity/ubuntu tweak etc. It's a very obvious bug. I hope somebody will pick it up soon. Luckily i have a dark background but if it were brighter or closer to pink, I would be annoyed.

Mario (mdjmario13) wrote :

I have the same problem D;

macstevejb (macstevejb) wrote :

Indeed, I have the same problem here, the only real solution for now seems to be to choose a wallpaper that is dark in the middle.
A really annoying bug for those of us who like to tweak the appearance of our desktops!

Ryan G (rtgkid) wrote :

This bug affects me, as I have marked. VERY annoying. Could someone at Canonical or an Ubuntu team please fix this ASAP? Thanks!

This bug affects me and I don't think the chamaleonic effect it's a good decision. It breaks the theme because only SOME of the elements are affected by the colour, but not all (window borders, menus, etc). Also, I don't think it's a good idea to prevent the user to choose the colour that they like.

affects: ubuntu → unity (Ubuntu)
Changed in unity:
assignee: nobody → Marco Biscaro (marcobiscaro2112)
Changed in unity (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Marco Biscaro (marcobiscaro2112)
Changed in unity:
status: Confirmed → In Progress
Chris E (ublinx) wrote :

This affect me also and i'm also think that this chameleonic effect is very ugly and now even obtrusively.
Pleeease somebody fix it.. Thanks!

This bug appears to be solved with the proposed update to unity (5.12-0ubuntu1.1). I can now change background color with MyUnity and Compiz Config Manager.

Sebastien Bacher (seb128) wrote :

weird, the merge request listed there is still waiting for review, I will keep the bug open until it's reviewed

Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
importance: Undecided → Low

@nicocarbone: are you sure this is fixed? I proposed a fix (https://code.launchpad.net/~marcobiscaro2112/unity/custom-bg/+merge/105370), but it is not merged with the official repository yet.

@marcobiscaro2112: It is working for me. I am using a different color from the one unity chooses for my background.

I installed from proposed unity 5.12 -0ubuntu1.1 to test the fix for bug #987304, and bamfdaemon and libbamf version 0.2.118-0ubuntu0.1 to test if they fixed bug #1002874, and found that they (i guess it was only unity) fixed this problem too. Maybe someone else should try if this solves the problem for them too before closing this bug.

the fix works, however, everytime you change your wallpaper, opening the dash will override the compiz setting, and you have to change the colour to make it work again.

Doug McMahon (mc3man) wrote :

the 5.12 -0ubuntu1.1 & 5.12 -0ubuntu2 (12.10) packages do both return the ability to set a custom color.
What they Do Not do is allow the use of #000000 which Marco's patch does fix.
Bug 924586
 The ability to use #000000 should be considered as important as being able to set a custom color, it allows users to opt out of the chameleon effect & is useful for users who enable "no blur" but want to darken the Dash

I've tested Marco's patch on both 5.12 -0ubuntu1.1 & 5.12 -0ubuntu2, #000000 is use-able & have noticed no conflict with whatever changed in those packages & or bamfdaemon, ect.

Whether Marco needs to adjust his patch to just address Bug 924586 he would now, hopefully that bug will not lanquish with this one 'inadvertently' being resolved

Em 25-05-2012 14:44, Martin-haesler escreveu:
> the fix works, however, everytime you change your wallpaper, opening the
> dash will override the compiz setting, and you have to change the colour
> to make it work again.
>
With the fix I proposed, this doesn't happen. The selected color is
persistent, even if you open the dash or change the background.

@Marco Bisaro Sorry, I was talking about the ubuntu-proposed update today.
@ Doug McNahom If you use #010101 as black, you get a black dash, in a wonderfully non transparent way.

Terry Gordon (terryg) wrote :

how can i apply Marco Biscaro's fix, this is an issue i would like to resolve.

monte (monte2) wrote :

now on 5.12 I can change luncher color and it stays while current session is running. But after reboot i have chameleon color back and have to change it manually through ccsm or myunity. Does everyone have the same issue?

summary: - Custom background color option broken
+ Dash ignores custom background color setting
Raimis (raimef) wrote :

@monte, yes me to.

monte (monte2) wrote :

now i discovered more weird behavior of unity's color. it still ignores custom color most time, but on abot 1 of 5 boot-ups it gets color that i've chosen. but even so, notification is chameleonic.
looking forward to see this bug fixed.

Changed in unity:
milestone: none → 6.2
Matt Miller (spam2000) wrote :

I am on Ubuntu 12.04 and the unity chameleon effect always seems to pick some awful looking color. I would like to go to gray, but the tweak tool does not work for me either. After making an update with the tweak tool, it just reverts back to chameleon within a minute or two.

s1ck (martin-junghanns) wrote :

same here

Didier Roche (didrocks) on 2012-08-10
Changed in unity:
milestone: 6.2 → 6.4
Changed in unity:
milestone: 6.4 → 6.6
Changed in unity:
status: In Progress → Fix Committed
Omer Akram (om26er) on 2012-09-14
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity:
milestone: 6.6 → 7.0
Omer Akram (om26er) on 2012-09-20
no longer affects: unity/6.0
Changed in unity:
milestone: 7.0 → 6.6
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 6.6.0-0ubuntu1

---------------
unity (6.6.0-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release.
    - Fixes non-escaped character sequences in dash previews (LP: #1039020)
    - Updated background layer for preview cover-art and details panels
      to be 10% low-light
    - Expand a PlacesGroup if it is the only category that contains results
      (LP: #950710)
    - Update unity autopilot tests to match autopilot API
    - Updated the convert files to fix some typos in the key names
    - Add gmodule dependency
    - Activate proper result if the categories aren't displayed in-order
      (LP: #1040101)
    - Refactor device launcher icons (LP: #713423)
    - LauncherController: make the controller enable the launcher struts,
      based on hide-mode option (LP: #1044005)
    - Launcher: make always possible to drag an icon to the bottom or top
      of its sub list (LP: #1043968)
    - Don't desat bfb/hud icon in DNDReset (LP: #1043963)
    - Progressively adjust the speed of the minimize animation. First
      time it is used is slower, then speeds up the more it is used.
      (LP: #1017510)
    - Implement new ordering of categories for home lens. (LP: #1043915)
    - UnityWindow now implements ScaleWindowInterface (LP: #876017)
    - Launcher: restore an icon position after that the dragging has been
      cancelled (LP: #955561)
    - LauncherDragWindow: cancel drag on window mapped/unmapped
      (LP: #1044723)
    - Now there is a check of an override color in RefreshColor (which is
      called when a PropertyNotify event happens). Also added a check in
      FullySaturateColor to a void division by zero. (LP: #975350)
    - Queue redraw after cover-art texture is updated from a url/file source.
      (LP: #1043947)
    - Fixed ability to delete glib::Source wrapper during its callback
      (LP: #1044823)
    - Close preview when dash is hidden. (LP: #1045298)
    - LauncherModel: rewrite the Reordering functions to keep the icon
      priority deltas (LP: #761155)
    - Make sure we can pass extra hints when activating preview actions.
      (LP: #1046352)
    - UnityWindow: scale window code improved (LP: #1033935)
    - The mouse will now cause the HUD buttons to change selection
      (LP: #1042692)
    - "Alt+Space" shortcut to reveal the window menu is not hardcoded, but a
       Compiz key option. " (Hold)" should also be translated. Made all
       Compiz plug-in names and all Compiz plug-in option names in
       unityshell.cpp static constants.
    - remove unity --reset, it's not anymore really needed now that we are
      in stable days of unity and we moved to gsettings
    - Removed the variables 'oldPrev' and 'oldNext' which got assigned the
      value NULL, but then were never used
    - Fixed the size of the previews to 770x380 pixels. (LP: #1045243)
    - UnityWindow: use smart pointers, use static close_icon (with dynamic
      state) and PanelStyle context (LP: #1033935) (LP: #1045127)
      (LP: #1046124) (LP: #1046126)
    - Remove everything in the #ifndef USE_MODERN_COMPIZ_GL ifdefs and remove
      the ifdefs alltogether. unity now requires compiz...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
tekstr1der (tekstr1der) wrote :

This bug is not fixed in the current release - 12.04.1.

With the color set via MyUnity, the launcher/dash color reverts to chameleon upon changing of the background image.

Someone who is able to mark this as affecting the current series - Ubuntu (Precise) - please do so. Otherwise this bug will be ignored due to its upstream/trunk "Fix Released" status. Launchpad has become very frustrating.

Nekhelesh Ramananthan (nik90) wrote :

tekstr1der, please create a new bug report stating the issue. I face the same issue. However, this current bug report is only if the dash automatically reverts the setting. While for both of us, it only reverts when the wallpaper is changed.

tekstr1der (tekstr1der) wrote :

@Nekhelesh: I've reported the continuation of this as Bug #1062661

Lorem (lrmpsm) wrote :

Furthermore, this fix is useless even on Ubuntu 12.10 because notify-osd uses chameleon color too

See the attachment below

This bug was fixed on quantal, and it's not eligible to be SRU'ed[1] to precise. About the notify-osd color, you can start a discussion in the unity-design mailing list.

[1] https://wiki.ubuntu.com/StableReleaseUpdates#When

Mo (morasu12) wrote :

The launcher color always changes after I log out or shut down.

Doug McMahon (mc3man) wrote :

The idea that this shouldn't/can't be SRU'ed into 12.04 is too bad & hard to understand based on -

The bug started in 12.04 & a component of was noted & bug confirmed in late Jan. during 12.04 leaving plenty of time to fix in 12.04. (unfortunately wasn't
The fix is simple & has shown no signs of any regressive behavior in any number of 12.04 test installs here starting in 02/12 & inc. a new 12.04.2 install.
In the companion bug to this, the fix has been nominated for precise (no action on) & remains 'triaged' for 12.04/unity5
Bug 924586

Manuel Tondeur (sinekonata) wrote :

So if I have 12.04.2 that I freshly installed this won't be fixed? How do I get it then? Was it released as a package or some source that I can download? if it is simple to modify as Doug says, can I do it myself?

I'm sick of it, ever since 11.10 I have a dark wallpaper and it's really annoying...

Stephen M. Webb (bregma) wrote :

> So if I have 12.04.2 that I freshly installed this won't be fixed?

Correct. The bug fix did not qualify to be included in Ubuntu 12.04 because it was reported after the release freeze and the fix not proposed until several months after 12.04 was released. The fix was included in the next release of Ubuntu (12.10) and is also included in the cirrent Ubuntu release (13.04).

It's still possible the bug fix would be accepted as a stable release update (SRU) for 12.04.03 if someone in the community (you!) were to backport the fix to Unity 5 and propose it for acceptance. There's a chance the SRU could still be rejected, but see https://wiki.ubuntu.com/StableReleaseUpdates for more information.

Doug McMahon (mc3man) wrote :

Don't know much about the SRU process, someone will have to take care of, (or not
attached is a debdiff if that helps process along

Also put up a ppa for those wishing to test to fix applied to 12.04
https://launchpad.net/~mc3man/+archive/color-fix

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions