Opening dash while an application is maximized makes unity completely useless, have to relogin

Bug #975103 reported by Omer Akram on 2012-04-06
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

bzr2245
VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller

1. login to unity start an application and maximize it
2. open the Dash

Now you can neither start any application nor will any menu open on the panel. the dash would just blink and the launcher tooltips dont redraw.

This started with bzr2237 before that Unity would just crash on this GPU when BFB was clicked. progress ;-)

Related branches

Didier Roche (didrocks) wrote :

on my nvidia machine:
01:00.0 VGA compatible controller: NVIDIA Corporation G71 [GeForce Go 7900 GS] (rev a1)

The issue given by commit rev 2237 was different (with a maximized application):
- the whole screen would turn black (I can sometimes see artifacts of the maximized windows), but globally, everything black apart from the launcher and the panel.

Reverting the commit fixed it.

Jay Taoko (jaytaoko) wrote :

bzr 2237 did not cause this problem. This issue is causes by other factors.

Omer Akram (om26er) wrote :

as I said "before that Unity would just crash on this GPU when BFB was clicked."

Omer Akram (om26er) wrote :

see bug 975291 for the crash.

Changed in unity:
assignee: Jay Taoko (jaytaoko) → nobody
status: Confirmed → Fix Committed
Jay Taoko (jaytaoko) wrote :

The branch linked above will address the usability issue when opening the dash on system that have no glsl support.
There remain an issue with the dash/launcher blur effect that needs to be addressed.

Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers