compiz crashed with SIGSEV in g_type_check_instance_is_a from unity::launcher::DeviceLauncherIcon::ShowNotification

Bug #971345 reported by Martin Mrazik on 2012-04-02
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Andrea Azzarone
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I'm reporting against Unity because I'm using staging PPA and ubuntu-bug is unwilling to report compiz bug from a "3rd party" repo.

I'll try to reproduce this later but it happened while I was trying to safely remove a USB stick bug drag and dropping the (USB stick) icon from launcher to trash.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.8.0+bzr2205ubuntu0+677 [origin: LP-PPA-unity-team-staging]
ProcVersionSignature: Ubuntu 3.2.0-21.34-generic-pae 3.2.13
Uname: Linux 3.2.0-21-generic-pae i686
.tmp.unity.support.test.0:

ApportVersion: 2.0-0ubuntu2
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
CrashDB: unity
Date: Mon Apr 2 10:03:21 2012
DistUpgraded: 2012-02-17 16:11:17,070 DEBUG The following packages are marked for removal: libcdio10 libunity6 libindicator6 libgdata1.7-cil libapt-pkg4.11 libicu44 linux-headers-3.0.0-12 libgtkspell3-0 libdns69 libminiupnpc5 libnux-1.0-0 libpoppler13 libisccc60 liblzma2 libgssdp-1.0-2 libnux-1.0-common libcdio-cdda0 libhunspell-1.2-0 liblwres60 gir1.2-dee-0.5 libbind9-60 libdee-1.0-1 linux-headers-3.0.0-12-generic libexiv2-10 libcdio-paranoia0 libisccfg62 libgupnp-1.0-3 libnl3 libapt-inst1.3 libindicator3-6 libisc62 libnautilus-extension1 libgupnp-igd-1.0-3 libpoppler-glib6
DistroCodename: precise
DistroVariant: ubuntu
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
MachineType: LENOVO 4178BSG
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-21-generic-pae root=UUID=4f16b282-59de-4923-aebf-3a8f0fcef5d9 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-02-17 (44 days ago)
dmi.bios.date: 07/29/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 83ET63WW (1.33 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4178BSG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr83ET63WW(1.33):bd07/29/2011:svnLENOVO:pn4178BSG:pvrThinkPadT420:rvnLENOVO:rn4178BSG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4178BSG
dmi.product.version: ThinkPad T420
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.7.4-0ubuntu1~ppa1
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu8
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Related branches

Martin Mrazik (mrazik) wrote :
Omer Akram (om26er) on 2012-04-02
Changed in unity:
importance: Undecided → High
assignee: nobody → Andrea Azzarone (andyrock)
milestone: none → 5.10.0
Omer Akram (om26er) on 2012-04-02
Changed in unity:
status: New → Confirmed
Andrea Azzarone (azzar1) on 2012-04-02
Changed in unity:
status: Confirmed → In Progress
Andrea Azzarone (azzar1) on 2012-04-04
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.