ALT+Tab in keynav mode brings up HUD

Bug #971097 reported by Alan Pope 🍺🐧🐱 🦄 on 2012-04-01
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Łukasz Zemczak
unity (Ubuntu)
Medium
Unassigned

Bug Description

Test Alt+F1 KeyNavMode Shortcuts
-----------------------------
This test shows that all the shortcuts work and also exits from keynav mode.

1. Press Alt+F1 to enter keynav mode
2. Press Super + a
3. Press Esc
4. Press Alt+F1
5. Press Alt + Tab <---- this bit fails
6. Press Alt+F1
7. Press Ctrl + Alt + t

Outcome
  The first shortcut opens the dash app lens, which it should open it and quit the
  nav mode. The second shortcut switches between applications. The last one will open
  a new terminal. This is to show all SUPER, ALT, and CTRL shortcuts work; while
  closing the keynav mode.

-------

Step 5 fails. I get HUD instead of alt-tabbing. Here's a video showing it.

http://www.youtube.com/watch?v=zVci878FZTA

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.8.0+bzr2201ubuntu0+677 [origin: LP-PPA-unity-team-staging]
Uname: Linux 3.3.0-030300rc5-generic x86_64
ApportVersion: 2.0-0ubuntu2
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CrashDB: unity
Date: Sun Apr 1 22:14:42 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120203)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Omer Akram (om26er) on 2012-04-02
Changed in unity:
importance: Undecided → Medium
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Łukasz Zemczak (sil2100) wrote :

For me the Alt + Tab step normally exits the keynav mode, HUD only appears when I do a really fast Alt + Tab tap. But that's probably what Alan has in mind.

tags: added: 5.10-pretesting1
Sebastien Bacher (seb128) wrote :

is that still an issue?

Sebastien Bacher (seb128) wrote :

seems it is...

Changed in unity (Ubuntu):
status: Confirmed → Triaged

Yeah, still does it here on two separate machines.

Still broken on ppa:unity-team/release. Also brings up HUD when doing ALT+`

I can confirm this not working with trunk unity.

Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity:
assignee: Brandon Schaefer (brandontschaefer) → Łukasz Zemczak (sil2100)
status: Confirmed → In Progress
tags: added: 1210b1blockers
Łukasz Zemczak (sil2100) wrote :

Not really a 1210b1blocker, as it is not a regression - it's something we know about well.

tags: removed: 1210b1blockers
Changed in unity (Ubuntu):
status: Triaged → Fix Released
Changed in unity:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers