Application launch time increased with type-to-search in unity 5.8

Reported by Alexander Nyrkov on 2012-03-27
78
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Unity
High
Michal Hruby
unity (Ubuntu)
High
Michal Hruby

Bug Description

After upgrade from unity 5.6 to unity 5.8 I've noticed a certain regression in the user experience when launching an app with the type-to-search dash feature from the Home lens.

Behavior in 5.6:
It allows me to launch an app with the return key as soon as the first search result recieved, e.g. I type 'ge' and immediately hit return, gedit launches though there're some search results left that could be displayed if I would wait a bit longer

Behavior in 5.8:
I have to wait until all search results are displayed before I can launch an app, e.g. I type 'ge', immediately hit return and nothing happens until dash displays all the search results it got.
This makes a user wait for a second or several seconds before he can get the application running although he already got the desired search result with the first couple of typed letters.

Maybe there is a reason for this behavior change but it feels like a usability regression.

Related branches

lp:~mhr3/unity/fix-966417
Merged into lp:unity at revision 2206
Gord Allott (community): Approve on 2012-04-02
Thomi Richards: Needs Fixing on 2012-04-02
description: updated
Omer Akram (om26er) wrote :

assigned to Michal please re-assign if that feels wrong.

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
assignee: nobody → Michal Hruby (mhr3)
milestone: none → 5.10.0
Michal Hruby (mhr3) on 2012-03-30
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Confirmed
Omer Akram (om26er) on 2012-04-01
Changed in unity (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Michal Hruby (mhr3)
Changed in unity:
status: In Progress → Fix Committed
Omer Akram (om26er) on 2012-04-02
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
tags: added: 5.10-pretesting1
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Alexander Nyrkov (nyrkovalex) wrote :

Thank you for your great job!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers